www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ELEKTOR 80C535-Board


Autor: JensK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich habe ein Compuboard80535 bekommen, aus Elektor Jahrgang '94.
Leider habe ich keinerlei Unterlagen zu dem Board, auf dem der EMON52
(Elektor Monitor) in der Version 0.1 läuft. Mir fehlen also sowohl die
Befehle des Monitors als auch Jumperfunktionen, Speichermap etc.
Aufgrund mangelnder Unterlagen habe ich mir die Befehle des Monitors
nun aus den Fingern gesaugt und dabei auch rausbekommen, dass der Mon
Intel-Hex frisst. Das Board funktioniert nun soweit prima, auch der
Anschluss an das Hyperterm klappt.

Mein Problem: Ich kann keinen Speicher modifizieren, weder ueber
IntelHex-Load noch ueber den Monitorbefehl dazu.

Hat jemand zufaellig noch Unterlagen zu diesem Board? Oder kann mir
sonst irgendwie helfen? Ich will noch anmerken, dass ich Intel-Newbie
bin und ansonsten nur die Motorola-Schiene (CPU32, 68HC11) gefahren
bin.

Danke im voraus,
Jens

Autor: Eddi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jens

Da ich auch noch 1,5 von den Boards hier rumliegen habe, habe ich noch
das original Elektor-Heft von damals. Ich kann das mal einscannen und
Dir zuschicken (ich hoffe, daß gibt keinen Ärger wg. copyright).

Gruß
Eddi

Autor: buz11 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt was ähnliches auf www.goblack.de    .
Lohnt sich mal anzuschauen .

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und wenn du dann noch Fragen hast, ich hab hier ein ganzes, 300 Seiten
starkes Buch von Elektor zu diesem Board rumliegen. Und vor etwa 5
Jahren hatt ich das Board auch schonmal am laufen :)

Mike

Autor: JensK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ersteinmal vielen Dank an Euch fuer die schnelle und kompetente Hilfe!


Mit der jetzigen Ausstattung war es mir moeglich, mal mit dem Scope
naeher zu schauen. Und siehe da, ich leide noch nicht ganz so unter
Demenz wie ich dachte. Dass ich keinen Speicher modifizieren konnte lag
schlicht und ergreifend an einem Hardwareproblem. Am Sockel des 80C535
war der Pin fuer das Write-Signal zu weit zurueckgebogen, so dass das
Signal draussen auf dem Board nicht ankam. Da der Pin in der Ecke des
Sockels liegt denke ich, dass evtl. der Controller beim Eindruecken in
die Fassung verkantet wurde und damit der Sockel Schaden erlitten hat.
Aber egal, jetzt laeuft das Board wie geschmiert, und ich kann mich
endlich den eigentlichen Aufgaben widmen.

Nochmal vielen Dank an Euch,

Jens

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.