www.mikrocontroller.net

Forum: PC Hard- und Software Eigenes Bauteil in Agilent ADS 2008, Fehler "undefined model"


Autor: Student auf Kaffeentzug (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Ich hatte mich bisher immer davor gedrückt eigene Bauteile in ADS zu 
erstellen aufgrund negativer Erfahrungen mit PSpice.

Nun habe ich hier z.B. das Modell eines normalen Feldeffekttransistors 
als Design (.dsn).
(Möchte mir einen Boost-Converter basteln um meinen kleinen Wecker mit 
einer einzelnen Solarzelle und Goldcap zu betreiben, und ggf. später 
noch andere Sachen)

Ich habe entsprechende Ports (Gate, Drain, Source, Temperatur) 
hinzugefügt.
Mit 'View' -> 'Create/Edit Schematic Symbol' habe ich ein ensprechendes 
Symbol mit den Pins erstellt und kann nun dieses Bauteil auch in der 
Bibliothek auswählen und in meine Schaltpläne setzen. (Hatte die 
Anleitung dazu ich irgendwo im Netz gefunden)

Bei jeder Simulation (z.B. Transient) erscheint folgende Fehlermeldung:
'X2' is an instance of an undefined model '2n7000_export_symbol'

Die selbe Fehlermeldung erscheint auch wenn ich von diesem Mosfet eine 
der vielen SPICE-Netzlisten aus dem Internet als Bauteil einlese, dieses 
aus der Bibliothek platziere und simulieren möchte.

Wie kann das Modell 'undefined' sein wenn doch alle Informationen 
vorhanden sind?
(Inklusive des korrekten Pfads der Modellnetzliste des Bauteils in der 
Bauteilbibliothek)
Alles Funktioniert bis zu diesem Punkt super.
Selbst wenn ich das Modell direkt simuliere klappt das auf Anhieb.

Muss ich irgendwo noch sowas wie ein extra "include sowieso" platzieren? 
:-)

Ich hoffe jemand kann mir einen kleinen Tip geben,
so langsam gehen mir die Ideen aus und Die ADS-Hilfe und Google bringen 
mich nach zwei
Tagen auch nicht mehr weiter...

Mit S-Parameterblöcken hatte ich solche Probleme bisher nicht. ;-)
Und einfach drauf losbasteln wollte ich diesmal eigentlich nicht...

Im Anhang findet ihr eine normale Astabile Kippstufe mit dem FET und das 
dazugehörige Modell des FET als .dsn-Datei.

Gruß, Lars

Autor: Student auf Kaffeentzug (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Hat sich erledigt, hab einfach nochmal alles abgegrast was zu finden 
war.
Hier: 
http://www.coe.montana.edu/ee/lameres/courses/ee46...
Unter "Part 6: Using Subcircuits" findet man die Lösung, falls jemand 
mal vor dem selben Problem stehen sollte.
Ist doch ein klein wenig aufwendiger. :-)

Gruß

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.