www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Welcher MOSFET für Motoransteuerung


Autor: Christof Kauba (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich hab ein kleines Problem.
Und zwar mchte ich einen Gleichstrommotor per PWM drehzahlsteuerbar 
machen.
Jetzt habe ich mir eine kleine Schaltung mit einem ATTiny45 gebaut und 
getestet. Zur Ansteuerung habe ich zuerst einen BUZ11A verwendet. Mit 
dem Effekt, dass der Motor anlief, als ich ihn ausschalten wollte aber 
einfach weiter lief -> MOSFET war defekt.

Ich habs dann mal ohne meine Schaltung nur mit dem MOSFET als Schalter 
probiert, selbes Ergebnis. Freilaufdiode hab ich natürlich drin.
Ich hab auch schon einen IRF1010N und einen IRLZ34N probiert, mit dem 
selben Ergebnis.

Zur Info: Der Motor wird versorgt mit 24V Gleichspannung von 2 
Bleiakkus. Er benötigt im Betrieb so zwischen 5 und 7 A, beim Anfahren 
kurzzeitig so zwischen 10 und 15A.

Was für einen Transistor sollte ich für diese Aufgabe verwenden? Oder 
muss ich noch eine Zusatzschaltung anbringen, damit die MOSFETs nicht 
immer kaputt gehen?

Danke im Voraus
Chris

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Chris,

das Problem wird sein, dass der Motor nicht nur "so 10-15A" sondern 
evtl. auch mal für ein paar 100ms ein Vielfaches davon aufnimmt.

Versuch es mal mit: http://www.datasheetarchive.com/search.php?q=BTS282

Gruss Otto

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also der IRLZ34N ist definitiv dafür geeignet.

Ich bin der Meinung, dass es an deiner Schaltung liegen muss.

Deine Fehlerbeschreibung deutet startk auf das FFehlen der Freilaufdiode 
hin. EIn thermischen Defekt schließe ich aus.

Poste mal die Schaltung!

Autor: Christof Kauba (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja ich hab zur Sicherheit eine Freilaufdiode parallel zum Transistor, 
und eine parallel zum Motor.
Es handelt sich jeweils um eine MUR8100E, die lt. Datenblatt 16A/1000V 
aushält.
Also ich denke mal an den Freilaufdioden sollte es nicht liegen.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zeig mal den Schaltplan und mach ein Foto vom Aufbau.
Der IRF1010 sollte selbst >100A kurzzeitig können.
Ich tippe fast auf eine zu langsame Ansteuerung, so dass er kurzzeitig 
zu viel Wärme produziert.

Autor: Christof Kauba (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe es jetzt ja testweise mal so aufgebaut, dass ich meine PWM 
Schaltung entfernt habe und den Transistor nur als reinen Schalter, also 
mit Taster verwendet habe. Dabei tritt dann wie oben schon beschrieben 
genau der gleiche Effekt auf.
Was meinst du mit zu langsamer Ansteuerung? Die PWM Frequenz selbst oder 
meinst du dass die Spannung nicht schnell genug von 0 auf 5V und 
umgekehrt geht?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
5V am Gate reichen nicht. 8V würde ich den Mosfet bei diesen Strömen 
mindestens geben.

Autor: avion23 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was sagt der Mosfet denn zu 24V am Gate?


D7 ist verkehrt falschrum.

Autor: Christof Kauba (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK. Glaubst du, dass es daran liegen könnte? Dann werde ich mal 
zusätzlich einen BPT einbauen, und das Gate dann auf 12V legen. Dadurch 
wird aber dann natürlich die Schaltung langsamer, da ja der BPT auch 
Zeit zum Umschalten braucht.
Kann ich da einen normalen BC547 verwenden?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Am besten machst du die Gateansteuerung so wie hier (ohne den 
Optokoppler, nur Q1, Q2, D3, R3, R4):
http://www.roboterwiki.de/index.php/Mumptai%27s_H-...
http://ichlebe.aufdemmond.de/calle/h-bridge/h-brid...

Autor: Christof Kauba (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK gut dann werde ich das mal so probieren, Danke schonmal!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.