www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Drehsensorsignal eines Lüfters am digitalen Eingang einer S7 funktioniert nicht


Autor: Dieter (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte das Drehsensorsignal eines Lüfters mit einer digitalen 
Eingangskarte einer S7 einlesen.
Im Anhang ist ein Anschlussbild vom Sensorsignal zu sehen.

Jetzt habe ich aber das Problem, dass ich das Sensorsignal nicht ohne 
Weiteres an den DI der S7 anschließen kann, da der Pull-Up-Widerstand 
größer ist als der innere Widerstand des digitalen Eingangs. Wenn ich 
das so anschließe, liegen an der S7-Karte nur ein paar Volt an, mind. 
11V sollten es schon sein (optimal: 24V).

Daten vom digitalen Eingang der S7-Karte:
Eingangsstrom bei "1": typ. 6,5mA
Eingangsspannung "0": -3 bis 5Vdc
Eingangsspannung "1": 11 bis 30Vdc bzw. 18 bis 30Vdc
Eingangsspannung Nennwert: 24Vdc

Mir fällt im Moment nicht ein, wie man hinter den Open-Collector einen 
weiteren Transistor verschalten muss, damit dieser eine optimale 
Eingangsspannung von 24V für den digitalen Eingang bereit stellt.
Vielleicht könnte mir jemand behilflich sein?! Wäre super!

Vielen Dank schonmal,
Dieter

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

Wenn’s kommerziell sein soll, helfen Pegelwandler. Diese gibt es dann 
auch im passenden Hutschienengehäuse. Beachte aber die Anzahl Impulse 
des Lüfters und die Zykluszeit der S7, eventuell wird noch ein Teiler 
benötigt.

MfG

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vergiss den PullUp.

Rot an 24V
Weiß an DI/S7
Schwarz an Masse.

Schließ aber bitte auch die Versorgungsspannung der DI-Eingänge der S7 
an +24V und Masse.

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo.

> Beachte aber die Anzahl Impulse
> des Lüfters und die Zykluszeit der S7
Ich habe eine spezielle Eingangskarte für Frequenzen, die ich schon 
parametriert habe. Mit einem normalen DI geht sowas nicht, da dafür die 
Zykluszeit der S7 zu "groß" ist.

> vergiss den PullUp.
Daran habe ich auch schon gedacht, aber dann halte ich doch die max. 5mA 
für den Transistor nicht mehr ein?! Das ist doch bestimmt schädlich...
Momentan greife ich das Signal zwischen Pull-Up und Kollektor ab.

> Rot an 24V
> Weiß an DI/S7
> Schwarz an Masse.
Soweit hab ich es auch bis jetzt, nur, dass ich "Weiß" mit 24V extern 
versorgen muss und noch der Pull-Up dazwischen hängt.

> Schließ aber bitte auch die Versorgungsspannung der DI-Eingänge der S7
> an +24V und Masse.
Na logo! Ist doch schon so geschehen.

Die 24V für Lüfter, Sensorsignal und SPS kommen von ein und demselben 
Netzteil.

Ich dachte immer, bei so einer Schaltung mit Open-Collektor brauche ich 
einen Pull-Up, damit "logische Signale" entstehen.
Im Anschlussbild ist es ja auch so gezeichnet.

Gruß,
Dieter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.