www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit 74141 Treiber IC Nixie ZM1336


Autor: Christian Betzen (chris001)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Alle!

Ich hab da ein Problem mit meiner Nixie Uhr. Die Uhr hat Siemens ZM 1336 
Röhren die über 74141 Treiber angesteuert werden. Die Eingänge der 
Treiber IC liegen über einen Widerstand 3,3k nach + 5V. Die Röhren 
werden mit 170V über einen Widerstand 8,2k angeschlossen. Wenn ich jetzt 
an den Treiber ICs kein Signal anlege werden die Röhren ja dunkel 
geschaltet.
Leider aber nicht ganz. Wenn ich das Licht im Zimmer aus mache, leuchten 
die Nixies noch etwas.

Jetzt zu meiner Frage: Wie bekomme ich die Röhren ganz aus?

Ich hab mal eine Röhre mit 150MOhm von +170V auf die einzelnen Kathoden 
geschaltet was auch was gebracht hat. Die Röhre ist dann ganz dunkel. 
Schalte ich jetzt Signale auf die Treiber ICs verzögert sich das 
einschalten dieser Röhre etwas.

Sind die 150MOhm zu klein? Oder der Vorwiderstand zu groß?

Danke schon mal für alle Antworten!

Schö mit Ö….


Christian

Autor: Johann L. (gjlayde) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Legst du zum Ausschalten die Eingänge der Treiber auf 0? Ich  mach das 
so, daß ich am Eingang nen Code > 9 anlege (74141 + ZM1210).

Die Tabelle mit den BCD-Werten ist oben rechts, die Röhren sitzen an 
X12, X34, X56 (Kathoden) und XA (Anoden).

Johann

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Hilfsspannung mit 50V erzeugen (muß kleiner als 60V sein wegen der 74141 
und so groß, daß die Differenz zur Anodenspannung unter der 
Brennspannung liegt). Von dort über jeweils 50...100k an jede Anode.

Uce der Ausgangstransistoren läßt nur 60V zu, der Reststrom steigt aber 
dann gern so an, daß die Elektrode schon erkennbar glimmt.

Ist einen Versuch wert, hat bei mir früher zumindest so funktioniert.

Gruß aus Berlin
Michael

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Christian Betzen schrieb:
> werden mit 170V über einen Widerstand 8,2k angeschlossen. Wenn ich jetzt
> an den Treiber ICs kein Signal anlege werden die Röhren ja dunkel
> geschaltet.

Die Chips sind so ausgelegt, daß immer eine Ziffer leuchten muß, 
ansonsten kann der Chip sterben.
Die maximale Sperrspannung ist ja nur 60V, daher muß immer ein Segment 
die Anodenspannung auf die Brennspannung herabziehen.


> Ich hab mal eine Röhre mit 150MOhm von +170V auf die einzelnen Kathoden
> geschaltet was auch was gebracht hat. Die Röhre ist dann ganz dunkel.
> Schalte ich jetzt Signale auf die Treiber ICs verzögert sich das
> einschalten dieser Röhre etwas.

Diese Zeit wird wohl die sein, die die Treibertransistoren brauchen, um 
sich von der Überlast zu erholen, d.h. wieder genügend hochohmig zu 
werden.
Ich sehe da schwarz für Deine ICs, lange werden die wohl nicht mehr 
leben.


Wenn Du dunkeltasten willst, mußt Du Treibertransitoren mit >=200V 
Sperrspannung verwenden.


Peter

Autor: Christian Betzen (chris001)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich steh da jetzt aufm Schlauch!

Ja! Ich könnte die Anode mit nem Transistor an und aus schalten. Aber in 
dem Datenblatt von dem 74141 steht das man mit nem BCD Code über 9 die 
Anzeige dunkel tasten kann.
Weil das auch vom Aufwand einfacher wäre, wollte ich es erst mal so 
versuchen.

Also soll ich die Widerstände zwischen den +170V und den einzelnen 
Kathoden kleiner auslegen? Der Strom den das IC dann schalten muss wird 
aber immer größer dann!:-(((

Schö mit Ö…


Christian

Autor: Tubie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sind das Original 74141 oder die Russischen Ersatz Typen? Bei Mir 
funktionierte das Dunkeltasten damals wunderbar mit dem Original. Mit 
dem heute noch verfügbarem Nachfolger funzt das aber leider nicht mehr. 
Es glimmen alle Segmente vor sich hin.

Kann aber auch zufall sein, das die damals alle dunkel waren. Es war 
eine 6-Stellige Anzeige.

Gruß,
Tubie

Autor: Wolf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Aber in dem Datenblatt von dem 74141 steht das man
 > mit nem BCD Code über 9 die Anzeige dunkel tasten kann.

 Das ist auch richtig.

Aber bereits im TTL-Kochbuch steht auf Seite 190 das von Peter Dannegger 
Beschriebene:
  "... daß bei allen im Betrieb möglichen Zuständen immer eine Kathode 
der   Röhre eingeschaltet ist. Im anderen Fall.....die Röhre dennoch 
zündet und ihren Strom über die am Ausgang des Treibers befindlichen 
Dioden ziehen. Dabei können diese Klemm-Dioden thermisch überlastet 
werden....."

Autor: Christian Betzen (chris001)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja es sind Originale! Es ist das Symbol von Texas drauf.

Dh. ich schalte die Anodenspannung dann wohl besser doch über einen 
Transistor aus?
Sonst kann es sein das ich öfter mal son IC neu machen muss?

Schö mit Ö….

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Christian Betzen schrieb:

> Dh. ich schalte die Anodenspannung dann wohl besser doch über einen
> Transistor aus?

Nein, du benutzt die Hilfsspannung, wie Michael oben geschrieben hat.
Die Katoden werden dann nur um den Betrag der Hilfsspannung
geschaltet, die Anoden liegen auf einem Betrag, der sie bei Katoden-
spannung 0 sicher zünden lässt, bei Katodenspannung 50 V jedoch sicher
erlöschen.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

muß mein Posting, auf das sich Jörg Wunsch bezieht, mal korrigieren:

> Brennspannung liegt). Von dort über jeweils 50...100k an jede Anode.
Die müssen natürlich, wie Jörg richtig schreibt, an die Katoden und 
nicht an die Anoden...

PS: wie soll ich wissen, was ich meine, bevor ich lese, was ich 
schreibe???

Gruß aus Berlin
Michael

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael U. schrieb:

> PS: wie soll ich wissen, was ich meine, bevor ich lese, was ich
> schreibe???

:-)

Ich war stillschweigend davon ausgegangen, dass du dich nur
verschrieben hast.

Autor: Christian Betzen (chris001)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Alle!

Das ist ja auch nicht so einfach mit den Kathoden u. den Anoden:-))))

Also gut! Ich teste das dann mal noch etwas aus mit der Hilfsspnnung, 
und werde über meine Erfolge berichten.

Man schreibt sich.

Christian Betzen

Autor: Frank Zöllner (frankovic)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf der Seite von Zetalink gibts in einer der Dokumentation einen 
schönen Nixie-Uhr-Schaltplan. Zwar nicht mit 74141, spielt aber keine 
Rolle. Dort sind die Kathoden mit etwa halber Anodenspannung 
"vorgespannt". (Die Anoden übrigens auch).
Frank

Hier der Link, ist das unterste PDF-Dokument
http://www.zetalink.biz/doxndox.html

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.