www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit Easy TCP/IP


Autor: Kai M. Tegtmeier (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, allerseits!

Hat jemand Erfahrung mit dem Easy TCP/IP-Modul von MCSELEC? Ich
versuche seit einiger Zeit, das Modul zum Laufen zu bringen, aber bis
jetzt kein Erfolg. Was mich stutzig macht, ist, daß die "Link"-LED
bereits leuchtet, wenn Spannung angelegt wird, obwohl noch kein
Netzwerkkabel eingesteckt ist. Der Atmel-Prozessor (bei mir ein
ATmega8515L) scheint zu laufen... Kennt sich jemand mit dem Board aus,
der mir weiterhelfen kann?

Vielen Dank für alle Hinweise!

Gruß
KMT

Autor: schneidertobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du ein IIM7000 oder ein IIM7010? Poste doch mal deinen Aufbau

Gruß Tobias

Autor: Kai M. Tegtmeier (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe ein IIM7000A. Der Aufbau ist der, der von MCSElec vertrieben
wird. Anbei mal der interessante Teil des Schaltplanes. Genaue Daten
finden sich unter www.mcselec.com --> Easy TCP/IP

KMT

Autor: schneidertobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du auch entsprechende Spulen oder Übertager bzw. ein RJ45-Jack, das
das zeig schon inegriert hat?(Benutze hier ein IIM7010A da ist das schon
im Jack drin)

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Wie herum hast du das iim7000a denn eingelötet/eingesteckt? Und welches
Board hast du? Damit gibts nämlich einige verschiede Anschlussvarianten.
Siehe:http://www.mcselec.com/download/avr/tcpip/Differen...

Ich hab auch ein IIM7000A Modul auf einem Board der 2. Version
(MCSTCPIP2.EDB) Dies sollte in der Nähe des Controllers aufgedruckt
sein. Bei meiner Platine hab ich das IIM7000A Modul dann so eingebaut,
dass der Quarz auf dem Modul zum Controller zeigt.

MFG Nik

Autor: Kai M. Tegtmeier (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die Hinweise!

Volltreffer: hab das IIM7000A-Modul genau verkehrt herum eingebaut. Hab
zwar schon die MCSTCIP3.EDB-Platine, da scheint sich aber was die
Markierung der Einbaulage angeht, nichts geändert zu haben. Weil ich
(so schnell) keine Pfostenbuchse für 2,0mm Raster (abartig!) kriegen
konnte, habe ich natürlich das Modul eingelötet. Da wird der Ausbau ja
spaßig werden. Muß ich denn die Aktion mit dem Durchtrennen der
Vcc-Leitung und C14 auch machen?!?

Vielen Dank schon mal bis hierhin!
KMT

Autor: Marco Haufe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn du ein 7000A auf dem MCSTCIP3.EDB betreibst, ist hier der Jumper J7
dazu da, die VCC an der Stelle zu trennen. Dann ist es im Grunde egal,
ob der C14 bestückt wird oder nicht. Tip : Pin 2 + 3 sind bei dieser
Boardversion am RS-232 Verbindung noch getauscht.
VG Marco

Autor: Marco Haufe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch so als Hinweis : unter www.mcselec.com/forum gibts eine Kategorie
Easy-TCPIP. Dort gibts ebenfalls qualifizierte Antworten, da dort auch
der Entwickler von BASCOM mitmischt....
VG Marco

Autor: Kai M. Tegtmeier (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, Marco!

Vielen Dank erstmal für die Hinweise. Ich hoffe ja, daß MCSElectronics
irgendwann mal das Manual für das Board updated. Da stehen nämlich noch
Jumper drin, die gar nicht mehr existieren...

By the way: Ich hatte jetzt einen ATmega8515L im Board drin. Welche
AVRs passen denn noch in das Board (ich nehme an, das müssen welche
sein, die Pin 40=Vcc und Pin 20=GND haben?!?)

MfG
Kai Markus

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.