www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Pegelanpassung mit Dual Buffer Gate


Autor: Andreas B. (loopy83)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo und Guten Tag,

ich wollte mich erkundigen, ob meine Schaltung ihren Zweck erfüllt.

Es geht um die Pegelanpassung eines 40MHz Signals von 0/3,3V zu 
0,5V/-4,5V.

Input: High 3,3V, Low 0V
Output: High 0,5V, Low -4,5V

Dazu habe ich mir einen Dual Buffer von TI rausgesucht (SN74LVC2G34).
Datenblatt: 
http://www.datasheetcatalog.org/datasheet2/5/0qq1u...

Nun lege ich den GND Pin auf -4,5V und den VCC Pin auf 0,5V. Somit 
beträgt die effektive Betriebsspannung ja 5V und liegt somit innerhalb 
der Specs.

Die Dioden habe ich mir von einer ähnlichen Anwendung abgeschaut, 
welchen Zweck sie genau erfüllen weiß ich leider nicht, ein Hinweis dazu 
wäre recht hilfreich, ob ich die brauche oder nicht. Ich hab sie dennoch 
erst einmal drin gelassen.

Realisiert die Schaltung die beschriebene Funktion?

Vielen Dank
Andreas

Autor: Andreas B. (loopy83)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keiner eine Idee?
DANKE

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Dioden verhindern, dass positive Signalanteile >Schwellspannung an 
die Eingänge des 74... gelangen. Sprich das Eingangs-Signal wird auf 
Minus geklemmt. Sollten in diesem Fall Schottkys sein.
Ansonsten sollte es so funktionieren, vorausgesetzt der Bezugspunkt von 
H-Low und H-High ist AGND.

Autor: Andreas B. (loopy83)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antwort.
Ich verstehe es aber noch nicht 100%ig.

Liegt am Eingang also ein 3,3V Pegel an, ist ja die Diode in 
Durchlassrichtung gegen Masse geschaltet. Also liegen am Eingang des 
74... ca. 0,7V an?!

Ist der Pegel 0V, liegen auch 0V an... also habe ich doch ein 
Eingangssignal von 0V Low und 0,7V High, oder wie sehe ich das?
Nur wird 0,7V bei 5V VCC des 74... noch nicht als High interpretiert 
(High = 0,7*VCC laut Datenblatt).

Könnte es Probleme mit den Massen geben, weil alle Signale und 
Spannungen ein Bezugspotential (AGND) haben?

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Könnte es Probleme mit den Massen geben, weil alle Signale und
> Spannungen ein Bezugspotential (AGND) haben?

Nein, sie müssen sogar ein Bezugspotential haben.

Autor: Gast (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Skizze

Autor: Andreas B. (loopy83)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hey vielen Dank für deine Mühe!

Mit deiner Zeichnung gehe ich voll mit.. positiv die Schwellspannung und 
ins negative die negative Amplutude.

Nur leider habe ich ein 0V und 3,3V Signal, also kein negatives 
Potential
Heißt, dass ich zwar als High Pegel die Schwellspannung bekomme, aber 
kein negatives Potential.

Siehe Skizze

(Annahme, 0,7V Schwellspannung, bei ner Schottky wären es vielleicht 
0,3V oder sowas)

Somit habe ich dann am Eingang des Buffers ein 0V - 0,7V Signal.

Da der Buffer mit den Potentialen -4,5V und 0,5V arbeitet, bin ich also 
durchgehend im High Pegel Bereich und sollte eine dauerhafte 1 (0,5V) am 
Ausgang haben.

Genau das ist mein Problem. Ich komme mit meiner Eingangsspannung nie in 
den Bereich von -xV, da die Diode nie in Sperrrichtung betrieben wird.

Ich hoffe, ich verstehe die ganze Sache richtig?!

MfG Andreas und Vielen Dank!

PS: Was mir gerade auffällt. könnte es sein, dass die SPannung nach dem 
Kondendator an der X Achse gespiegelt werden muss?

Autor: Andreas B. (loopy83)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat vielleicht noch jemand einen Hinweis zu der Sache?

Das Problem ist auch, dass es den Buffer nicht im DIL Gehäuse gibt, 
sonst würde ich ihn mal schnell bestellen und austesten.

Vielen Dank!

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das funktioniert schon so allerdings hast du eine untere Grenzfrequenz 
die sich aus R und C berechnen laesst.
Du hast doch Kondensatoren in den Eingaengen die verschieben dir den 
Pegel in negative. Du kannst die sache ja mal ohne die Buffer testen. Du 
muesstes dann negative Impulse dort messen koennen.

Gruss Helmi

Autor: Andreas B. (loopy83)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das bedeutet also, dass ich nach dem Kondensator einen solchen 
Spannungsverlauf haben würde (idealisiert, nen Rechteck wirds wohl nicht 
werden, eher was in Richtung Lade- und Entladekurven eines Kondensators 
statt den steilen Flanken). => Siehe Anhang

Da der Buffer mit -4,5V und 0,5V betrieben wird, wäre nach Datenblatt 
(High = 0,7*VCC) die Schaltschwelle bei -1V.

Da der Eingangstakt sich ja zwischen 0,3V (Schottkydiode Schwellspanung) 
und -3V bewegt, hätte ich auf jeden Fall eine Überschreitung des 
Highpotentials bei -1V und der Buffer schaltet je nach anliegendem Takt, 
so wie er es soll (nicht invertiert).

Sehe ich das richtig?

Die Grenzfrequenz ist unkritisch, da sie bei 0,1uF und 300k zwischen 5 
und 6 Hz liegt... also ein 40MHz Signal würde quasi ungehindert 
passieren können und die Pegel werden nicht allzu sehr verwaschen.

Vielen Dank!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.