www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit AVR Burn-O-Mat


Autor: Luca Jessen (funkraut)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey Leute,

Um die Fusebits zu setzen benutze ich das Programm AVR Burn-O-mat. Ich 
hab es jetzt auf meinem PC installiert aber es lässt sich einfach nicht 
öffnen. Der Prozess scheint zu laufen aber ich sehe nichts auf dem 
Bildschirm. Weiß jemand von euch woran das liegen könnte?

Danke im voraus!
MFG
FunKraut

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
k.A. warum das Programm nicht lädt. Warum setzt du die Fuses nicht 
einfach mit nem anderen Programm z.B. AVR Studio?

Autor: Luca Jessen (funkraut)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich denke das werde ich auch tun. Ich habe bis jetzt immer Programmers 
Notepad gehabt also alles mit WinAvr gemacht. Mit dem kompletten AVR 
Studio hab ich das noch nicht versucht.

Autor: Luca Jessen (funkraut)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt find ich aber nichts wo ich meinen Programmer einstellen kann. Da 
steht nirgends was von Usbasp. Oder reicht es wenn das im Makefile 
steht? Außerdem seh ich nicht wo ich die Fuses setzen soll. :-(

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Burn-o-mat geht bei mir auch nicht. D.h. es läßt sich zwar starten, 
brennt aber fehlerhaft mit einem AVR910 progger. Wird der usbasp 
überhaupt von etwas anderem als avrdude unterstützt?

Auf der fischl.de Seite steht ein Link zu einem Frontend für avrdude. 
Sieht interessant aus.

Autor: Luca Jessen (funkraut)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich hab mich mal schlau gemacht. Der USbasp wird nicht vom AVR 
Studio unterstützt. Entweder müsste ich mir einen Programmer zulegen der 
davon unterstützt wird, oder ich müsste in meinem USBasp eine andere 
Firmware reinladen. Z.B die vom STK500 oder AVR ISP mk2. Dann sollte es 
funktionieren. Da ich aber den USBasp noch brauche (für meine Projekte 
auf der Arbeit) kann ich keine andere Firmware reinladen. Das komische 
ist das es bei mir auf der Arbeit keine Probleme mit dem AVR Burn-o-mat 
gibt. Ich werde da mal nachfragen :-) Danke jedenfalls

MFG
FunKraut

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.