www.mikrocontroller.net

Forum: Platinen [KiCad] Text negiert Plotten


Autor: Thomas Weinhold (lodentoni)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, ich hab grad ein Problem.
Wenn ich in PcbNew den Plot negiere, dann sind die Layer, auf denen Text 
eingefügt ist einfach schwarz. Ist das ein Bug, oder muss man 
irgendetwas beachten?

Layer die keinen Text enthalten, werden ohne Probleme negiert. Layer mit 
Text sind einfach nur schwarz (keine Struktur). Es ist auch egal ob man 
es mit CU- oder anderen Layern versucht.


P.S. Ich Plotte als A4-Postscript und wandle das mit FreePDFXP in eine 
PDF um.

Autor: Johannes S. (demofreak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche Version?
Häng mal das File an, dann probier ich das hier mit dem CVS-Snapshot.

Autor: Thomas Weinhold (lodentoni)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab mir extra nochmal ne aktuelle Version geladen (Build: 20090216).

Autor: Johannes S. (demofreak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jo, ist bei mir auch so. Ich habs mit SVN-R1835 getestet.

In der PS-Datei sind ein paar Anweisungen zuviel bzw. falsch, keine 
Ahnung. Wenn man ein paar der Zeilen:

0.000 0.000 0.000 setrgbcolor

mittels % auskommentiert, sieht es ok aus. Scheint so, als wenn die 
Schrift nicht mitinvertiert wird, sondern ebenfalls schwarz ist wie der 
Hintergrund.

Riecht nach Bug. ;)

/Hannes

Autor: Thomas Weinhold (lodentoni)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tatsächlich, danke!
Einfaches Suchen/Ersetzen behebt dann das Problem.

Autor: Johannes S. (demofreak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das schon, aber ein Bugreport wäre sicher trotzdem angebracht. Gerade in 
den letzten Tagen basteln die eh wieder dran rum, vllt würden sie es 
gleich mit abstellen...

/Hannes

Autor: Thomas Weinhold (lodentoni)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich find grad keine offizielle Sammelstelle für Bugs. Wo soll ich denn 
den Bug melden?

Autor: Johannes S. (demofreak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Thomas Weinhold (lodentoni)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, ich habs gemeldet.

Vielen Dank an Euch, war mir wirklich eine Hilfe!

MfG

Autor: Johannes S. (demofreak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Thomas Weinhold (lodentoni)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wow, knappe vier Tage.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.