www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Dreieckgenerator verändert Frequenz


Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HI @ all

Ich habe mir einen Dreieckgenerator nach diesem Vorbild aufgebaut.
Link 2te Zeichnung.
http://homepages.internet.lu/absolute3/tronic/sz.htm

Den genauen Schaltplan werde ich morgen hier posten.

Ich erzeuge ein Dreieck
500kHz
4V Uss
Periode dauert also 2µs

Mein Problem die Periodendauer schwankt +/- 20nS
Ist ohne Schaltplan etwas schlecht muss ich selber gestehen aber ist 
doch schon etwas spät.
Ich wollte Fragen woher das am ehesten kommt.

Rauschen, Schwingungen, unsaubere Versorgungsspannung oder unsauberer 
Referenzspannung.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Betriebsspannung muß stabilisiert sein.
Bei 500 kHz spielt auch der verwendete OPV eine Rolle.
Schleifkontakt Poti ev. Mal mit einem Festwiderstand probieren, ob die 
Frequenz da auch wandert.

Schwankungen um 1% ist so schlecht erst mal nicht.
Mit Quarz aufbauen, wenn die 500 kHz fest sein sollen.

Autor: Redegle (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Quarz kommt erstmal nicht in Frage, ist auch egal ob das nun 500kHz sind 
oder 510kHz es sollte nur konstant bleiben.

Austausch gegen Festwiderstände könnte ich versuchen. Kenne die Werte ja 
nun, die ich für die momentanen Einstellungen benötige.

Betriebsspannung schwankt nur noch sehr geringfügig also mit dem 
Oszilloskop sind keine niederfrequenten Schwankungen zu entdecken. 
Natürlich bricht die Spannung im Schaltmoment minimal ein aber ich denke 
das sollte nicht so große Fehler zur Folge haben.

Werde aber jetzt die Schaltung anhängen. Ich denke dann kann man mehr 
erkennen.

Was definitiv verwundern wird ist die Z-Diode direkt am Ausgang des 
Komparators. Das Problem war, dass die Ausgangsspannung des Komparators 
einem Rechteck mit aufgesetztem Dreieck ähnelte. Bezogen auf die 
gesammte Periode nicht nur auf den Schaltmoment.
Noch zu erwähnen währe, dass die Z-Diode den Komparator nicht in die 
Kurzschlussbegrenzung treibt. Denn die Ausgangsspannung beträgt bei 1mA 
3,4V und bei 10mA 3V.
Somit begenzt der Spannungabfall an der Ausgangsstufe des Komparators 
den Strom noch bevor der Kurzschlussstrom von 20mA fließt.

Autor: Raimund Rabe (corvuscorax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welchen (schlechten) Grund gab es denn die Referenzspannungserzeugung 
doppelt zu machen?!?
Sowohl der LT1016 als auch der LT1227 könnten dies aus ein und derselben 
Quelle beziehen. Dies dürfte mit ein Grund für den Jitter sein.

Autor: Ulrich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn die Ausgangsspannung des Komperators kein richtiger Recheck ist, 
kann es Probleme geben. Die zenerdiode ist da eher weniger gut geeigent, 
denn Zenderdioden haben oft eine merkliche Kapazität und bei dem eher 
hohen strom am Ausgang des Komperators kann sich auch einiges Erwärmen. 
Sinnvoller wäre da ein CMOS Logicgatter zwischen, oder die Zenerdiode 
weglassen, und dafür die Widertände R1 und R4 vergrößern wegen der 
größeren Amplitude.

Damit die Schaltung stabil läuft sollte da ganze angeschirmt sein, denn 
schon kleine Rückkopplungen des Ausgangssignals können die Frequenz 
stören. Es kann auch schon einen Unterschied machen wo und wie man da 
Oszilloskop ranhängt.

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Raimund Rabe
Ich habe nicht viel Ahnung vom umgehen mit Jitter. Könntest du mir bitte 
erklären, in wie fern 2 Referenzspannungen für Jitter sorgen? Es sollte 
ja kein Problem sein eine zu entfernen.

@ Ulrich
Das Rechteck sieht schön aus und es lässt sich keine Erwärmung 
feststellen. Die Bauteile sind kalt, nicht mal lauwarm. Die 
Anstiegsgeschwindigkeit ist auch im Bereich des DBs.

Die "Verzerrung" habe ich am Rechteck des Komparators gemessen, es ließ 
sich feststellen, dass der positive Bereich in der länge (Zeit) 
schwankt. Deswegen mein Rückschluss auf den Jitter.

Kannst du angeschrimt etwas genauer erklären?
Ich verwende eine Massefläche welche Massepotental hat.
Die Potis sind auf der Oberseite.
R8, C1 und R5 sind auf der Unterseite.

Autor: Helmut (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Geht es hier um den Jitter in der Simulation oder hast du den Jitter in 
einem realen Aufbau gemessen?

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In einem realem Aufbau gemessen.

Autor: Helmut (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schwachstelle deiner Schaltung ist die Komparatorausgangspannung.
mach da zwei 74HCT04 dahinter um saubere 0/5V zu bekommen.
Diese schöne Rechteckspannung nimmst du dann für den Integrator und! die 
positive Rückkopplung am Komparator.

Autor: Helmut (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
" Die Schwachstelle deiner Schaltung ist die Komparatorausgangspannung.
mach da zwei 74HCT04 dahinter um saubere 0/5V zu bekommen.
Diese schöne Rechteckspannung nimmst du dann für den Integrator und! die
positive Rückkopplung am Komparator. "

Ach ja, die Z-Didoe am Komparatorausgang muss auch weg.

Autor: doofi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und C1 ist hoffentlich ein ordentlicher Kondensator und kein
XR5/XR7-Kerarmikscheibchen.

Glimmer würde sich anbieten.

Autor: Helmut (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein C0G Kondensator wäre auch OK.

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Rechteckspannung werde ich euch morgen mal zeigen die müsste in 
Ordnung sein.

In wie fern würde sich ein XR7-Kerarmikscheibchen auswirken?

Ich benutze diese hier
http://www.reichelt.de/?;ACTION=3;LA=444;GROUP=B35...

Hab aber noch 4 1nF SMD C0G.
Würde sich es anbieten diese in Reihe zu schalten oder erhöhrt dies 
unnötig die Indktivität?

Autor: Zirkel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der LT1016 hat einen TTL-kompatiblen Ausgang, er braucht keine HCTs 
hintendran, siehe ausführliche Beschreibung im Datenbuch.
Sag mal, warum du die Z-Diode drin hast/hattest.

Autor: Redegle (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte auch nicht vor HCTs dranzuhängen.
Hätte das morgen genauer erklärt, wenn ich das oszi bild mache. Das 
Problem ist folgendes. Ich mache mal nen Bild, dann lässt sich das 
genauer erklären.

Siehe Anhang

Der LT1016 hat die Eigenschaft das der Ausgang ohne Belastung wie auf 
dem nachfolgendem Bild im Anhang aussieht.
Kann mir zwar nicht 100% erklären wie es dazu kommt aber es ist so. Es 
ist kein Überschwinger sondern die Spannung sinkt kontinuierlich ab.

Die Diode schließt den Ausgang sozusagen kurz.
ABER
Bei höherer Strombelastung steigt der Spannungabfall am LT1016 
automatisch. Deswegen pendelt sich der Stromverbrauch bei ca. 10mA ein.
Bei den 10mA und 2V Spannungsabfall verbrät der LT1016 20mW.

Autor: Helmut (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der TTL-Ausgang ist ja genau das Problem. Sieht total lausig aus. Der 
bestimmt den Integrationsstrom und die Schaltschwelle. Das wird nix.

Autor: Zirkel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
R5 und R4 sind sehr niederohmig, der LT1227 zieht kräftig nach Low/- und 
senkt linear (so wie die Kondensatorladung) den Spannungsteiler R5/R4 
ab.

Autor: Zirkel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Außerdem soll R4 (sehr viel) größer sein als R5 (im Link 1:10), bei dir 
ists umgekehrt.

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
R4 ist wie es dabei steht ein 100kohm Potentiometer.

R4   > R5
100k > 4k


Aber es geht um den Jitter nicht direkt ob die Schaltung funktioniert.
Ich werde aber gerade Bilder machen.

Autor: Zirkel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jitter ist das nicht, was du gezeichnet hast.
Das ist eine gleichförmige Abnahme der 1016-Ausgangsspannung.
Auf welchem Ohm-Wert steht das Amplituden-Poti?

Autor: Redegle (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Rechteck groß

Autor: Redegle (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Rechteck in Umschaltmoment gezoomt.

Autor: Redegle (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Dreieck groß

Autor: Redegle (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Dreieck extram nah rangezoomt.

Sieht nicht ganz so schön aus aber einen Teil mogelt das Rauschen des 
Oszis dazu.

Autor: Redegle (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Rechteck wird bei steigender Flanke getrigert.
Betrachtungspunkt ist um 1µs nach rechts geschoben und ich betrachte die 
sinkende Flanke.

Dort erkennt man auch das eigendlich Problem

Autor: Ulrich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das HCT Gatter wäre ein Ersatz für die Zener-diode. damit kreigt man 
eine schönes Rechtecksignal mit stabiler Amplitude, ohne dem Komperator 
stark zu belasten.
Eine mögliche Quelle für den Jitter sind Schwankungen in der Amplitude 
des Rechwcksingals: Der Wert vor den Flanken bestimmt die 
Schaltschwelle, aber der Mittelwert bestimmt die Steigung des Dreiecks. 
Die absolute amplutide ist also nicht so wichtig und auch der unschöne 
Anfall ist nicht das Problem, aber ein Rauschen in der Amplitde kann es 
sein. Gerade Zenerdioden Rauschen auch mal ganz gut.
Die andere  mögliche Quelle ist eine Einkopplung von 50 Hz bzw. 100 Hz, 
das kann dann schon mal zu einer FM Modulation führen. Eine gute 
Schirmung ist hier wohl nötig.

Für weniger Einkopplungen wäre es eher sinnvoller R1 kleiner und dafür 
C1 größer zu haben. R4/R5 sind auch nicht zu niederohmig.

Der Poti für R4/R5 ist auch keine so gute Idee, denn der beeinflußt auch 
die Frequenz. R4 sollte schon eher größer als R5 sein, vor allem wenn 
die Amplitude des Rechtecks ohne Zenerdiode größer wird.

Die Auskopplung sollte man auch besser gleich noch mit einplanen: einen 
Poti für die Amplitude und Puffer  1:1 hinter den OP. Ein weiters gatter 
von 74HCT04 (oder 14) fürs Rechteck.

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab jetzt erstmal den Widerstand für die Frequenz gegen einen 
Festwiderstand ersetzt. Wenn ich am Poti gewackelt hab hat sich die 
Frequenz verändert.

Anschließend habe ich die Versorgungsspannung nachgemessen und 
anschließend die dortige Kapazität signifikant erhöht. Durch 
parallelschalten mehrere SMD Kondensatoren.

100Hz rauschen habe ich vorher minimiert sind höchstens 1-2mV auf der 
Versorgungsspannung.

Auf den Einsatz eines HCT Gatter wollte ich möglichst verzichten. Denke 
aber darüber nach.

Wenn ich nun alle sonstigen Verbraucher auf der Platine ausschalte habe 
ich den Jitter fast weg.

Wenn ich die Verbraucher einschalte ist der Jitter wieder da. Muss mal 
gucken wo da die Störungen herkommen. Bzw. ich weiß woher muss die 
kommen aber nicht wiso sie sich im Dreieck widerspigeln.

Aber was mir auffällt. Wo ich gerne mal eure Meinung höhren wollte.
Wenn ich die Massefläche, welche galvanisch von 230V AC getrennt ist 
anfasse oder mit PE verbinde wird das Rauschen weniger. Woran könnte das 
liegen? Ist die Schirmung ohne PE Anschluss unwirksam?

Ist ggf ne dumme Frage ich weiß.

Autor: Zirkel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Die Rechteckspannung werde ich euch morgen mal zeigen die
 > müsste in Ordnung sein.

Und jetzt bist du nicht mit ihr zufrieden (TEK0032.png)?

Ist die Z-Diode weg?
Sind inzwischen R4/R5 Einzelwiderstände geworden?
Was werkelt noch in der Nähe deines Dreieckgenerators?
Was sind das für Verbraucher?
Sind die LTs nach Herstellerempfehlung entkoppelt?

Autor: Ulrich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schirmung muß nicht mit dem PE verbunden sein. Der Schirm sollte mit 
der Masse der Schaltung verbunden sein und ganz rum gehen.

Die verbindung zu PE bringt vor allem was, wenn der Schirm nicht ganz 
rum geht, sondern z.B. nur einseitig ist.

Autor: SNT-Opfer (gastiert wieder) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Redegle, erinnerste Dich an deinen Thread in "einem anderem" Forum, dort 
schrieb ich dir am 5.3.09 folgendes :

>In der Offseteinstellung an einem Highspeed Komparator ?

>Och, ist klasse ... jegliche kleine Schwankungen in der Versorgung, aus
>welcher der Saft für das Offsetpoti kommt, werden auf Signal drauf gepackt.
>Im Dreieck machen sich die kleinen Schwankungen als Jitter im Rechteck >bemerkbar
>... das führt zu Rauschen.
>Intensivnutzer von hochauflösenden AD-Wandlern kennen das auch ganz gut...
>und viel unterscheidet einen Damp nicht von einem AD-Wandler ...


bzw.am 6.3.09 :


>Naja, mehr oder weniger.
>Problematisch sind halt Offset an Dreieck und Audio. Zu allem Überfluss
>gibts dann bei einer Gleichtaktstörung auf Ub, die doppelte Amplitude aus
>sicht des Komparators. (Invertierernder, Nichtinvertierender Eingang).
>Hinzu kommt der Drift, läuft auch auseinander, einer hoch, der andere
>runter...

>Daher ja mein Vorschlag, soweit möglich symmetrisch arbeiten und nur 
>homopathisch Offset einspeisen um asymmetrien in der Schaltung
>auszugleichen. Bei mir nehme ich zum stabilisieren des Offsets LM336-2.5,
>eine positiv, eine negativ. Hat man eine gut funktionierende
>Feedbackschleife, braucht man ansich gar keine Einstellung, aber am
>Anfang ist sie recht praktisch.

>Die Störungen deiner Endstufe bekommste auch mit viel Cs niemals komplett
>aus der Versorgung raus, bei Audio reichen wenige mV zum hörbaren
>Rauschen, aus.Nen uF ist schon gross, 100n Keramik packen mehr, hab das
>durch ... Überall rote Kästen drauf ... brachte nix.
>So ein Komparator hinterlässt beim Umschalten kleine Peaks in der
>Versorgung, da auch er Kapazitäten umladen muss, die bekommt man in
>Grenzen mit schnelle induktionsarmen Abblock Keramiken gut in den griff,
>aber auch nur wirkungsvoll wenn der Komparator wenigstens ohne Sockel
>(bei Dip) und so kurz wie möglich an seine Abblock Cs gebunden wird.
>Der LT1016 im Sockel macht ganz lustige Sachen ... wollte dem Datenblatt
>auch erst nicht so recht glauben ... bis sich dann einen 50Mhz Oszillator >hatte.

>Ist alles etwas fusselig und schwer zu packen (da schwierig zu messen),
>daher ausprobieren ... Theorie ist das eine, praktisch wird man bei nen
>DAmp immer wieder überrascht. Eine Simulation bringt echt nur nen groben
>Überblick, obs überhaupt spielt ... in der Simulation funkt deine
>Endstufe und der Treiber nicht in den Analogteil rein.

>Aufbauen !

;-)

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ SNT-Opfer (gastiert wieder) (Gast)

Hast ja irgendwo recht.
Muss ich auch eingestehen.

Mir sagt zwar der Name SNT-Opfer nicht sehr viel aber ok.

Das nächste mal würde ich es auch andersder machen.
Hatte aber aufgrund dessen, das der LT1016 nur im Positiven Bereich 
arbeiten kann das Problem, dass ich mit einem Potentiometern dran muss 
und ich wollte weils mein erster "Funktionsgenerator" ist auch etwas 
Erfahrungen sammeln. Da war das so weit ganz in Ordnung.
Ist atm auch so weit ok hab das mit den 2 Z-Dioden einigermaßen in den 
Griff bekommen. Die Referenzspannung sind also ziemlich stabil. Ziemlich 
stabil heißt die Schwankung ist unter 1mV.
Die Versorgungsspannung +/-5V ist auch stabil. Also maximal 2mV 
Netzbrummen. Hatte da am Anfang eine Hochfrequente Schwingung drauf am 
LT1016 so 500kHz Sinus. Durch nen paar Kondensatoren ist die auch weg.

Ohne externe Komponennten läuft die Schaltung jetzt einigermaßen Stabil. 
Also hab nen Jitter von ca. 2,5nS. Hab nicht genau gemessen nur mal so 
grob drüber geguckt. Könnte also auch leicht abweichen.

Problem ist nur, das ich mir durch die Externen Komponenten etwas Dreck 
einfange der mir die Masse versaut.

Werde da wenn ich mehr Zeit habe mal genauer nachgucken. Hab das 
Masseproblem erst seitdem ich die Kondis am Dreieckgenerator vergrößert 
hab.

@ Zirkel

Genau das Bild gefiel mir nicht.
Die Z-Diode ist noch nicht weg
R4/R5 ist noch ein Potentiometer also einer von den beiden. Der andere 
ist ein Festwiderstand.
Der andere Verbraucher ist ein Mosfettreiber für eine H-Brücke. Hatte 
aber als keine Probleme wegen Masse ist jetzt ziemlich Plötzlich 
gekommen. Muss das mal genauer Untersuchen. Dann melde ich mich wieder.
Entkoppelt sind die Bauteile bei weitem gut genug^^


@ Ulrich

Du hast vollkommen recht^^
Im Moment habe ich nur eine Massefläche welche als Schirmung fungiert. 
Zusätzlich wird dort nach das Massepotential für meine Verbraucher 
geführt.
Glaubst du es würde später besser, wenn um die Schaltung ein 
Aluminiumgehäuse drum herrumkommt, welches mit GND verbunden ist?

Autor: Snt Opfer (snt-opfer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, wollte dir die negativen Erfahrungen ersparen ... aber wenn du da 
durch etwas gelernt hast, ist es ja noch gut ausgegangen ;)

SNT-Opfer aka Basstler, D-Amp Forum

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ah ok.

Wusste nicht obs für euch in Ordnung ist hier den Forenname zu posten.

Btw
Manche Sachen muss man eben selber Ausprobieren.

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und ggf. dabei scheitern ^^

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich wollte als nächstes Versuchen die beiden Z-Dioden durch einen.
LM136 zu ersetzen

http://www.national.com/ds/LM/LM136-2.5.pdf

Währe das Sinnvoll im Bezug auf Rauschen und Filterwirkung von 100Hz?

Ich habe gefunden, dass der LM136 ein Rauschen von 250-125 nV/sqrt(Hz) 
hat. Ist das besser als bei einer 0815 Z-Diode?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.