www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATMega16 PortD.3


Autor: Lukas -- (lukas)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo.

Warum gibt der ATMega16 an PortD.3 immer zu 5 Volt raus?
Ich habe den Port Pin als Eingang definiert.
Ich habe Jtag disablet.
ich habe versucht den Pin extern mit nem Pull-Down auf Masse zu ziehen.
Ich habe den µC getauscht.
Und immer bekomme ich 5 Volt am PortD.3.

Am PortD.3 sind sogar 5 Volt, wenn ich den µC lösche und er kein 
Programm hat.

Kann jemand helfen?

Vielen Dank.

Autor: Klaus 2m5 (klaus2m5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vermutlich durch einen Fehler in der externen Beschaltung. Schluss auf 
Vcc, falscher Pin beim messen? Um ganz sicher zu gehen, mit reset aktiv 
(low) messen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.