www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit Relaissteuerung


Autor: Mike (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen

Habe noch immer das Probelm, dass der Transitor Q3 viel länger leitend
bleibt als er soll.
Wenn ich über den Mikroprozessor eingebe, dass das Relais welcher er
ansteuert 0,3 Sekunden anziehen und wieder loslassen soll, bleibt das
Relais fast eine Sekunde geschlossen.
Mit dem OSZI gemessen ist die Spannung tatsächlich für ca. 1s auf
high.
Hänge ich die ganze Transistorschaltung ab und messe dann am Prozessor,
so stimmen die 0,3 Sekunden.

Habe auch einen Versuch gemacht, in welchem ich einen Schalter an den
Basiswiderstand R36 angeschlossen habe und über diesen den 5Voltpegel
geschalten habe. Hier funktionierte das Relais tiptop, ich konnte das
Relais unter 1s ansteuern.

Habe schon ein Kondensator (10nF) parallel zu R36 gehängt, jedoch
brachte dies auch keinen Erfolg.

Habt Ihr noch Ideen?? Bitte melden....

Gruss Mike

Autor: Danny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum nimmst du einen normalen Transistor anstatt eines TTL-kompatiblen
MOS-Fet? Wäre ja möglich, daß die 20mA die ein Port liefern kann nicht
reichen um den Transistor voll durch zuschalten.
Dann würde dein Transistor relativ warm und würde durch die Temparatur
mehr leitend, was zu einer längeren "An-Zeit" führt. Würde auch
erklären warum es mit deinem Taster am Transistor funktioniert.

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Danny

Hast du einen Typ, oder vieleicht sogar die Schaltung, welche ich
verwenden könnte, wenn ich einen FET nehmen würde???
Kenne mich mit Feld effekt Transistoren leider fast nicht aus...

Danke

Gruss Mike

Autor: Danny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab mal ein bißchen gesucht, unter anderem gibt es den BSP75, wenn dein
Relais nicht mehr als 1A zieht dann geht dieser.
Datenblatt unter
http://www.infineon.com/cgi/ecrm.dll/ecrm/scripts/...
Es gibt noch andere Typen, Du musst nur darauf achten das sie TTL oder
Logic Level kompatibel sind.

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielen dank danny
ich werde das mal genauer unter die Lupe nehmen. Ich hoffe du hast
nichts dagegen, wenn ich dich bei Fragen über Email kontaktiere...

Gruss Mike

Autor: Danny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kein Problem Mike, am Montag abend kann ich Dir einen genauen Typ
mailen, habe ein paar Typen in meiner krabbelkiste auf Arbeit.

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, danke danny

es wäre noch cool, wenn diese nicht in smd forat erhältlich wären, denn
ich habe meine schaltung auf eine Lochkarte gebaut.

Noch ein schönes Wochenende

Mike

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Mike,
aber dein Controller läuft schon mit dem richtigen Takt, oder ??
Ich meine wegen der Fusebits...
wenn du einen Mega benutzt, läuft der eventuell nur mit 1 MHz Takt...
kannst ja nochmal schauen....

Als Mosfet geht z.B. der BS170, aber ich glaube nicht das es daran
liegt...
Gruß

Sven

Autor: harry (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,

deine schaltung ist schon ok so.
ich hab eine ähnliche im einsatz, allerdings mit bc546, läuft tiptop.
der basiswiderstand sollte nicht mehr als 1k betragen, dann schaltet
der transistor sofort und zuverlässig durch. ggfs von der basis noch
4k7 gegen masse, damit die ladung auf der basis zuverlässig abgebaut
wird. um ein relais zu schaltebn braucht's nun wirklich keinen fet,
ein gewöhnlicher schalttransistor macht das locker mit.

gruss, harry

Autor: Ralph Dillhardt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

die Angaben von 'harry' kann ich bestätigen.
Die Diode D40 die Parallel zum Relais eingezeichnet ist sollte auch
eine Schottky-Diode sein und keine 1N4148. Die Bipolaren Schutzdioden
die Conrad im Programm hat funktionieren auch hervorragend. Zur Not
kann auch eine 1N4007 verwendet werden. Eine 1N4148 ist keine gute
Wahl.

MfG
Ralph

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.