www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit DAC7552


Autor: pait (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich versuche gerade den DAC7552 von TI zum laufen zu bekommen.
Das Problem ist, dass obwohl die Bits von der SPI richtig übertragen 
werden, er trotzdem keinen Mux von sich gibt.
Die Daten von der SPI hab ich mit ´nem Oszi überprüft und die stimmen 
auch.

Mal die wichtigsten Pins wie ich sie belegt habe:
PD -> high
DCEN -> low
CLR -> high
SDIN -> SIMO
bei den anderen kann man ja kaum was falsch machen.

SYNCH geht kurz vor den zu sendenden Bits auf low und danach dann wieder 
auf high.
An SDIN schicke ich zum test CFFF (1100 zur Steuerung und FFF als Daten 
Bits). MSB zuerst, und die Flanken von SCLK leigen auch gut, eigentlich 
müsste es geh´n. Damit müsste er eigentlich alle beiden Ausgänge mit der 
maximalen Spannung belegen, also der angeschlossenen Referenzspannung.
Hab auch schon eine Menge anderer Möglichkeiten versucht, ohne Erfolg.

Also es gibt zwei Möglichkeiten. Entweder ich hab irgendwo was 
essentielles übersehen, oder der DAC funktioniert nicht. Das Ding ist 
halt ziemlich schwer zu handhaben in der kleinen Bauform.

Bin dankbar für jede Hilfe.
Vielleicht fällt ja jmd spontan was dazu ein.

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn die restliche Beschaltung stimmt dann sende mal
nicht CFFF sondern EFFF.
Dann wird der gesendete Wert direkt für die Ausgabe
verwendet.

Autor: pait (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja das hatte ich auch schon versucht gehabt. Ohne irgendeine Wirkung.

Autor: pait (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gibt es vielleicht die Möglichkeit mit einem Multimeter zu bestimmen ob 
der IC noch funktioniert?
Dachte daran über den Innenwiderstand des IC´s zu testen.
Also z.B. zwischen SDIN und Vout. Aber so wie ich dass aus dem 
Datenblatt lese dürfte ich dort nichts messen können oder?

Autor: pait (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Okay, hat sich erledigt.

Der DAC war wirklich kaputt. Jetzt funktioniert alles.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.