www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Eingangspin verfälscht Signal


Autor: Franz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich habe hier einen Tiny13 der ein Rechtecksignal auswerten soll welches 
den Step für eine Treiberstufe eines Schrittmotors steuert.
Wenn ich nun dieses Signal messe hat es im Ruhezustand 0V schliesse ich 
nun den Tiny13 an wird das Signal ca. 2.7.Volt angehoben
Die Versogungsspannung ist 3.1 Volt FIX.
Ich habe den Pin als Eingang geschaltet keine Pullups eingeschaltet.
Entsprechendes Bit im DDRB Register ist 0 und im PORTB Register 
ebenfalls 0.
Oder habe ich etwas übersehen?
Hat jemand eine Erklärung warum das so ist?

Gruß ab

Franz

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Oder habe ich etwas übersehen?
>Hat jemand eine Erklärung warum das so ist?

Masse nicht verbunden?
Schaltplan posten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.