www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik "Verschmutzte" Stromversorgung


Autor: Pez G. (pgivy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

in einer Schaltung verwende ich LED Displays, die die Stromversogrung 
ziemlich verschmutzen. Direkt an den Displays habe ich 2 Kondensatoren: 
100nF und 10uF. Direkt an der Stromversorgung habe ich auch 
Kondensatoren (100uF, 470uF, 100nF) installiert. Es bringt aber nicht 
viel. Auf der Stromversorgung liegen Schwankungen von einigen 10 mV mit 
einem Sinus artigen Muster, das von dem Inhalt des Display abhängt.

Die Stromversogrung selbst vom Labor-Netzteil, das ziemlich sauber ist.

Ich möchte diese Schwankungen weg bekommen, damit ich damit ein DCF-77 
Module mit Strom versorgen kann.

Gibt es ein Standard-Rezept für solche Probleme, ein elektronische Idiom 
so zu sagen?

Viele Grüße

pgivy

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
DCF-77 und gemultiplexte LEDs passt aber gar nicht gut
zusammen.

Autor: Hans Mayer (hansilein)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche Frequenz haben die Störungen? Und um welche Spannung geht es?
Werden die Module wirklich gestört?
Könntest Du für die Module einen getrennten Spannungsregler vorsehen?

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mit Betriebsspannung hatte ich bei DCF77 Modulen meist aus alten Uhren 
noch keine Probleme. RC-Entkopplung der Betriebsspannung bzw. eine rote 
LED als Z-Diode bei 1,5V betriebenen Modulen reichte bisher.

Direkte Störungen in Empfänger bzw. Antenne sind dagegen manchmal nicht 
beherrschbar. Zum Syncronisieren dann eben nachts für ein paar Minuten 
die alles abschalten, was stört und die DCF-Daten holen.
So ungenau geht der AVR freilaufend auch nicht, daß es ein Unglück ist, 
wenn es mal eine Nacht nicht klappt.

Gruß aus Berlin
Michael

Autor: Pez G. (pgivy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Holger,

mir sind (Dir bestimmt auch) Lösungen bekannt, die funktionieren. Sie 
wurden aber nicht von Dilettant wie mir zusammengebraut :-)

Autor: Pez G. (pgivy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hans,

Hans Mayer schrieb:
> Welche Frequenz haben die Störungen? Und um welche Spannung geht es?
> Werden die Module wirklich gestört?
> Könntest Du für die Module einen getrennten Spannungsregler vorsehen?

Wenn ich mich nicht verrechnet habe, haben die Störugen zwischen 500 und 
1000 Hz.

Die Module werden tatsächlich sehr gestört. Der Art, dass ich dachte, 
sie wären defekt oder minderwertig.

Eine separate Versorgung könnte ich vorsehen, wäre aber nicht meine 
Lieblingslösung.

Viele Grüße

pgivy

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
man müsste mal raus finden was genau stört, ich denke weniger das es die 
Versorgungsspannung ist sondern eher die Signalleitungen für dein 
Multiplexgedöngs.

Also um die Versorgungsspannung ruhig zu bekommen nimm lieber einen 
LC-Filter
aus 100µH in Reihe und einem guten 10µF Elko direkt am LCD. Und in die 
Signalleitung könntest du je evtl. 50-100 Ohm rein setzen um 
Reflektionen zu verhindern.

Ein Oszi wäre hier sehr vorteilhaft.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die http://dse-faq.elektronik-kompendium.de/dse-faq.htm#F.8.1
warnt nicht ohne Grund bei Multplexanzeigen vor der EMV Problematik.

Die Störungen der Versorgungsspannung lassen sich noch recht leicht 
entkoppeln, eigener Regler, (mehrere) R (mehr als 100 Ohm) C (mehr als 
100uF) Glieder hintereinander, oder Drosseln in der Stromzuleitung zum 
Display und dahinter ein Elko.

Aber das DCF77 Modul wird meist auch von der hohen geschalteten Strömen 
gestört, die das Display schaltet, daher sind gut designte Displays mit 
langsam ansteigendem Strom auf der Multiplexansteuerung (slew rate 
limited) um die Stoerfrequenz tief zu halten und die Abschirmmassnahmen 
klein halten zu können.

Autor: Jadeclaw Dinosaur (jadeclaw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
470 Ohm in Serie und 220 - 470µF empfängerseitig sollten im Normalfalle 
ausreichen. Modul natürlich einen halben bis einen Meter von der Anzeige 
entfernt legen, damit das Multiplexgepfeife nicht in den Empfänger 
einschlägt.

Gruß
Jadeclaw.

Autor: Pez G. (pgivy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jadeclaw Dinosaur schrieb:
> 470 Ohm in Serie und 220 - 470µF empfängerseitig sollten im Normalfalle
> ausreichen. Modul natürlich einen halben bis einen Meter von der Anzeige
> entfernt legen, damit das Multiplexgepfeife nicht in den Empfänger
> einschlägt.
>
> Gruß

Hallo Jadeclaw,

vielen Dank für die konstruktive Antwort. Der Ansatz bringt tatsächlich 
viel. Die besten Ergebnisse erziele ich mit einem Widerstand von 5 Ohm 
und einem Kondensator mit 1000µF.

Egal mit welchem Widerstand ich es versuche, es gibt im Sekundentakt 
einen
Spannungsabfall, der wohl mit dem Verbrauch des Empfängermoduls zu 
erklären ist. Je größer der Widerstand, desto größer der 
Spannungsabfall, je kleiner der Widerstand desto geringer die 
Glättungswirkung. Bei 5 Ohm ist ein Spannungsabfall von immerhin ca. 25 
mV gegeben, was sich immer noch manchmal störend auswirkt, denn das 
Modul will am liebsten konstant versorgt werden.

Fällt Dir was ein, wie man diese Spannungsschwankung zumindest schwächen 
kann? Ich habe es auch mit größeren Kondensatoren (2700µF) versucht, die 
Schwankung ändert sich nicht merklich.

Viele Grüße

pgivy

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Statt der 5 Ohm Widerstandes kanst Du es mit einer (Eisenkern)-Drossel 
in Serie mit einer Ferritkern-Drossel versuchen. Auch gut ist Pi-Filter 
mit nachgeschalteter Stabilisierung (jadeclaw wies Dich ja bereits auf 
die LED als Z-Diode hin, Du kannst natürlich auch mehr Aufwand betreiben 
um geringeren Ri zu erhalten).

Abstand des DCF Moduls vom Rest der Schaltung bringt aber deulich mehr - 
wen Du 1 m hinkriegst, evtl kanst Du den auch vergrößern auf z.B. 2 m?

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Pez G. schrieb:
> Jadeclaw Dinosaur schrieb:
>> 470 Ohm in Serie und 220 - 470µF empfängerseitig sollten im Normalfalle
>> ausreichen. Modul natürlich einen halben bis einen Meter von der Anzeige
>> entfernt legen, damit das Multiplexgepfeife nicht in den Empfänger
>> einschlägt.
>>
>> Gruß
>
> Hallo Jadeclaw,
>
> vielen Dank für die konstruktive Antwort. Der Ansatz bringt tatsächlich
> viel. Die besten Ergebnisse erziele ich mit einem Widerstand von 5 Ohm
> und einem Kondensator mit 1000µF.

Die üblichen Module verbrauchen so wenig, daß ich mit 1k/22µ da noch 
keine Probleme hatte. Eventuelle Pegelwandler/LEDs o.ä., die vom Modul 
bedient werden, bekommen ihre Betriebsspannung natürlich vor dem 
Siebglied.
Nur das Modul selber kommt hinter den Tiefpass.

Dem Logiksignal dahinter sind die Störungen relativ egal.

Das Modul erstmal mit 1-2m geschirmten Kabel (alte Kopfhörerkabel sind 
da gut) vom GErät weg.
Wenn es da stabil geht, kommen die Störungen nicht über die 
BEtriebsspannung...

5 Ohm/1000µ oder mehr ist was als Siebung für einen 4W Verstärker-IC. 
;-)

Gruß aus Berlin
Michael

Autor: Pez G. (pgivy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael,

Michael U. schrieb:
> Die üblichen Module verbrauchen so wenig, daß ich mit 1k/22µ da noch
> keine Probleme hatte. Eventuelle Pegelwandler/LEDs o.ä., die vom Modul
> bedient werden, bekommen ihre Betriebsspannung natürlich vor dem
> Siebglied.

Das ist kein so übliches Modul. Es ist eins von Meinberg mit zwei LEDs: 
Empfangspegel- und Signal-Anzeige. Das Module beinhaltet auch eine 
Verstärkerschaltung, daher der relativ hohe Verbrauch.

> Das Modul erstmal mit 1-2m geschirmten Kabel (alte Kopfhörerkabel sind
> da gut) vom GErät weg.
> Wenn es da stabil geht, kommen die Störungen nicht über die
> BEtriebsspannung...

Das Kabel zum Modul ist ca. zwei Meter lang.
Das Problem sind tatsächlich die vierstelligen 5x7 Punktmatrix 
LE-Displays, die ich verwende. Sie verursachen je nach dem dargestellten 
Bitmuster sehr heftige Störungen auf der Stromversorgung. Zur Gegenprobe 
habe ich die Displays abgeklemmt, woraufhin die Stromversorgung sauber 
wurde, und der Empfang sich stabilisierte.

> 5 Ohm/1000µ oder mehr ist was als Siebung für einen 4W Verstärker-IC.
> ;-)

Wenn Programmierer den Lötkolben in die Hand nehmen, kommen nun mal 
entweder solche Schrotflintenlösungen oder Verberennungen dritten Grades 
zustand :-D

Viele Grüße

pgivy

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Pez G. (pgivy)

>viel. Die besten Ergebnisse erziele ich mit einem Widerstand von 5 Ohm
>und einem Kondensator mit 1000µF.

Dann ist was faul.

>Egal mit welchem Widerstand ich es versuche, es gibt im Sekundentakt
>einen
>Spannungsabfall,

Dann ist erst recht was faul!

>Glättungswirkung. Bei 5 Ohm ist ein Spannungsabfall von immerhin ca. 25
>mV gegeben, was sich immer noch manchmal störend auswirkt, denn das
>Modul will am liebsten konstant versorgt werden.

Niemals. Das Modul zieht 100uA (MIKROAmpere), da reichen ein paar uF und 
1k aus, wei bereits mehrfach geschrieben.

Wahrscheinlich ist dein Netzteil zu schwach bzw. DORT sollte ein 
grösserer Elko von 100..470 uF dran.

>Fällt Dir was ein, wie man diese Spannungsschwankung zumindest schwächen
>kann?

Den Fehler suchen. Möglicherweise misst du auch eine Fahrkarte.

> Ich habe es auch mit größeren Kondensatoren (2700µF) versucht, die
>Schwankung ändert sich nicht merklich.

Was für eine Fehlmessung spricht.

MFG
Falk

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es könnte auch Programmierer geben, die dann ein Softwareupdate 
nachschieben, was zur störenden Zeit die Anzeige stromlos schaltet?

Autor: Franzi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht einen Transistor opfern. Das Filter ist viel rauschärmer als 
ein 78xx.
R  10k
C > 10uF

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

> Die Stromversogrung selbst vom Labor-Netzteil, das ziemlich sauber ist.
dazwischen liegen Leitungen, die Störungen einfangen können.
Mit einem Linearregler (78xx/79xx) bekommst Du sowas meist einfach in 
den Griff.

Freundliche Grüße
Michael

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich würde jetzt vermutlich zum Test das DCF-Modul aus Batterien 
versorgen, nur Signal und GND an die AVR-Geschichte.

Einfach nur, um generell auszuschließen, daß nicht einfach der Empfänger 
gestört wird.

Wenn es dann immernoch nicht geht mit Anzeigen dann werden vom Aufbau 
vermutlich soviele Störungen erzeugt und abgestrahlt, daß einfach der 
Empang gestört wird.
Dann müßte man dort die Ursache bekämpfen...

Gruß aus Berlin
Michael

Autor: Jadeclaw Dinosaur (jadeclaw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pez G. schrieb:
> Hallo Michael,
>
> Michael U. schrieb:
>> Die üblichen Module verbrauchen so wenig, daß ich mit 1k/22µ da noch
>> keine Probleme hatte. Eventuelle Pegelwandler/LEDs o.ä., die vom Modul
>> bedient werden, bekommen ihre Betriebsspannung natürlich vor dem
>> Siebglied.
>
> Das ist kein so übliches Modul. Es ist eins von Meinberg mit zwei LEDs:
> Empfangspegel- und Signal-Anzeige. Das Module beinhaltet auch eine
> Verstärkerschaltung, daher der relativ hohe Verbrauch.
Das erklärt es natürlich. Ich war, wie wohl die meisten anderen Poster 
nach diesem Eintrag von einem der üblichen 
Reichelt-/Conrad-/Pollinmodule ausgegangen, die in der Tat sehr wenig 
verbrauchen, bei denen kann man locker bis 1kOhm Serienwiderstand gehen. 
Hier ist anders vorzugehen, nämlich entweder mit einem LC-Glied, 2- 10mH 
mit 100 - 500µF oder evtl. alternativ die von Franzi vorgeschlagene 
Transistorschaltung probieren.


> Das Kabel zum Modul ist ca. zwei Meter lang.
> Das Problem sind tatsächlich die vierstelligen 5x7 Punktmatrix
> LE-Displays, die ich verwende. Sie verursachen je nach dem dargestellten
> Bitmuster sehr heftige Störungen auf der Stromversorgung. Zur Gegenprobe
> habe ich die Displays abgeklemmt, woraufhin die Stromversorgung sauber
> wurde, und der Empfang sich stabilisierte.
Das wäre noch eine Alternative, nachts während der Synchronisation das 
Display einfach abschalten. Den Rest der Zeit hängt die Uhr sowieso am 
Controllerquarz.

Gruß
Jadeclaw.

Autor: Pez G. (pgivy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank Euch allen, insbesondere Jadeclaw und Franzi.
Ich habe an jedes Display jeweils ein 100nF und ein 10uF Kondensator
angebracht. Für die Skizze von Franzi habe ich für den Widerstand 10K,
den Kondensator 1000uF und den Transistor ein BC-547 gewählt.
Das funktioniert, obwohl (oder vielleicht weil) ich nicht verstehe,
warum in den Kollektor völlig verrauschte 5,4V reingehen aus dem Emitter 
aber stabile 4,7V rauskommen. Das lese ich irgendwo noch nach.


Viele Grüße

pgivy

Autor: Jadeclaw Dinosaur (jadeclaw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Sache ist relativ einfach, unter Belastung fließt Strom in die Basis 
des Transistors ein, dadurch sinkt bedingt durch den 10kOhm-Widerstand 
die Spannung an der Basis etwas ab. Dazu kommt, daß der Transistor 
selbst bestrebt ist, den Spannungsunterschied zwischen Basis und Emitter 
nicht über ca. 0.6 Volt ansteigen zu lassen --> Siehe Emitterfolger / 
Kollektorschaltung: 
http://www.elektronik-kompendium.de/sites/slt/0204133.htm

Da aber der Spannungsabfall über die Kollektor/Emitterstrecke jedoch 
größer ist als zwischen Basis und Emitter ist jetzt die durch den Elko 
entrauschte Spannung an der Basis maßgebend. Das Ganze ist im Prizip 
nichts anderes als eine einfache Z-Dioden-Stabilisierung, nur eben 
anstatt der Z-Diode eben ein dicker Elko: 
http://www.elektronik-kompendium.de/public/schaere...

Gruß
Jadeclaw.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.