www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Erster Schaltplan+Layout in Ordnung?


Autor: kornodon (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Habe gerade meinen ersten Schaltplan und Layout mit Eagle zum selbst 
Ätzen fertig gestellt und bitte euch mal nach Fehlern / möglichen 
Verbesserungen ausschau zu halten.

Ist ein Atmega 644-Testboard mit USB und SD-Karte.(Man muss immer das 
was man gerade benutzen will mit kurzen Drahtstücken über die 
Buchsenleisten mit dem Atmega verbinden.)

Später kommen dann noch weitere Module dran (evtl. Bluetooth, GPS, ...)

Stromversorgung geht entweder direkt mit 5Volt oder über den Regler 
(Gleichspannung vorausgesetzt).
Sind die Dioden an den Linearreglern da so richtig?

MfG
Stefan

Autor: kornodon (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
..und hier noch das Layout

Autor: Alex Bürgel (Firma: Ucore Fotografie www.ucore.de) (alex22) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Konnte auf den ersten, schnellen, Blick nichts gänzlich falsches 
Entdecken. Ja, die Dioden an den LDOs sind so richtig, allerdings finde 
ich 1N4148 etwas unterdimensioniert für diesen Zweck...

Autor: kornodon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, habe ich durch 1N4001 ersetzt.

Sonst noch irgendwas? Bin für alle Anmerkungen dankbar.

Autor: Julian W. (julian-w) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also es dürfte nichts Schade, die 90° Ecken durch zwei 45° Kanten zu 
ersetzten. Gibt weniger Reflexionen auf der Leitung.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Julian W. (julian-w) Benutzerseite

>ersetzten. Gibt weniger Reflexionen auf der Leitung.

Wenn das Licht drauf scheint? ;-)
Reflexionen durch 90 Grad Winkel spielen unter 2..3 GHz keine Rolle.

MfG
Falk

Autor: Sven P. (haku) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diese Stiftleisten oder was das da sind, die würd ich weiter vom 
Prozessor weg setzen, sonst kriegste Probleme, wenn da nochn Sockel für 
den Prozessor dazukommt etc.

Autor: Julian W. (julian-w) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gut, kann sein, so genau kenn ich mich damit nicht aus. Ich hab immer 
45° Winkel benutzt, einfach aus vorsicht, nicht das die "teure" Platine 
am Ende nicht funzt. Hab da auch immer lieber ein paar 100nF-Kondis mehr 
eingebaut.

Was ich dir noch empfehlen kann, ist die Stiftleiste etwas weiter weg 
vom Atmega zu platzieren. Kommt man später leichter drann. Ich hab sowas 
ähnliches gemacht und ärgere mich schwarz, dass ich die Stifleiste so 
dicht an einem Sockel platziert habe.

Edit: Upps, wohl etwas zu lange am Post gefeilt ;)

Edit2: Was mir noch gerade einfällt wäre, dass du auf das Top-Layer (?), 
also die rote Seite, noch ein GND-Polygon zeichnest, also die Fläche 
voll mit GND-Signal machst. Spart zum ersten Ätzmittel und  ist besser 
für die EMV.

Autor: kornodon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erst mal danke für die Antworten.

Hatte leider vergessen zu erwähnen, dass die Platine einseitig wird und 
das rote Drahtbrücken darstellen soll.

Die Buchsenleisten sollten theoretisch direkt am Sockel hängen, denk 
dass ich da halbwegs mit Draht drankommen werde. Aber wenn die Teile da 
sind guck ich nochmal, obs auch wirklich passt.

MfG

Autor: Julian W. (julian-w) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich würde sie lieber 1-2 mm weiter weg setzten. Ich habe solche 
Anschlussbuchsen, die genau auf die Anschluss-Leiste passen.
Foto: http://shop.ulrichradig.de/out/pictures/1/rot_p1.jpg

Die passen harschaff zwischen die Anschlussleiste und den Sockel, aber 
da die rechteckig sind, ist dass immer etwas gefrimmel, bis ich die 
drauf hab.

Und bei dir im Layout ist doch wirklich reichlich Platz, die etwas nach 
außen zu verschieben, ohne groß alles neu routen zu müssen...

Autor: kornodon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, habe sie ein bisschen weg gemacht.

Was ich noch fragen wollte: sind die Kondensatoren an Q2 (für die RTC, 
32,768kHz überflüssig oder sogar falsch? Habe nämlich im Internet schon 
mehrere Schaltungen ohne gesehen.

Und ist es besser den 3,3V-Regler hinter den 5Ver zu machen oder auch 
direkt an die Eingangsspannung?

Autor: Julian W. (julian-w) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kornodon schrieb:
> Und ist es besser den 3,3V-Regler hinter den 5Ver zu machen oder auch
> direkt an die Eingangsspannung?

Ist eigentlich egal. Die Verlustleistung ist die Gleiche.
Solange der 5V-Regler nicht zu stark belastet wird und ausreichend 
gekühlt wird, kannst du dahinter noch den 3,3V Regler schalten 
(Vorausgesetzt er arbeitet mit 5V korrekt).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.