www.mikrocontroller.net

Forum: PC Hard- und Software USB verbindung


Autor: Timo Massierer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe folgendes Problem:

ich habe einen Entwicklungsboard bei dem wenn ich USB anstecke ein 
virtual com port installiert werden sollte.

problem ist, dass wenn ich das usb anstecke, der computer nicht mehr 
reagiert. sobald ich den usb stecker wieder ausstecke reagiert der 
computer wieder. (während dieser ganzen aktion war der schirm am 
mikrocontroller nicht mit masse verbunden)

wenn ich jetzt den schirm am mikrocontroller mit masse verbinde und den 
usb stecker dann einstecke, dann erkennt der pc nichts, reagiert aber 
noch normal.


woran könnte das liegen?

danke!

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohne nähere Angaben könntest du genauso gut
fragen warum dir der Weihnachtsmann kein rotes
Fahrrad geschenkt hat.

Autor: Wegstaben Verbuchsler (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Software:

Welches Betriebssystem? Linux, W98, WXP, W-irgendwas?

ist denn der Treiber für (d)ein virtuelles COM-Port schon auf deinem PC 
vorhanden? Gibt es da eventuell konflikte? (--> alte Treiber rauswerfen)



Hardware:

Allgemeine Verkabelung des Board ist ok? Was für Strippe nimmst du 
zwischen Board und PC?

Steckst du das Board an einen Hub rein, oder an eine (einzelne) USB 
Buchse? (--> nur an einzelne Buchse ranstecken)

Wird das Board eventuell über USB mit Spannung versorgt (--> Board mit 
externen Netzteil betreiben)

Ist das Board eventuel Typ USB2, und dein PC kann nur USB1 ? (--> prüfen 
welche Modus Board bzw. PC kann)

Autor: Reinhard S. (rezz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wegstaben Verbuchsler schrieb:

> Ist das Board eventuel Typ USB2, und dein PC kann nur USB1 ? (--> prüfen
> welche Modus Board bzw. PC kann)

Ob USB 1.1 oder USB 2.0 macht für die Funktion an sich keinen 
Unterschied. Nur die Geschwindkeit ist bei 1.1 etwas geringer.

Autor: Wegstaben Verbuchsler (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ob USB 1.1 oder USB 2.0 macht für die Funktion an sich keinen Unterschied.

"Theoretisch" nicht. Wenn die Schnittstelle erst mal läuft. Das macht 
sie aber hier grade NICHT.

Ich hatte auch schon mal ein Board, welches "einfror" wenn da eine USB2 
Komponenten angesteckt wurde. Daher mein Hinweis darauf. (keine Ahnung 
obs damals an HW oder SW des Boards oder der Komponente lag)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.