www.mikrocontroller.net

Forum: PC Hard- und Software [Suche]: LVDS Kabel


Autor: Björn Petersen (oecke)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin.

Ich habe mir für mein Laptop ein neues Display gekauft, weil das 
originale gebrochen ist.
Das Originale hatte WXGA Auflösung, das neue WSXGA+ Auflösung. Das 
Display wird erkannt, das Bild jedoch nicht korrekt dargestellt. Es 
fehlt jede zweite Zeile. Stefan Mayer hat hier im Forum über das gleiche 
Problem geschrieben und den Fehler im nicht ausreichend beschalteten 
Kabel gefunden.
Das originale Kabel meines Laptops (Samsung R509 T3200 Daria) hat 
ebenfalls nur die ODD, jedoch nicht die EVEN Signale aufgeschaltet. Das 
nachzurüsten scheint mir fast unmöglich, ein neues voll beschaltetes 
Kabel wäre die schnellste und sicherste Methode.

Weiss jemand wo ich sowas bekommen kann? Es muss ja nicht original 
Samsung sein. Hauptsache es ist lang genug und hat die richtigen 
Stecker.

Stecker Display: LVDS
Stecker Mainboard: 30pol. 2-reihig
Stecker Converter: 8pol.

Gute Grüße,
oecke

Autor: Tilo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mich ein wenig mit LVDS und einem Notebook-TFT beschäftigt. 
Wenn jede 2. Zeile fehlt, die farben aber ansonsten OK sind, ist das 
Kabel in Ordnung.

So etwas wie Odd und Even gabs bei mir nicht.

Autor: Tilo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag:

Eventuell werden die Daten anderst codiert. Poste mal das Datenblatt von 
deinem alten und deinem neuem Panel.

Autor: Björn Petersen (oecke)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich eins hätte, gerne.

Das alte ist ein Samsung LTN154AT, das neue ein Samsung LTN154P1.
Vielleicht kennst Du ja ne Adresse mit Datenblätter zu den Displays.

Kann man irgendwo auch nen Schaltplan zum Laptop bekommen?

Gute Grüße

Autor: Tilo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe mit Google zumindest Basisinformationen gefunden. Das alte 
Display benutzt zwei LVDS Interfaces mit mehreren Kanälen (Mein Display 
hat nur ein Interface). Für das neue Display habe ich sogar ein 
Datenblatt gefunden (auch wenn nicht viel drin steht).

Mit dem Kabel könntest du doch recht haben, der eine Kanal funktioniert, 
der 2. ist falsch verdrahtet. Da hilft nur weitere Informationen über 
die Display suchen.

Autor: Björn Petersen (oecke)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe nun beide Datensheets gefunden.

Das AT07 (equivalent zum AT10):
http://lcdtech.no-ip.info/download/specs/Samsung/L...

Das P1:
http://beyondinfinite.com/lcd/Library/Samsung/LTN1...

Wie darin zu erkennen ist, benutzt das P1 8 Datenpaare, das AT10 (bzw. 
AT07) nur 4 Datenpaare. Weiterer Unterschied ist der Anschluss des I2C 
am AT10, der Pin 5 ist aber am originalen Kabel nicht belegt.
Da der Stecker auf dem Mainboard nur 30 Pins hat, der Converter aber 
auch noch darüber angesteuert wird, sind letztlich nur noch 4 Pins (in 
einer Reihe) + 2 Pins am mainboardseitigen Stecker übrig. Habe das 
schlechte Gefühl, das es wohl doch nicht funktionieren wird?!

Gute Grüße

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das geht nie da es deine Machine nie mit WSXGA+ Display gegeben hat.
Zusätzlich zum pasenden Display müssen in der Regel auch noch EEPROM
Daten im Display passend sein.
Es gibt nur wenige Notebooks die sowas korrekt erkennen.
IBM Lenovo ond ein paar HPs kenne ich die es korrekt machen.

Ich habe vor einiger Zeit mein HP von WXGA glare auf WUXGA matt
umgestellt.

Thomas

Autor: Tilo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit den Datenpaaren ist vermutlich anderst gemeint.
Bei LVDS werden die Signale differntiell übertragen, daher werden für 
ein Signal immer 2 Leitungen benötigt.

Bei den Display-Controllern, die ich bisher gesehen habe, gibt es auf 
einem paar Clock und auf 3-4 weiteren Paaren die Nutzdaten. Bei deinem 
alten Display ist das genau so (Steht im Datenblatt S.14)

Dein neues Display hat eine höhere Auflösung, damit steigt die 
Datenrate. Damit die Frequenz auf den Leitungen nicht höher wird, wird 
das Display virtuell in 2 Displays aufgeteilt. Über den einen Kanal 
werden die gerade, über den anderen Kanal die ungraden Zeilen übertragen 
(Datenblatt S.8).

Genau hier liegt das Problem. Dein Notebook sendet für das neue Display 
die falschen Signale, weshalb das neue Panel nicht funktioniert. Die 
wirst ein anderes kaufen müssen.

Autor: Björn Petersen (oecke)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also an dem eeprom wird es nicht liegen. das display wird sofort als 
wsxga+ erkannt. es fehlen halt, wie tilo schreibt, signale.
diese scheinen vom chipsatz nicht bis zum stecker verbunden zu sein.
ich bin mir jedoch ziemlich sicher, dass man das display zum laufen 
bekommt, wenn man die leitungen manuell nachverbindet.
das problem ist halt, das der chip direkt aufgelötet ist und man nicht 
sieht welche lötpunkte man dazu benutzen muss.
plan vom chip habe ich, jedoch nicht von der platine.
kann man ein vom pcb einen plan bekommen oder gibt samsung sowas nicht 
raus?
ich würde es drauf ankommen lassen und es manuell anlöten, traue ich mir 
locker zu.

ansonsten, welches wxga display ist das preis/leistung beste am markt?
da ich lieber ein mattes display möchte, würde ich das originale 
LTN154AT10 einem anderen vorziehen. es soll jedoch annähernd die gleiche 
helligkeit (220 cd/m²) haben.
hersteller ist mir egal, hauptsache gut, günstig und am liebsten matt.
die vergleichtypen sind unüberschaubar und sagen nichts über qualität 
aus.

gute grüße!

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> kann man ein vom pcb einen plan bekommen
> oder gibt samsung sowas nicht raus?

Eher gibt MS den Sourcecode von Windows 7 raus.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>also an dem eeprom wird es nicht liegen. das display wird sofort als
>wsxga+ erkannt
woher weist du das?
Nochmal:
deine Maschine ht es nie mit WSXGA+ gegeben. Es ist wesentlich mehr 
notwendig als nur die Kabel nachzuziehen. Dein Video Bios weis 
vermutlich
gar nichts von anderen Displays.
Glaube mir: es wird nie funktionieren. Ich tausche hier im Schnitt 3..4
Pannels von XGA bis WUXGA am Tag.
Beitrag "Laptop Displaycontroller Ansteuerung"
das wäre was gewesen 15.4 WXGA matt

Thomas

Autor: Björn Petersen (oecke)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas schrieb:
> woher weist du das?
ich weiss es nicht zu 100%, aber das display wird ja von windows 
einwandfrei mit 1680x1050 erkannt. und quasi auch so angesteuert, nur 
dass eben die zeilen fehlen. von daher gehe ich davon aus, dass der 
chipsatz die daten auch ausgibt.

> Beitrag "Laptop Displaycontroller Ansteuerung"
> das wäre was gewesen 15.4 WXGA matt
ist das auch gut, oder sind die display alle änlich gleich gut? muss ich 
nur auf die daten achten und werde zufrieden sein?

EDIT: das war ein 14.1, aber nun gut. welche hersteller kann man denn 
als grobe richtung empfehlen?

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Erkennung läuft über das EEProm. Der Chipsatz ist nicht das Problem.
Wer sagt dir denn dass die Signale bis zum LVDS Stecker geroutet sind?
Wie gesagt deine Kiste gibt es nur in WXGA.

15.4 '' WXGA Displays sind im wesentlichen alle gleich Helligkeit um
die 200 NID. Heller Displays sind entweder mit 2 Röheren oder mit LED
Hintergrundbeleuchtung ausgestattet.

Wir setzen hier bei den matten vorwiegend LG ein LP154...
alternativ nehmen wir AU Optronics B154...
CMO und Chungwa sind nicht mehr so toll die nehmen wir nur im Notfall.

Thomas

Autor: Björn Petersen (oecke)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas schrieb:
> Die Erkennung läuft über das EEProm. Der Chipsatz ist nicht das Problem.
> Wer sagt dir denn dass die Signale bis zum LVDS Stecker geroutet sind?
> Wie gesagt deine Kiste gibt es nur in WXGA.
eben, darum würde ich sie ja selber routen. die pins des chipsatz sind 
sicherlich (ich denke es einfach mal) auf einen offen pin auf dem pcb 
gelegt. zum stecker routen, fertig. ein versuch wäre es wert. da ich 
aber nicht sagen kann welche pins auf dem pcb die benötigten sind, 
bringt mir das alles nichts. die benutzten 8 habe ich gefunden, aber den 
rest erraten macht keinen sinn und hat sicher einen kompletten defekt 
zur folge.

> 15.4 '' WXGA Displays sind im wesentlichen alle gleich Helligkeit um
> die 200 NID. Heller Displays sind entweder mit 2 Röheren oder mit LED
> Hintergrundbeleuchtung ausgestattet.
>
> Wir setzen hier bei den matten vorwiegend LG ein LP154...
> alternativ nehmen wir AU Optronics B154...
> CMO und Chungwa sind nicht mehr so toll die nehmen wir nur im Notfall.
vielen dank, dann werde ich mich an LG, AU und Samsung halten.
>
> Thomas
Björn  ;)

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> die pins des chipsatz sind sicherlich (ich denke es einfach mal)
> auf einen offen pin auf dem pcb gelegt.

Warum sollten unbenutzte Balls eines BGA mit auch nur irgendwas 
verbunden sein?

Autor: Björn Petersen (oecke)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das weiss ich eben nicht, aber es könnte ja vielleicht sein.
es ist zwar spekulation, aber niemand kann mir das gegenteil beweisen. 
;)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.