www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Temperaturdrift Transistor BSP299


Autor: Stefan_KM (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen.

Ich habe eine Frage zum Transositor BSP299.

Ich verwenden diesen Transitor für die Regelung eines Stromausgangs. 
Dabei wird der Transistor von einem OPV geregelt. Der OPV wird über ein 
PWM angesteuert und es stellt sich am Ausgang des Stromausgangs der 
gewünschte Strom ein.

Nun ist die Platine in einem Gehäuse und die Komponenten des Gerätes 
erwärmen die Luft im Gerät und der eingestellt Strom beginnt zu sinken.
Wie ist dieder Effekt zu erklären? Hat der Transistor eine 
Temperaturdrift die zum "Verstellen" des Stromausgangs führt?

Kann mir da jemand helfen?

Danke

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das da überhaupt ein Strom fließt wundert mich (C10).

Autor: Stefan_KM (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, kleiner Übertragunsfehler.

Jetzt aber.

Weis niemand einen Rat?

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Stefan,

>Weis niemand einen Rat?

Wahrscheinlich schwingt dein OPamp, oder du verlangst von ihm eine 
Ausgangspannung, die er nicht liefern kann. Wie groß ist denn die, wenn 
der Strom anfängt zu driften?

C4, C6, C7, C8, L1 und L2 würde ich weglassen, weil der OPamp den MOSFET 
sowieso nur ganz langsam steuern kann.

R2 kannst du auch weglassen. Aber zwischen OPamp-Ausgang und Gate würde 
ich einen 1k Widerstand zwischenschalten, um den Ausgang des OPamp von 
der Gate-Source Kapazität zu isolieren.

Kai

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Um welche Stromstärke handelt es sich eigentlich?

Autor: Peter Roth (gelb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der OPamp hat eine rein Kapazitive Last (1MOhm zählt hier nicht).
Viele OPamps haben gerne eine Grundlast, damit die Ausgangstufe ein 
bisschen Strom kriegt und sich ein stabiler Arbeitspunkt einstellt. Also 
R2 mal auf 10kOhm ändern.

Und der zuvor erwähnte 1kOhm zum Gate hin kann auch helfen.

Grüße, Peter

Autor: Stefan_KM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da der OPV mit 15V versorgt wird, und der Transostor bei 10V voll auf 
ist, sollte der OPV schon die gewünschte Spannung liefern können.

0-20mA möchte ich ausgeben.

Ich werden R2 mal kleiner Dimensionieren.

Könnte das Problem nicht auch von R7 kommen? Wenn der Wert des 
Widerstandes sich durch Temperaturänderung verändert, stellt sich auch 
ein anderer Strom ein. Zusätzlich ändert sich das RDsOn des Transistors 
und schon driftet der Stromwert weg?

Ist das eine mögliche Ursache?

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Viele OPamps haben gerne eine Grundlast, damit die Ausgangstufe ein
>bisschen Strom kriegt und sich ein stabiler Arbeitspunkt einstellt. Also
>R2 mal auf 10kOhm ändern.

Der LM321 hat eine Klasse-A-Ausgangsstufe und benötigt eigentlich keine 
Grundlast um einen stabilen Arbeitspunkt einzustellen.

Kai

Autor: Stefan_KM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Da der OPV mit 15V versorgt wird, und der Transostor bei 10V voll auf
>ist, sollte der OPV schon die gewünschte Spannung liefern können.

>0-20mA möchte ich ausgeben.

Ja, wenn der Strom so gering ist, sollte das klappen.


>Könnte das Problem nicht auch von R7 kommen? Wenn der Wert des
>Widerstandes sich durch Temperaturänderung verändert, stellt sich auch
>ein anderer Strom ein.

Wenn du hier einen guten Metallfilm-Widerstand einsetzt, sehe ich nicht 
den geringsten Grund für irgendwelche relevanten Stromänderungen. Von 
welchen Stromänderungen sprichst du eigentlich?


>Zusätzlich ändert sich das RDsOn des Transistors und schon driftet der
>Stromwert weg.

Nee! Das kompensierst du ja gerade durch die OPamp-Gegenkopplung.

Kai

Autor: Peter Roth (gelb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
>
> Der LM321 hat eine Klasse-A-Ausgangsstufe und benötigt eigentlich keine
> Grundlast um einen stabilen Arbeitspunkt einzustellen.

Sicher ist sicher, siehe Datenblatt:

"For AC applications, where the load is capacitively coupled
to the output of the amplifier, a resistor should be used, from
the output of the amplifier to ground to increase the class A
bias current and to reduce distortion"

Die verwendeten Widerstände sollten natürlich nur 50ppm Temperaturgang 
haben.

Grüße, Peter

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Peter,

>"For AC applications, where the load is capacitively coupled
>to the output of the amplifier, a resistor should be used, from
>the output of the amplifier to ground to increase the class A
>bias current and to reduce distortion"

Tatsache! Man lernt nie aus...

Vielen Dank,

Kai

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.