www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 868MHz Funkbrücke mit Aurel RX-8L50FM70SF und TX-8LAVSA01IA


Autor: Christoph Pelich (cpehonk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich möchte gerne mit den o.a. Modulen eine serielle Funkbrücke aufbauen. 
Dazu kommen je ein Pärchen der beiden Module auf einer AT89C52 Platine 
zum Einsatz. Auf kurzen Strecken klappt das auch prima (ca. 3-4m). Aber 
wenn ich das von der Garage aus bis in den Keller probiere (ca. 15m 
durch die Wände), kommt nix Vernünftiges an Signalen mehr an.

Hat jemand einen Schaltplan für die Sende- und Empfangsschaltung ?
Die beiden Module arbeiten mit 5V und ich arbeite nur mit einer kurzen 
(83mm) Drahtantenne.

Was muss ich tun, um das sauber hin zu bekommen ?
Habe den Empfängerausgang des Moduls über 100K an einen BC317 
angeschlossen, der dann gegen GND zieht.

Viele Grüße
Christoph

Autor: Christian H. (netzwanze) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde jeweils eine GSM800-Handyantenne (amerikanisches Netz) 
anklemmen.
Damit kannst Du dann höhere Reichweiten erzielen.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn man einen AM Sender mit einem FM Empfänger paart
ist das nicht besonders klug ;)

Autor: Christoph Pelich (cpehonk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Holger: die passen nicht zueinander ?!

Der Empfänger war extra (Conrad) als Gegenstück verlinkt gewesen.
Na, dann brauch ich mich nicht zu wundern.
Welches Sendemodul ist denn dann das Richtige ?

Viele Grüße

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>@Holger: die passen nicht zueinander ?!

Nein.

>Der Empfänger war extra (Conrad) als Gegenstück verlinkt gewesen.

Ich finde deinen Sender gar nicht bei Conrad.

>Welches Sendemodul ist denn dann das Richtige ?

Für 5V ist der TX-8L50PF06 geeignet.

Autor: Christoph Pelich (cpehonk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Module habe ich 2005 gekauft. Seit dem läuft die Funkbrücke, aber 
nur über einen Weg von ca. 3m ...
Da habe ich wohl einfach nur Glück gehabt ...;)
Danke für den Hinweis, Holger !

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch mal ein Kommentar hierzu:

>Habe jetzt mit den RFM12B Modulen auf 868 MHz Basis angefangen. Ich
>bekommen die Module zwar zum Laufen, muss aber im gleichen Zimmer
>bleiben, damit der Empfang klappt.

>Aber wenn ich das von der Garage aus bis in den Keller probiere (ca. 15m
>durch die Wände), kommt nix Vernünftiges an Signalen mehr an.

Keller ist so ziemlich das schlimmste was du machen kannst.
Stahlbetondecken lassen nicht besonders viel HF durch.
Da wird es möglicherweise auch nicht viel nutzen wenn du dir
jetzt einen passenden FM Sender kaufst.

Autor: Christoph Pelich (cpehonk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit dem Keller ist nur zu Entwicklungszwecken (WerkKELLER ist 
vorhanden). Im Betrieb ist der eine Punkt in der Garage (Holzdach), der 
andere Punkt an der Außenwand vom Haus. Da ist zum Glück kein Stahlbeton 
dazwischen (nur Kalksandstein-Mauerwerk).

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie sieht es denn mit den Antennen aus?
Am weitesten kommt man wenn man die schön gerade nach
oben ausstreckt. Also nicht aufwickeln, biegen oder sowas.
Das man die Antennen nicht in ein Metallgehäuse einbaut
dürfte wohl auch klar sein ;) Metall berühren sollten
die Antennen auch nicht, und etwas Abstand von Metall haben.
Also nicht gerade an der Regenrinne festmachen das ganze.

Autor: Christoph Pelich (cpehonk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Holger,

ich habe gerade festgestellt, dass es seinerzeit das falsche PDF zum 
Download gegeben hat. Ich setze tatsächlich den RX-8L50SA70SF ein.
Habe das auf dem Modul nochmal geprüft.
Meine Antenne ist bislang ein Draht (gerade, 90 Grad von der Platine) 
mit einer Länge von knapp 85mm. Mehr wollte ich eigentlich nicht 
spendieren, da die Antenne noch in das Gehäuse [Plastik ;)] passen 
sollte.

Das empfangene Signal ist nur leider derart schwach, dass ich nix mehr 
daraus machen kann. Auch der Transistor hilft da nicht mehr.

Hast Du noch Vorschläge ?

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Das empfangene Signal ist nur leider derart schwach, dass ich nix mehr
>daraus machen kann. Auch der Transistor hilft da nicht mehr.

Hab mich schon gefragt was der Transistor da soll. Dein Ausgang
ist Pin14 (DataOut)? Hast du den uC da evtl. auf Ausgang programmiert?

Autor: Christoph Pelich (cpehonk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, ich gehe mit Pin 14 des Empfänger-Moduls auf den RX-Pin (P3.0) des 
89C52 (serielle Übertragung). Der ist als Eingang geschaltet. Gehe ich 
direkt auf den Pin, ist die Reichweite extrem niedrig (ca. 2-3m).
Ich habe dann einen BC317 dazwischen geschaltet, der gegen Masse zieht.
Dahinter einen 74LS04, damit ich das Ausgangssignal nicht negiert 
bekomme.
Damit komme ich im Erdgeschoss immerhin so auf 6-7m. Aber ich benötige 
noch mehr...
Da ich mit HF sonst nichts am Hut habe, bin ich mit meinem Latein am 
Ende. Kann doch nicht sein, dass das nicht klappen soll. Andere bekommen 
doch auch deutlich größere Reichweiten hin. Frage mich nur, wie.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich habe dann einen BC317 dazwischen geschaltet, der gegen Masse zieht.
>Dahinter einen 74LS04, damit ich das Ausgangssignal nicht negiert
>bekomme.

Das ist aber Quatsch. DataOut liefert TTL Pegel.
Hast du beide +V Anschlüsse auf 5V gelegt?
Hast du alle Ground Leitungen angeschlossen?

>Ja, ich gehe mit Pin 14 des Empfänger-Moduls auf den RX-Pin (P3.0) des
>89C52 (serielle Übertragung).

Da hab ich noch einen Tip für dich:
Du kannst nicht mit dem UART auf den Sender gehen
und dann mit dem Empfänger wieder auf den UART deiner
Empfangseinheit. Warum? Nimm mal ein Osci und miss am DataOut
des Empfängers wenn der Sender aus ist. Da kommt ein
nettes Rauschen raus.

Autor: Christoph Pelich (cpehonk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
holger schrieb:
> Das ist aber Quatsch. DataOut liefert TTL Pegel.
> Hast du beide +V Anschlüsse auf 5V gelegt?
> Hast du alle Ground Leitungen angeschlossen?

Alle GND schon, den V+ Preamp allerdings nicht.

> Da hab ich noch einen Tip für dich:
> Du kannst nicht mit dem UART auf den Sender gehen
> und dann mit dem Empfänger wieder auf den UART deiner
> Empfangseinheit. Warum? Nimm mal ein Osci und miss am DataOut
> des Empfängers wenn der Sender aus ist. Da kommt ein
> nettes Rauschen raus.

Das mit dem Rauschen habe ich schon gemerkt, aber bei ausreichender 
Signalstärke war dies nicht das Problem, da ich spätestens im 2. Versuch 
eine sauber Übertragung hatte. Damit Sache der Software, wo ich mich gut 
auskenne ... ;)

Ich vermute, Du würdest noch ein R,C Glied hinter DataOut und vor den 
UART Eingang setzen.

Mein Problem ist, dass ich als seltener Hobby-Bastler leider nicht über 
die entsprechenden Gerätschaften verfüge (Osci, etc.).

Du hast mir ja nun schon viele gute Tipps gegeben. Darf ich eine Bitte 
äußern ?
Wie würdest Du das Empfänger-Modul und den µC beschalten ?
Könntest Du mir bitte einen entsprechenden Schaltplan o.ä. geben ?

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Alle GND schon, den V+ Preamp allerdings nicht.

Autsch, dann hat der Antennenverstärker keinen Saft.
Schliess +VPreamp an 5V an. Du wirst dich wundern
wie weit du dann kommst ;)

>Ich vermute, Du würdest noch ein R,C Glied hinter DataOut und vor den
>UART Eingang setzen.

Damit wirst du das Rauschen nicht los.

>Mein Problem ist, dass ich als seltener Hobby-Bastler leider nicht über
>die entsprechenden Gerätschaften verfüge (Osci, etc.).

Das ist schlecht. Osci würde hier viel helfen.
Die Signale sind ja im kHz Bereich. Da könnte man
schon mit nem Soundkartenosci gut arbeiten.

>Wie würdest Du das Empfänger-Modul und den µC beschalten ?

Wie gesagt, schliess +VPreamp an 5V an. Am besten beide +V
jeweils mit 100uH Spule und 100n an GND entkoppeln.
Sollte aber auch ohne Spule schon ganz gut funktionieren.

Autor: Christoph Pelich (cpehonk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
holger schrieb:
> Autsch, dann hat der Antennenverstärker keinen Saft.
> Schliess +VPreamp an 5V an. Du wirst dich wundern
> wie weit du dann kommst ;)

Stimmt ! Mit Preamp auf +5V klappt's wie geschmiert.

> Das ist schlecht. Osci würde hier viel helfen.
> Die Signale sind ja im kHz Bereich. Da könnte man
> schon mit nem Soundkartenosci gut arbeiten.

Habe eine entsprechende Software gefunden. Echt genial.
Läuft prima.

Nochmals vielen Dank für Deine Hilfe !

Autor: Patrick B. (p51d)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Muss den Thread mal aus der Versenkung holen. Ich möchte ebenfalls eine 
Funkverbindung mit dem RX-8L50FM70SF aufbauen. Das TTL Signal wandle ich 
mit einem MAX232 und dann direkt auf den PC. Habe das ganze nun 
aufgebaut.
als Antenne benutze ich einen Draht. Nun messe ich aber sobald ich den 
Empfänger anschliesse ein undefinierbares Signal am Ausgang. Es ist wohl 
TTL hat aber keinerlei Regelmässigkeit. Dieses Signal erhalte ich egal 
ob der Transmitter läuft oder nicht, ob Antenne angeschlossen oder nicht 
und auch unabhängig davon, ob der MAX232 angeschlossen ist. Weis jemand 
woran dies liegen könnte.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Weis jemand woran dies liegen könnte.

Das ist rauschen was da raus kommt. Die Dinger haben
keinen Squelch.

Autor: Patrick B. (p51d)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antwort. In diesem Zustand ist der Receiver schlicht nicht 
zu gebrauchen ,da der PC komplett mit Daten geflutet wird. Wie kann ich 
dieses Problem lösen?

Autor: Stephan Henning (stephan-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mit zB einer entsprechenden Kodierung der Daten.
Schau mal nach Manchester.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.