www.mikrocontroller.net

Forum: Platinen Erster Schaltplan bitte mal drüberschauen


Autor: Tobias G (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ich bin noch Anfänger und habe gerade mein ersten Schaltplan mit 
Eagle entworfen und wolte mal fragen ob das ganze so ok ist. 
Bezeichnungen usw stehen ja drauf.

Mfg Tobias G

Autor: Daniel B. (inox5) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: kurz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Leds sind alle verpolt.

Autor: Helfer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
LED 3 ist falsch gepolt

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die leds sind alle falschrum

Autor: Tobias G (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Noch einen kleinen Fehler gefunden g.

@Daniel B. Die Seite kenn ich, ok er ist jetzt nicht perfekt gemacht 
finde ihn aber drotzdem übersichtlich.

Es geht mir auch nicht unbedingt um die übersicht sondern um die 
schaltung ansich.

Mfg Tobias G

Autor: Daniel B. (inox5) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann tausch doch mal die LEDs. Du hast die alle falsch herum geschaltet.
Und lass ERC auch drüberlaufen. Da fehlen einige Junctions.

Autor: Helfer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie viele wollens noch sagen
>Die Leds sind alle verpolt.
nur LED3 ist falsch
die anderen sehen zwar komisch aus aber sie sind nicht falsch

Autor: Helfer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hust hust
ich hab wohl gnd übersehen

Autor: Tobias G (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So LED´s sind gedreht.

Autor: kurz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@helfer:  Anode der Leds an GND sieht wirklich komisch aus, und wird 
auch nicht funktionieren, es sei der uC hat ne negative 
Ausgangsspannung. Wie begründest Du Deine Aussage? Bin neugierig.

Autor: Tobias G (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So hab nochmal Erc drüberlaufen lassen und paar Fehler behoben.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

was hängt an Pin 15+16 vom Display?
Ich vermute die Beleuchtung.

Egal, welcher Art Beleuchtung es ist: es wird so nicht funktionieren...

Gruß aus Berlin
Michael

Autor: Tobias G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HI danke für denn Tipp wo liegt der fehler ich kann ihn nicht finden?

Mfg Tobias G

Autor: schwups.... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
-S2-S5 fehlen die Pullup-Widerstände wie bei S1/R1.
-Spricht etwas dagegen dem Reset einen Kondensator zu spendieren
 das die Schaltung bei Inbetriebnahme gleich automatisch einen
 Reset bekommt?
-Vom Max 232 fehlt die Betriebspannung an Pin 15(GND)/16(VCC)
 und ein Stabilitätskondensator von ca. 1µF/16Volt in der
 Betriebspannung (Datenblatt beachten).
-Für den Atmega sollte man einen Abblockkondensator von 100nF
 nahe den Betriebsspannungspins einplanen.
-Die Rohbetriebsspannung sollte schon ein paar Klemmen bekommen
 sonst wird das im Layout auch nicht berücksichtigt.
-Für den Messknecht ist ein Massepin recht nützlich, wird aber
 meist erst dann vermisst wenn man einen braucht.

Ansonsten ist mir nichts weiter aufgefallen.
Noch ein Wort zu den LED`s. Die waren ALLE falsch gepolt.
Jetzt sind die richtig. Stromfluss immer in Pfeilrichtung
(kleine Eselsbrücke).

Autor: Achim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für S2-S5 brauchst du keine Pullups wenn du die internen nutzt. Die 
Abblockkondensatoren hast du mit C1 und C2 auch schon bedacht.

Am MAX232 ist der R2 Pin mit GND verbunden, ich glaub nicht das das 
gewollt ist.

Autor: Tobias G (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi, so hab nochmal einiges geändert:

@schwups
1. Ich nutze die internen Pullups.
3. Hab ich gemacht ziehmlich dumm das man nicht gleich die 2pins 
angehängt hatt, musste erst überlegen was du damit meinst.
4. Sind Eigebaut.
6. Jap könnte man noch einen reinsetzen.

@Achim
Danke dir hab ich behoben :)

Was ich noch geändert hab am Display Pin 15 + 16 richtig an denn Poti 
angeschlossen.

Ich überleg mir noch ob ich einen ISP Anschluss mit ranhänge wobei es 
dann schon ziehmlich voll wird da ich das ganze auf einer normalen 
Streifenraster aufbauen will.

Autor: Tobias G (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi, so nochmal ein kleines Update:

1. Mess-Pin hinzugefügt.
2. In die Spannungsversorgung noch eine Diode eingebaut 
(verpolungsschutz).

Ich glaube ich werte morgen das ganze mal auf der Streifenraster 
umsetzen falls jemend noch einen fehler endeckt..


Mfg Tobias G

Autor: Michael M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mach doch mal ein invoke auf den max. dann musst die spannung nicht so 
"verkrüppelt" hinführen.
deine hintergrundbeleuchtung wird nicht leuchten - du wirst doch wohl 
noch ein paar leds anschließen können???

eine isp auf stiftleisten kann nie schaden, zumal die pins ja sogar noch 
frei sind.

Autor: schwups.... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Tobias G

>In die Spannungsversorgung noch eine Diode eingebaut
>(verpolungsschutz).
 Sehr umsichtig, wenn auch fragwürdig.
-Ein Dreieck ist ein Betriebsspg.-Symbol(ähnlich wie das Masse-Symbol)
 das im Schaltplan aber nicht nochmal auftaucht weil es ja die
 Rohbetriebspannung ist. Sinn ist, für die Betriebsspg. keine
 Leitungen kreuz und quer durch den Schaltplan zu zeichnen wenn
 man Betriebspg. auch an anderer Stelle benötigt. Dadurch werden
 Pläne übersichtlicher wie man das beim Masse-Symbol gut sehen kann.
-Wenn die Rohbetriebsspg. irgendwie angeschlossen werden soll
 (egal ob gesteckt oder gelötet) ist ein mindestens 2pol. Stecker
 oder Buchse nötig, der nachher auch im Layout auftaucht und
 genutzt werden kann, ansonsten wird es keine Anschlußmöglichkeit
 geben, außer man missbraucht den Pad der Verpolschutzdiode und eine
 hauchdünne, mechanisch wenig belastbare Leiterbahn(Masse). Also macht
 eine ordendliche Anschlußmöglichkeit mit + und Masse für die
 Rohbetriebsspg. Sinn, oder nicht?
-Die Pin Nr.15/16 vom Max 232 würde ich noch vervollständigen.

Autor: manateemoo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich kenne das LCD zwar nicht, aber muss die Kontrastspannung wirklich 
positiv sein? (oft ist eine negative Kontrastspannung notwendig)

Autor: Tobias G (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi, so nochmal ein kleines Update ich hoffe das ich deine Punkte so 
verstanden hab wie du es meintest.

Nur was ich nicht verstanden habe ( -Die Pin Nr.15/16 vom Max 232 würde 
ich noch vervollständigen. ) Meinst du ich soll die 2 pins an das 
Dip-Gehäuse antappen, zurzeit sind sie ja mittig gesetzt.

mfg Tobias G

Autor: Achim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit dem von Michael M. schon erwähnten Invoke Befehl kannst du die 
Versorgungsspannungspins des MAX232 auf dem Schaltplan sichtbar machen 
und dann verbinden.

Du hast die Spannung für die Hintergrundbeleuchtung nun ohne 
Vorwiderstand angeschlossen. Das wird diese wahrscheinlich nicht lange 
überleben. Schau mal ins Datenblatt deines Displays welche Daten die 
Hintergrundbeleuchtung hat. Dann kannst du den Widerstand so berechnen, 
wie du es wahrscheinlich bei den anderen LEDs auch gemacht hast.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
C11 ist zu groß, da reichen 10µF. Parallel zu C10 fehlt noch ein 4,7µF. 
C10 allein ist zu wenig. Die beiden Kondensatoren vor und nach dem 7805 
müssen so nah wie möglich an die Anschlüsse des 7805.
Aref wird wohl nicht benötigt, ist aber besser man schließt es an VCC 
an.
An Pin1 (Reset) noch einen 2,2µF gegen Masse schalten.

Autor: Michael M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der letzte post enthält nur falsche tipps.
totaler blödsinn

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
na Michael, der Kindergarten heute geschlossen?
Du solltest deine Ausbildung noch mal wiederholen oder hast du keine?

Autor: Michael M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
soso du trottel, dann pass mal auf:

> An Pin1 (Reset) noch einen 2,2µF gegen Masse schalten.
10k und 2,2uF geben 22ms. versuch damit mal mit nem flotten oder 
billigen isp zu programmieren.

> Parallel zu C10 fehlt noch ein 4,7µF. C10 allein ist zu wenig.
der 7805 is kein LDO, der extern kompensiert werden muss.
außerdem gibt es in der schaltung rein gar nichts, das dicke transienten 
auf der 5V-seite macht.

> Aref wird wohl nicht benötigt, ist aber besser man schließt es an VCC
> an.
Vcc hat an Aref überhaupt nichts verloren.
erstens kann Vcc per fuse als referenzspannung auswählen.
zweitens liegt die ausgewählte ref.-spannung immer an dem pin, damit man 
sie puffern kann. hat man was andres als Vcc als ref,... den rest kannst 
du dir vllt sogar denken.

> Die beiden Kondensatoren vor und nach dem 7805
> müssen so nah wie möglich an die Anschlüsse des 7805.
oha, da hat ja tatsächlich was gestimmt. jetzt sitz ich wirklich in der 
tinte...

Autor: Schwups.... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> Die beiden Kondensatoren vor und nach dem 7805
>> müssen so nah wie möglich an die Anschlüsse des 7805.
>oha, da hat ja tatsächlich was gestimmt. jetzt sitz ich wirklich in der
>tinte...

Das ist nur im Layout relevant. Ich Schaltbild braucht so ein
Sachverhalt gar nicht stehen. Das entnimmt man entweder dem
Datenblatt oder das zeigt die Erfahrung die ja hier sachkundig
weitergegeben wird.
Allerdings würde ich jemandem der sich "Gast" als Nicknamen wählt
nicht mal glauben, das es Nachts dunkel wird.
Gast nennen sich nur Idioten die keine Fantasie und keine Bildung
haben. Große Klappe und nichts dahinter und wahrscheinlich sich
noch feige hinter so einem ausgelutschten Namen zu verstecken.
Kinder, Kinder,....


@ Tobias

Warst ja richtig fleißig mit deinem letzten Update aber
anscheinend haste mich missverstanden. Rohbetriebsspg.
ist die Spg. die vor der Diode von irgendwo her kommt.
Das <<- Symbol wird dir nichts nutzen. Was dort nötig ist,
ist ein Stecker oder ein Buchsen-Symbol mit 2 Kontakten,
oder mit mehreren Kontakten wo nur 2 Pins benutzt werden.
X1 ist so eine Steckverbindung, wenn auch schon etwas
Speziell. In deiner Bibliothek müsste es aber auch
Steckverbinder mit 2 Kontakten geben oder du baust dir
eins selber und fügst das an Stelle des <<- und dem
Masse-Symbol ein, jeweils einen Kontakt für jedes Potenzial.
Im Layout muss dann ein entsprechender Steckverbinder zugeordnet,
platziert und dann angeschlossen werden.
Ich hoffe ich habe mich diesmal verständlicher ausgedrückt.


>Nur was ich nicht verstanden habe ( -Die Pin Nr.15/16 vom Max 232 würde
>ich noch vervollständigen. ) Meinst du ich soll die 2 pins an das
>Dip-Gehäuse antappen, zurzeit sind sie ja mittig gesetzt.

Angetapt haste die ja schon aber für die Schaltplansoftware
im Nirvana(im Nichts). Da muß an dem Max232 ebensolche Pins
mit Nummer beschriftet sein, sonst fehlt das nachher auch im Layout.
Kann sein das die Pin`s als Hidden oder so geschaltet sind
und automatisch über die Betriebsspg.netze(->5V,Masse) verbunden
sind. Wenn nicht, muss man das Symbol für den Max232 in der 
Bibliothek(Editor) noch nachbessern, so das die Pins auch im
Schaltplan zu sehen sind. Einfach nur so an die Symbolkiste
anzutapen hat das keine Funktion.

Autor: Tobias G (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi, so nochmal ein Update:

1. Vom Max232 die hitten pins eingeschaltet und zwar werden die extern 
angezeigt aber im layout passt alles.

2. Bei der Stromversorgung jetzt 2 pins zugefügt.

3. Am Lcd noch einen Widerstand eingefügt.


mfg Tobias G

Autor: Tobias G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sry für die Rechtschreibfehler da ich noch nicht registriert bin..

Autor: Michael M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
an die 5V vom ISP könnte ein jumper nicht schaden. oder auch einfach 
weglassen.
der pin ist nur dazu da, um die schaltung per ISP zu versorgen.

Autor: Tobias G (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Update mit isp jumper.



mfg Tobias G

Autor: Achim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das der VCC Pin des ISP nur zur Versorgung der Schaltung gedacht ist 
stimmt so nicht. Programmer wie der AVR ISPmkII haben einen 
Levelconverter, der die Versorgungsspannung der Schaltung an dem Pin 
erkennt und nicht funktioniert, wenn dieser nicht beschaltet ist. Aber 
mit dem Jumper bist du für alle Fälle gerüstet.

Hast du den Vorwiderstand der Hintergrundbeleuchtung berechnet oder 
nimmst du einfach für alle LEDs 150 Ohm? Bei der Hintergrundbeleuchtung 
ist die Forward Voltage höher, als bei einer z.B. roten LED (siehe 
Datenblatt). Den Widerstand kannst du sicher noch kleiner machen, falls 
du es heller haben möchtest.

Autor: Schwups.... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Tobias

1. Wo denn? Am Schaltbild des MAx232 sehe ich nichts.
Wenn man später mal einen Fehler sucht, muss man sich erst
das Datenblatt raus kramen um zu wissen an welchem Pin welche
Spg.gemessen werden kann.

Sorry für die Rechtschreibung?
Solange sich keiner beschwert
gehts doch.
Andernfalls nimm den Firefox-Browser und installiere eine
Rechtschreibung(Add-on) dazu und gut ist. Mach ich genau so.

Bekommen wir hier auch das Layout zu sehen?

Autor: Tobias G (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi, ich habe das ganze mal rot markiert. Wie schon gesagt hab ich das 
ganze mit dem Invoke Befehl aktiviert(Wird auch richtig im Layout 
angezeigt).
Danke für denn Tipp mit dem Addon.

@Achim, Ich habe denn Widerstand so gewählt weil ich mir noch nicht 
sicher bin wie hell es sein wird. Aber Wahrscheinlich reicht auch ein 
100 Ohm.Eventuell sollte doch wieder ein Potentiometer einbauen um das 
ganze per Hand einzustellen zu können.

Bezüglich dem Layout wie ich schon weiter oben geschrieben hab,baue ich 
das ganze auf eine Streifenrasterplatine auf deswegen ist mir das Layout 
nicht wirklich wichtig.

Autor: Dem Asterix sein Obelix (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Gebilde im Kringel ist jetzt aber nicht Dein Ernst!?
Das geht doch auch übersichtlicher.

Autor: Schwups.... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Tobias


Ist zwar nicht die Norm, aber wenn es funzt, warum nicht?
Immer noch einfacher, als sich wegen eines Bauteils tagelang
mit dem Libraryeditor beschäftigen zu müssen.

Richtig heißt das Add-ons. Das bischen Aufwand sollte
man schon treiben, sonst fragt nur einer nach, was
damit gemeint ist und das muss ja nicht sein, oder?

Ein zusätzlicher Tip(den ich auch hier über das
Forum gelernt habe):
Hinter .,;? immer eine Leerstelle lassen bevor
man ein neues Wort tippt. Das erleichtert den
Zeilenumbruch und verbessert die Lesbarkeit.

@Dem Asterix sein Obelix

ernsthaft?
Die spinnen, die...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.