www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR USB ISP Programmer und connectprobleme


Autor: Fabi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Und zwar ich habe mir einen AVR USB ISP Programmer gekauft von:

Ebay-Artikel Nr. 370248604315

Anleitung war dabei, alles prima (nur das schalterstellung vertauscht 
war in anleitung aber kein problem)

Wenn ich ihn anschließe zeigt mir vista immer welcher virtuelle COM port 
verwendet wird etc.

Wenn ich mit AVR Studio programmiere, dann klappt alles.
Doch wenn ich mit Bascom programmieren will, dann klappts einfach nicht 
und ich weiß einfach nicht woran es liegt.
Wäre echt toll wenn ihr mir vllt weiterhelfen könntet.
im anhang ist mal ein bild von meinen Programmereinstellungen in bascom.
Habe mir dazu eine kleine Platine gebaut wo nur die ganzen mosi,miso etc 
pins angeschlossen sind + spg versorgung vom programmierer.
am reset eingang habe ich keinen pullup widerstand, aber es klappt bei 
avr studio ja auch so.

mfg

Autor: Fabi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
keiner eine idee woran es liegen könnte??

also wie gesagt avr stuido geht des brennen in bascom halt net, wobei in 
der anleitung steht bascom kompatibel

mfg

Autor: Sven B. (svenba)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Hab den gleichen Programmer, nutze aber nur AVR-Studio und da klappt 
alles... Bist du sicher, dass der COM-Port in Bascom mit dem von Vista 
genutzten übereinstmmt? Wenn du die automatische COM-Port Zuweisung von 
Vista nutzt, versuch doch mal manuelle Eingabe.Hba auch gelegentlich das 
Problem, dass AVR-St trotz richtiger Einstellungen nichts findet, dann 
hilft meistens nur USB ab- und anstecken und Software neu starten...

Autor: Fabi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hm ok danke werde des nochmal versuchen, aber ich meine dass es immer 
der richtige com port war.

die programmereinstellungen ist ja richtig oder?
und die stk500.exe kann ja in jedem beliebigen ordner sein und muss 
nicht da wo es in der anleitung steht oder?


mfg

Autor: Fabi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey, habe jetzt nochmal alles versucht, aber i-wie will es einfach nicht 
funktionieren in bascom.

Hat noch jmd eine Idee was ich versuchen könnte?

mfg

Autor: Fabi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
KLAPPT!!

Habe nochmal andere programmer ausprobiert und musste nicht den 
programmer STK500 (req. stk500 exe)

sondern ich musste STK500 native driver!!!

boah war des aber en stress:)

mfg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.