www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik BTM-222 - Hebo Adapter - com problem


Autor: Dave XA (dichterdichter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab jetzt endlich mal Zeit gehabt um Hebos Adapterplatine zu benutzen.
Alles zusammengelötet, angeschlossen.

Die Rote Led leuchtet die orangene blinkt dauerhaft.

Ich erkenne auch ein BT gerät über mein handy / laptop.


die konfigurierung über hypertel klappt aber nicht.
ich hab das board an den arduino USB adapter angeschlossen
-->http://arduino.cc/en/Main/MiniUSB

Ich bekomm keine Antwort auf die befehle
und kann auch nix einstellen. btm-222 antwortet nicht
RX an TX; TX an RX

Heisst das blinken der LED vlt was?



Gruß

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stimmt die Baudrate im Terminalprogramm?

Autor: Dave XA (dichterdichter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab alle möglichen ausprobiert.
angefangen von 19200 mit und ohne flusssteuerung

kann ich die verbindung irgendwie testen ?

Autor: Dave XA (dichterdichter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mist, war grad per BT verbunden, so kann man sich täuschen.

Autor: Dave XA (dichterdichter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, verbindung geht mit einem anderen rechner...
das man immer die verstaubten dinger herausholen muss :-)

gibt aber noch die ERROR meldungen wenn ich was setzen will wie z.B.
ATN=x aber da hab ich schon einige betträge gesehen...

Autor: Dave XA (dichterdichter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab mal rumprobiert und rumgelesen aber keine Lösung für mein Problem 
gefunden.

Unter OSX kann ich keine Verbindung zum BTM-222 aufbauen, liegt 
warscheinl am treiber für den USB adapter.

unter Windows direkt (kein parallels) bekomme ich eine Verbindung.
Es ist schon fast wurst welche baud rate ich einstelle. Er antwortet mir
ob ich die 9600 oder 19200 nehm, egal...

auf AT antwortet er mit OK
auf ATI mit FW:agere softmodem usw.
auf ATI1 mit OK (müsste da nicht ne konfigliste kommen?)

ATN=Name mit ERROR
ATP=0001 mit Error

muss ich die befehle irgendwie beenden oder irgendwas beim eingeben 
beachten?


ich bekomm das ding auf jeden fall nicht konfiguriert.
help ?

Autor: T7890 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo dichterdichter,

ich habe gerade das gleiche Problem.
Bei mir wird auch die Konfiguration nicht rausgeschrieben und auf die 
meisten Befehle gibt es eine ERROR-Meldung. Da ich schon mehrere dieser 
Module im Einsatz habe, denke ich dass ich eines mit einer falschen 
Firmware erwischt habe. Beim Probieren von mehreren Befehlen meldete 
sich das BTM222 bei ATI4 mit "HDA CX11254 Soft Modem".

Hast du das Modul umgetauscht oder gibt es dafür eine Lösung?

Hier noch ein paar Ausgaben des Moduls:

AT
OK
ATI
56000
OK
ATI1
255
OK
ATI2
OK

OK
ATI3
HSF_V7.80.2.51
OK
ATI4
HDA CX11254 Soft Modem
OK
ATI5
256
OK
ATI6
SoftK56
CModem Version 12
Rksample Version 342
OK
ATI7
255
OK
ATI8
Oct 15 2008 # 17:51:27
OK
ATI9
GENERIC
OK



Gruß, T7890

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.