www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR Studio Fehler beim überspielen/ testen


Autor: Alexander W. (syrius)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich versuche zum ersten mal ein Programm in AVR Studio zu testen bzw auf 
das AVR STK500 zu übertragen. Dazu arbeite ich folgendes Tutorial durch
http://www.henkessoft.de/Roboter/stk500.htm

Nun musste ich schon abweichend von dem Skript, zusätzlich den Standort 
der m8515def.inc Bibliothek angeben. Auf dem angehängeten 
Bild(schirmausschnitt) habe ich versucht zu Debuggen ( das Schrittweise 
Debuggen(F11) scheint nicht möflich zu sein). Zu sehen sind  die 
Fehlermeldungen . Zusätzlich weiss ich nciht, ob die ausgwählte Debug 
Plattform richtig ist, darum habe ichs auch noch mit aufs Bild genommen. 
Ansonsten habe ich noch keine Einstellungen vorgenommen. Außer der 
Verkabelung auf dem Board wies im Tutorial zu sehen ist

Falls jemand den (die?) Fehler sieht bitte ich um Response

Grüße
Alex

: Verschoben durch Moderator
Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann den Fehler nicht nachstellen. Mit einem frisch installierten 
AVR Studio (4.17 Build 666) kann man das asm001 Beispiel sofort 
übernehmen. Mann muss nur beim Anlegen des Projektes den AVR Assembler 
auswählen und den µC (Atmega8515). Dann habe ich noch den AVR Simulator 
als Programmiergerät eingestellt. Dann Copy&Paste des Quelltextes. Dann 
Start Debugging...

Vorschlag: AVR Studio deinstallieren, neuste Version beschaffen, 
Installieren.

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Falls jemand den (die?) Fehler sieht bitte ich um Response

Nimm den AVR-Simulator2. Im AVR-Simulator1 must du den Pfad zu 
Includefile komplett angeben. Beim Simulator2 reicht '.include....'

MfG Spess

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte den AVR Simulator (1) genommen und brauchte keine kompletten 
Pfade anzugeben.

Mir ist aber aufgefallen, dass in der Auswahl meines AVR Studios beim 
AVR Simulator 2 das oben bei Alexander sichtbare Preview fehlt, d.h. 
ich habe eine andere (neuere?) Version. Vielleicht wurde der 
Simulator(1) ebenfalls überarbeitet.

Autor: ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte heute genau das gleiche Problem (streng nach Tut gearbeitet, 
dennoch Fehler),
Habe dann die neueste Version installiert, daraufhin lief alles 
Problemlos.

Autor: Alexander W. (syrius)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke die Neuinstallation scheints echt gebracht zu haben. 
Komischerweise habe ich  aber genau die Version 4.13 die auch im Tut 
verwendet wurde auch in Betrieb gehabt.

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>>Falls jemand den (die?) Fehler sieht bitte ich um Response

>Nimm den AVR-Simulator2. Im AVR-Simulator1 must du den Pfad zu
>Includefile komplett angeben. Beim Simulator2 reicht '.include....'

AVR-Simulator2 ist natürlich falsch. Gemeint war AVR-Assembler2. Beim 
AVR-Assembler1 muss der Pfad (auch in Version 4.17) komplett angegeben 
werden. Das das mit einer Neuinstallation klappt, liegt daran, das der 
dort per default eingestellt ist.

MfG Spess

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.