www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik programmiergeräte


Autor: ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi, ich habe mit der mikrocontrollerprogrammierung angefangen und schon 
die ersten tests durchgeführt. ich selber besitze und benutze das 
myavrmultiprog. nach einer mühseligen installation und in betriebnahme 
hat es endlich funktioniert. jetzt habe ich es seit montag nicht mehr 
benutzt. wenn ich jetzt mit dem avr studio meinen controller flashen 
will sagt mir das avr studio das es mein board nicht findet.

im weiterne habe ich jetzt das myavr mk2 mit usb ausgeliehen bekommen 
dies ebenfalls installiert. dieses gerät funktioniert jetzt. hat es was 
mit meinem problem zu tun?? wie kann ich mein problem lösen sodass ich 
mein myavrmultiprog benutzen kann??

noch ein kleiner hinweis mein multiprog hat vor der installation des mk2 
bereits nicht funktioniert.

bitte helft mir. ich interessiere mich sehr für die mikrocontroller, 
aber die installation der einzelnen komponenten verdirbt einem den spaß

lieben gruß und danke im vorraus

Autor: Bernd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier ein Link, der dir sicher helfen wird. 
http://www.duden.de/deutsche_sprache/sprachberatung/

Autor: Axel Krüger (axel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mal Geräteeinstellung bzgl. Com port prüfen (Systemsteuerung <-> AVR 
Studio)

Autor: ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi ich habe das board jetzt ans laufen bekommen. ich habe den 
comanschluss gewechselt. zuerst hatte ich noch eine fehlermeldung beim 
flashen, aber diese war nach einem neustart behoben. doch das avr studio 
hat probleme beim flashvorgang. es bleibt immer das alte programm auf 
dem controller. mache ich etwas falsch wenn ich das projekt speicher und 
dann einfach mit dem avrprog den mikrocontroller flashe? bei meinen 
ersten anfängen hat dies immer funktioniert. habt ihr da vielleicht eine 
lösung??

lieben gruß

Autor: Peter R. (pnu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist eben eine Eigenheit des AVR Studio, dass es das jeweils 
letztbenutzte .hex file als default benutzt. Die Mühe, das jetzt 
aktuelle .hex-file einzugeben bleibt nicht erspart.

Bei einem STK 500 hat es im von Studio angezeigten Bedienmenu des 
Programmers die Angabe des aktuellen .hex-file und daneben ein Feld mit 
drei Punkten, über das man browsen kann, also das neue file im 
entsprechenden Ordner suchen und öffnen kann.

Im Bedienfeld von myavrmultiprog dürfte es so eine Funktion ( hex-file 
wählen) ebenfalls geben

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.