www.mikrocontroller.net

Forum: PC-Programmierung BASCOM und AVR-ISPmkII - kein connect


Autor: Paul Ehrlich (banditavr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
habe Probleme mit meinem AVR-ISPmkII (USB) von BASCOM auf meinen 
ATMEGA128  zu connecten.
Unter AVR-Studio funktioniert alles. Hardwareprobleme also 
ausgeschlossen.
Den Programmer habe ich ausgewählt und auch unterschiedliche 
Taktfrequenzen probiert.
Das device wird einfach nicht erkannt.
Die Grün/Rote Dual LED zeigt übrigens "grün", das sollte eigentlich 
bedeuten, dass die Zielhardware richtig erkannt wird???
Wenn ich gezielt einen falschen Programmer auswähle, wird das auch so 
mitgeteilt.
Da dieser Hinweis auf einen falschen Programmer (bei richtiger Auswahl 
im Menü) fehlt, nehme ich an, dass der Programmer schon erkannt wird, 
aber die Kommunikation mit dem Device nicht funktioniert.
Bin im Moment ratlos.
Da aber alles unter AVR-Studio funktioniert, habe ich sicher irgendeine 
Einstellung falsch gemacht.
Kann mir da jemand "auf die Sprünge" helfen?
Eine Suche im Board hat mir da auch keinen Hinweis gebracht.

Danke schon mal.

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hatte das selbe Problem. Mit der Bascom Version 1.11.9.5 geht es.
Ich konnte diese Version vorerst aber nur als Demo Dowmloaden.
Ich habe dann die Datei 'Bascavr.exe' meiner Vollversion durch die 
gleichnamige Datei aus der Demo ersetzt. (Vorher unbedingt 
Datensicherung
durchführen!!)
Bei den Vorgängerversionen wurde die ISP-Frequenz im Programmer durch
Bascom immer auf 8 MHZ verstellt.

Gruß Jürgen

Autor: Paul Ehrlich (banditavr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Problem geklärt.
Habe die Datei setuplibusb.exe bekommen (ist offenbar leider nur bei der 
Vollversion dabei).
Nach Aufruf sieser exe ist der Programmer auch unter der demo 
funktionsfähig. :-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.