www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik rs485 verkabelung


Autor: sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich tausche Daten zwischen einem PC (Master) und zwei Mega88 (Slaves), 
mittels des RS485 aus. Die serielle Schnittstelle des PC's (Master) 
steuert ein RS232 zu RS485 Wandler (MAX 232 / MAX 490) an, die Slaves 
verfügen über einen MAX 490 welche auf den USART des jeweiligen Mega88 
geschaltet ist.

Das funktioniert auch alles ganz gut, allerdings nur wenn die 
Leistungslänge wenige cm lang ist. Wenn ich einen Slave über ein 4 Meter 
langes altes Netzwerkkabel (CAT 5) verbinde findet keine Kommunikation 
mehr statt.

Ich versuche dies nun schon seit zwei Wochen hin zubekommen, leider ohne 
Erfolg. Habe alles Überprüft, die Slaves sind von der Hard- und Software 
identisch (bis auf das der eine Slave die Devicenummer 1 hat und der 
andere Devicenummer 2). Mein Protokoll ist sehr Simpel (Master / Slave), 
der jeweilige Slave antwortet nur wenn es vom Master gefragt wird. 
Derzeit bei 9600 Baud. Ich kann auch die Slaves untereinander 
austauschen, alles funktioniert, sofern die Leitungslänge nicht länger 
als weniger cm beträgt. Habe auch die Verkabelung x mal überprüft 
(A,B,Y,Z) usw., leider ohne Erfolg.

Habe auch die enstechenden Terminierungs-Widerstände eingebaut, derzeit 
jeweils an den "Enddevices" von 120 Ohm. Leider unterscheiden sich 
diesbezüglich diverse Datenblätter und Internetbeiträge.

Ich hoffe mir kann jemand einen Rat geben. Danke

Autor: roffez (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Poste doch mal deinen Schaltplan. Ich vermute hier ist was im 
Argen....hast Du Failsafe-Pullup/Pulldown-Widerstände an den RS485 
Leitungen angebracht? So ca. 620 Ohm, die eine Leitung gegen VCC die 
andere gegen GND (googel mal welche Leitung wohin muss, Stichwort "open 
failsafe"). Das verhindert empfangenen Blödsinn wenn kein Sender aktiv 
ist.
Noch ein Tip: Sind die richtigen Leitungen miteinander verdrillt?
Sollte bei 4m/9600bps aber auch so gehen, die Datenrate bzw. Entfernung 
ist lächerlich. Ich mach hier 10 MBit über 100m CAT5 störungsfrei.

Autor: RAY (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

4m bei 9600baud sollte für RS485 kein Problem sein - wo hängt denn der 
dritte Baustein? Du hast ein Ende mit z.B. PC, ein Ende mit einem MAX 
und dazwischen irgendwo den dritten MAX. Abgeschlossen wird normal an 
beiden Enden des Kabels, nicht bei den Bausteinen dazwischen (siehe auch 
Bild 22 im Datenblatt) - Ansonsten Versorgung OK? keine Masseschleifen? 
kein unterbrochener Leiter oder vertauschte A/B-Leitung?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.