www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Tektronix 2445B - y-Verstärker CH1/2 fehlerhaft?


Autor: Stephan M. (stephanm)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich habe ein Problem mit meinem Tektronix 2445B: Das dargestellte Signal 
wird in y-Richtung nichtlinear verzerrt. Als Beispielbild hab ich die 
Anzeige eines Sinus (f=3.6kHz, aus einer Wienbrücke) angehägt. Das 
Problem tritt auf den Kanälen 1 und 2 gleichermassen auf, nicht aber auf 
den (Logik-)Kanälen 3 und 4 (dort sehe ich einen sauberen Sinus).

Beim Verschieben des Signals in y-Richtung treten gar lustige Effekte 
auf - in der Bildmitte wird das Signal z.B. mit 1 Div Höhe als etwas 
abgerundetes Dreieckssignal angezeigt, beim verschieben nach oben oder 
unten ändert sich die Höhe bis auf 2.5 Div und man erkennt wieder was 
vom Sinus. (Bei Interesse poste ich weitere Bilder oder vielleicht mal 
ein Video :-)

Mit der tatsächlichen Signalamplitude hat das allerdings fast garnix 
mehr gemeinsam - statt 400mV Spitze-Spitze (wie auf dem Bild) hat das 
Signal eigentlich > 1.3V S-S.

Auffällig ist auch, dass die y-Positionsregler für CH1/2 den Strahl nur 
noch bis kurz unter/über die Oberkante/Unterkante schieben können. Bei 
CH3 und CH4 kann ich eine Nulllinie über den gesamten Schirm schieben, 
ohne oben und unten hängen zu bleiben.

Ich frag mich nun ernsthaft, was da defekt sein könnte und ob sich ggf. 
eine Reparatur lohnen würde. Meinungen?

Dankeschön,

Stephan

Autor: Phil J. (sunflower_seed)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guck doch selber mal nach.
Meistens sind es die üblichen verdächtigen.
Elkos, Transistoren oder Dioden.
In deinem Falle würde ich mal die Lötstellen prüfen.
Vielleicht haben Kanal 1 + 2 den selben Vorverstärker.
Das Board wäre zu prüfen.

Autor: Stephan M. (stephanm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Kanal 1 und Kanal 2 haben getrennte Vorverstärker. Schematisch siehts 
pro Kanal so aus: BNC-Buchse -> Abschwächer -> Vorverstärker -> 
Kanalschalter. Beim Kanalschalter laufen alle 5 (4 Kanäle + Readout) 
Eingangskanäle zusammen.

Ich hab mich jetzt doch mal mit meinem Uralt-Oszi an die Innereien des 
2445B getraut. Hinter dem Abschwächer hab ich noch nen Sinus, nach dem 
Kanalschalter nicht mehr. Zwischen Abschwächer und Kanalschalter gibts 
leider keinen zugänglichen Testpunkt, also kann ich so nicht 
feststellen, bei welcher der beiden Komponenten der Fehler liegt.

Allerdings ist die Verzerrung bei CH1 und CH2 praktisch identisch, denn 
wenn ich CH1/2 mit dem selben Signal füttere, decken sich beide Signale 
auf dem Schirm. Ich würde daher schätzen, dass der Kanalschalter den 
Defekt verursacht, da doch ansonsten beide Eingangsverstärker exakt den 
selben Fehler (qualitativ wie quantitativ) hätten?

Stephan

Autor: Ingo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

im Netz findest Du irgendwo ein Service Manual zum 2445 (ohne B) mit 
Schaltplänen als pdf. Das ist zwar nicht voll identisch mit dem 2445, 
hilft aber bei der Suche nach den Netzteilspannungen usw. Die 
Versorgungsspannugen würde ich zuerst überprüfen.
Alle Netzteilspannungen lassen sich auf der Hauptplatine an einem 
DIP14-Sockel messen (siehe Anhang).

Gruss, Ingo.

Autor: Stephan M. (stephanm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Ingo

Danke für den Tip und die Tabelle, das Service Manual hab ich sogar. Die 
Spannungen sind alle ok, sie liegen wunderbar im Toleranzbereich.

Die Anzahl der diskreten Komponenten rund um den Kanalschalter ist super 
gering: für diese Hybridschaltung sind nicht mal eigene 
Abblockkondensatoren vorgesehen. Inzwischen bin ich eigentlich der 
Meinung, dass es am Kanalschalter liegen muss - vor dem Kanalschalter 
sehe ich überall wo ich hinkomme ein sauberes Signal, dahinter nicht 
mehr.

Stephan

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ TE:

Du tauscht den defekten U400 gegen einen korrekt funktionierenden und 
wirst feststellen: Genau dieser Hybrid ist die Ursache für den Fehler in 
Deinem Scope.

BTDT.

> ... eine Reparatur lohnen würde?

Auf jeden Fall lohnt die, ist ja ein super Gerät.


hth,
Andrew

Autor: Stephan M. (stephanm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Andrew Taylor
Danke für die Info. Kennst Du eine zuverlässige Bezugsquelle für das 
Ding?

Stephan

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na klar: Ikke.  ,-)

Schick mir einfach PN für den Rest, dann können wir die Details klären.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.