www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik mit BUZ 11a eine Batterie laden


Autor: Erba57 Ba (orfix) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte mit einem BUZ 11a eine Batterie laden. Zwischen Drain und 
Gate befindet sich ein 47K Widerstand. Am Buz sind 3 Volt 
Spannungsabfall, ich dachte immer FET sind niederohmig?
Wenn ich den Widerstand überbrücke wird der Ladestrom auch nicht 
grösser, wo ist nun mein Fehler?

mfg

orfix

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Erba57 Ba (orfix) Benutzerseite

>Wenn ich den Widerstand überbrücke wird der Ladestrom auch nicht
>grösser, wo ist nun mein Fehler?

Dir fehlen elementare Grundlagen. Lass die Finger davon oder bilde dich 
erst einmal.

MFG
Falk

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie schaut denn der Rest der Schaltung aus? Zwischen Drain und Gate 
könnte auch ne Spule sitzen mit lila Anstrich. Dann kann man immer noch 
nicht sagen, was stimmt und was nicht.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein paar kleine Tips:

Batterie sollte zw. Plus und Drain hängen, nicht zw. Source und Masse.

Verwende ein Poti < 10 kOhm am Gate also 2 äußeren Anschlüsse einmal auf 
+ und - und den Mittelabgriff aufs Gate. Je nachdem wie rum die die 2 
äußeren Anschlüsse anklemmst entscheidest du ob bei einem recht- oder 
linksdreh die Spannung am Gate steigt. Da Fets Spannungsgesteuert sind 
und eine Gatekapazität besitzen bleiben die meist leitend wenn du einem 
Spannung an das Gate gegeben hast deswegen ein Pulldown oder gleich ein 
Poti verwenden

Da die diesem Fall der Transistor im Linearbetrieb arbeitet und eine 
leere Batterie eine hohe Last darstellt, wird der Transistor sehr heiß 
werden und warscheinlich auch über den Jordan gehen.

Meine Glaskugel hat gerade Urlaub, deswegen weiß ich nicht um was für 
eine Batterie(Spannung, Kapazität) es sich handelt, welches 
Spannungs/Stromquelle zur Verfügung steht..... ein paar Infos wären also 
sehr nützlich falls man dir helfen soll.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Zwischen Drain und
>Gate befindet sich ein 47K Widerstand. Am Buz sind 3 Volt
>Spannungsabfall, ich dachte immer FET sind niederohmig?
Unter den Bedingungen verhält sich der völlig richtig.
Der FET benötigt eine Gate-Source-Spannung von mehrern Volt, um komplett 
aufzusteueren. Wenn du D und G mit R überbrückst, dann würde ja bei ganz 
durchgeschaltetem FET an D und S (fast) dieselbe Spannung liegen, was 
auch heißt, dass der FET eigentlich fast 0V UGS hat, also nichtleitend 
ist. Das widerspricht sich! Deshalb stellen sich die rund 3V ein, die 
dann auch als UGS anliegen und so noch einen Strom fließen lassen.

Du musst die Gate-Spannung immer mindestens 5-10V über dem Potential der 
Source halten, dann gehts ....

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
da der Verbraucher zw. Plus und Drain hängt musst du deine Spannung für 
das Gate zw. Plus und Verbraucher abnehmen.

Habe letztens erst eine Linearregler für einen Lüfter gebaut war auch 
ein BUZ11 oder ein IRF540.

Zeichen doch mal auf wie du was angeschlossen hast.

Autor: Erba57 Ba (orfix) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

vielen danke für die hilfe, bin echt überrascht für die tolle 
unterstützung.

hab nun die batterie zwische drain / + und den Widerstand auf + jetzt 
sind es nur noch 3 mV spannungsabfall.

dank an HildeK (Gast)

wollte nun mit einen ausgang vom atmega den bc337 ein und aus schalten, 
an der basis sind aber immer noch 0,7 Volt wenn der ausgang AUS ist.

wer kann wieder helfen?

mfg

orfix

Autor: Artjomka (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In deiner Schaltung fehlt eine Strombegrenzung (bis auf den 1 Ohm 
widerstand).

Welche spannung misst du denn am ausgeschalteten AVR Ausgang? Immernoch 
5V? Dann hat das Ausschalten nicht funktioniert.

Ein BUZ11 ist ein MOSFET und kein JFET (Schaltzeichen). Der 1 Ohm 
Widerstand ist doof platziert, ich würde den in die + Leitung legen 
(auch wenn es in dem Fall wahrscheinlich nicht viel aus macht).

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das ganze funktioniert aber auch ohne den BC Transistor. Man kann den 
BUZ11A direkt vom µC-Pin ansteuern, als Widerstand würde ich dann aber 
1-2 kOhm nehmen. Mit 10V erreicht er halt erst seinen niedriegen RDSon 
Wert von 0,045 Ohm

Schau dir mal im ST Datenblatt das Diagramm Output Characteristics an. 
Da siehst du wieviel Spannung du am Gate benötigst um einen bestimmten 
Strom bei einer bestimmten DS-Spannung fließen zu lassen.

Häng mal zw. A2 und A10 ein Amperemeter und schau dir mal an wieviel 
Ladestrom du auf den kleinen Akku gibst, da bei einer 24V Quelle schon 
einiges fließen sollte. Oder Taktest du den FET an um den Ladestrom zu 
verringern?

Autor: Erba57 Ba (orfix) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

vielen Dank für die Antworten.

@ Artjomka:

Schaltzeichen muss ich noch ändern. Am Shunt wird der Ladestrom 
gemessen, meine ist im Minuszweig besser?

@Kosmos:

hab den BC Tran. entfernt, nun funktioniert das ein / aus schalten.
Wenn ich das NT auschalte, wird Spannung zurück gespeist, also wird die 
Batterie entladen. Hab das Gate auch schon auf Masse gelegt, aber es 
wird immer noch Spannung zurück gespeist. Der buz müsste doch hochohmig 
sein?

mfg

orfix

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der Widerstand R2 muss vom Gate gegen Source geschalten werden und dann 
vom µC Pin direkt auf das Gate gehen, evtl. nochmal 1 kOhm zw. Gate und 
µC Pin damit dieser nicht überlastet wird. Du brauchst keine Spannung 
von der Batterie auf das Gate geben.

Autor: Artjomka (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
orfix mit dem 10k widerstand r2 holst dir die 12V an deinen AVR pin, das 
ist nicht gesund. der sollte gegen source geschaltet sein.

Ein FET sperrt nur in eine Richtung, in der anderen richtung ist er 
leitfähig (body-diode).

Autor: Erba57 Ba (orfix) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas und Artjomka, vielen Dank für die schnelle Hilfe.

Hab die Schaltung nach eueren Vorschlägen umgebaut, funktioniert super.

Nun mein nächstes Problem:

Mit den Multimeter messe ich am Shunt zwischen 82,8mA und 83,7mA.
Bei meiner Messung mit den Atmega toggelt das Display zwischen 0,019 bis 
0,185.
Messe ich z.B. die Atmega Versorgungsspannung  zeigt das Display 4,995 
an. Auch mit den Ozi messe ich 0,22 mV (Sägezahn) am Shunt.

Wie kann ich eine stabile Strommessung am Shunt erreichen, Softwaremäßig 
oder mit R/C Glieder?


Mit freundlichen Grüßen

Orfix

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
den 1 Ohm Shunt was du da drin hast würde ich zwischen a2 und a10 setzen 
sieht irgendwie besser aus wenn das direkt in der Zuleitung am 
Verbraucher dranhängt und nicht in der Masseleitung.

Ja wenn deine Stromwerte springen schalten du zum Messgerät einen 
Widerstand in Reihe und einen Kondensator parallel. 1 kOhm und 100nF 
könnten schon reichen ansonsten eine Hälfte eines Potis statt den 
Widerstand benutzen z.B. 10 kOhm Poti.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
per Software gehts natürlich auch du musst je nach Abtastfrequenz mehre 
Messwerte addieren und dann wieder durch die Anzahl der Additionen 
teilen.

z.B. 127+128+126+127+128+130+125+124 = 1015 / 8 = gerundet 127

Ich würde es in Hardware machen dann braucht sich der µC nicht darum 
kümmern, also Poti plus Kondensator. Zu dem oberen Beispiel anstatt den 
Potiwert zu erhöhen kannst du auch einen größeren Kondensator einbauen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.