www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik DC DC Converter Problem!


Autor: M. L. (pioneer)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

ich habe ein problem mit dem dc/dc converter TPS61032 von TI.

ich habe bereits den dritten IC in meinem versuchsaufbau geschrottet, 
weiß aber nicht warum :-( die teile sind ja auch nicht ganz billig

beim anlegen an spannung (ca.3V, strombegrenzung 10mA) bekomme ich einen 
satten kurzschluss, der aber nicht von meiner aussenbeschaltung sein 
kann.

der kurzschluss ist nach dem test immer am IC zwischen PIN 1/2 und PGND. 
vor dem test ist dieser pfad jedoch hochohmig.

meine aussenbeschaltung ist identisch mit dem sich im anhang befindlich 
datenblatt (siehe seite 16 oben)

kann mir jemand einen tip geben? muss ich besondere bauteile verwenden?

danke im voraus

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielleicht kann Deine Drossel nur 50Hz :-(
wie Du allerdings mit 10mA den IC schrotten willst, kann ich nicht 
nachvollziehen.

Autor: Polly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... problem mit dem dc/dc converter ...

Du hast auch ein Problem mit der Groß-/Kleinschreibung.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Datenblatt sieht OK aus....

Wie sollen wir dir weiter helfen?
Poste mal deinen Schaltplan, Layout und ein Foto von dem konkreten 
Aufbau?

Autor: M. L. (pioneer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das ist eine induktivität mit 100kHz testfrequenz, speziell gedacht für 
DC DC converter beschaltung

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ohne jetzt alles durchzulesen:
das Ding taktet mit 600 kHz.
Hast Du überhaupt die Erfahrung/Ausrüstung (Oszi?) sowas zu 
bauen/testen?
Was heißt denn Kurzschluß bei 10 mA? Du weißt schon wie ein 
Hochstzsteller arbeitet, oder?

Autor: M. L. (pioneer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja klar ausrüstung ist komplett.
erfahrung, naja eher weniger. es ist mein erster kontakt mit DC DC 
convertern

ich habe an meinem labornetzteil 10mA als strombegrenzung eingestellt, 
damit mir die schaltung im fehlerfall nicht um die ohren fliegt.

beim testen der DC DC schaltung lag nach anlegen der spannung ein 
Kurzschluss vor -> also 0V, 10mA an der labornetzteilanzeige

Autor: M. L. (pioneer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die schaltung ist auf einer SMD-universalleiterkarte aufgebaut. die 
flächenabmaße der schaltung betragen ca. 3cm x 3cm

Autor: Yago Shep (yago)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und woran hast du erkennt dass das IC defekt ist?
Evtl ist es auch ein Kurzschluss auf der Platine, oder der Regler wurde 
verkehrt herum eingelötet...
Foto wäre nützlich, wie schon oben geschrieben

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1.Selbst wenn die Schaltung 100% richtig sein sollte, kann der Aufbau 
total falsch sein.

2.Evtl. hilft ein Labornetzteil mit Strombegrenzung die weiteren Opfer 
in Grenzen zu halten ?

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn dieser "Kurzschluß" im 600 kHz-Takt erfolgt, ist doch alles i.O.
Du mußt mal etwas mehr Infos über Hochsetzsteller einholen. Die ICs 
leben garantiert alle noch. Du mußt vor dem Messen wissen, was 
rauskommen soll.

Autor: .... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> beim testen der DC DC schaltung lag nach anlegen der spannung ein
> Kurzschluss vor -> also 0V, 10mA an der labornetzteilanzeige

Du schreibst zwar nicht welche Last angeschlossen war, aber selbst im 
Leerlauf dürfte die Schaltung eine höhere Stromaufnahme als 10mA 
besitzen, vor allem im Anlaufmoment.
Kein Wunder, dass dein Labornetzteil in die Strombegrenzung geht.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
2. ist erledigt
3. Glaskugel meint Masseproblem untersuchen ? Power + Logikmasse?
oder einfach fertigen DC/DC benuten (Auge zu Sander)

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Das Datenblatt sieht OK aus....
>Wie sollen wir dir weiter helfen?
>Poste mal deinen Schaltplan, Layout und ein Foto von dem konkreten Aufbau?

Lass mal ein paar Bilder herüberwachsen. So ist es nur Stochern im 
Trüben!!!

Autor: M. L. (pioneer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yago Shep schrieb:
> Und woran hast du erkennt dass das IC defekt ist?

ich hab die ICs ausgelötet und einen 0-Ohm Durchgang zwischen SW und 
PGND gemessen. Bei den unberührten ICs ist diese Strecke im M-Ohm 
Bereich.

Autor: M. L. (pioneer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yago Shep schrieb:

> Evtl ist es auch ein Kurzschluss auf der Platine, oder der Regler wurde
> verkehrt herum eingelötet...


diese Fehler schließe ich aus

Autor: M. L. (pioneer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
faraday schrieb:
> wenn dieser "Kurzschluß" im 600 kHz-Takt erfolgt, ist doch alles i.O.
> Du mußt mal etwas mehr Infos über Hochsetzsteller einholen. Die ICs
> leben garantiert alle noch. Du mußt vor dem Messen wissen, was
> rauskommen soll.

bis jetzt konnte ich noch garnichts messen. die Schaltung ist 1:1 nach 
der Vorgabe im Datenblatt mit den entsprechenden Bauelementen aufgebaut. 
wenn ich die Schaltung im Leerlauf in Betrieb nehme, dann zieht mir die 
>200mA
am Ausgang kommt garnichts

Autor: M. L. (pioneer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
.... schrieb:
>> beim testen der DC DC schaltung lag nach anlegen der spannung ein
>> Kurzschluss vor -> also 0V, 10mA an der labornetzteilanzeige
>
> Du schreibst zwar nicht welche Last angeschlossen war, aber selbst im
> Leerlauf dürfte die Schaltung eine höhere Stromaufnahme als 10mA
> besitzen, vor allem im Anlaufmoment.
> Kein Wunder, dass dein Labornetzteil in die Strombegrenzung geht.

Schaltung hab ich ohne Last getestet. Der Strom ist >2000mA, höher wollt 
ich nicht gehen

Autor: M. L. (pioneer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oszi40 schrieb:
> 3. Glaskugel meint Masseproblem untersuchen ? Power + Logikmasse?

PGND und GND sind miteinander verbunden

Autor: M. L. (pioneer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab jetzt leider keine Kamera zur Hand. aber werd evtl heut 
nachmittag welche reinstellen

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>wenn ich die Schaltung im Leerlauf in Betrieb nehme, dann zieht mir die
>200mA

Elko defekt/falsch rum?
Dann mußt Du eben Stück für Stück ablöten und wenn möglich unbestückte 
LP messen.

Autor: M. L. (pioneer)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hier ein bild meiner schaltung
hab sie nochmal auf eine andere leiterkarte mit neuen Bauelementen 
bestückt.
funktionstest ist wieder negativ ausgefallen :-(

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
M. L. schrieb:
> ...
> ich habe an meinem labornetzteil 10mA als strombegrenzung eingestellt,
> damit mir die schaltung im fehlerfall nicht um die ohren fliegt.

Das muß nicht vor durchgebrannten ICs schützen, weil die
möglicherweise schon in den ewigen Schaltgründen sind, bevor der
Stromregler reagiert.
Bevor du noch 10 Stück negativ testest, würde ich einfach eine
flinke Feinsicherung in die Zuleitung hängen; die ist billiger
als der Wandler. Seit ich das regelmäßig mache, ist mein
Materialverbrauch deutlich gesunken.

> ...

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles klar, die ganze herumdiskutiererei hätten wir uns sparen können.
Der Aufbau geht so nicht!!!
(Übrigens auch nicht die 1MB je Bild /PDF -> schau dir die Forumsreglen 
nochmal an)

Du lernst gerade, dass es einen Unterschied zwischen Schaltplan und 
Layout gibt, sowie idealen wie realen Bauteilen gibt.

- Es fehlt einer der beiden Kondensatoren (Vermutlich Eingangs-C )
- Die Leitungslängen gehen garnicht -> zu viel Streuinduktivität (der 
TI-Regler stirbt bestimmt aufgrund von Überspannung direkt beim ersten 
oder zweiten Schaltvorgang)

Das folgende PDF zeigt das Layout des EvaKits. Ist zwar nicht viel 
beschrieben aber zumindest gibt es schon mal einen optischen Unterschied 
zwischen Deinem Layout und dem TI-Design:
http://focus.ti.com/lit/ug/slvu080a/slvu080a.pdf

Autor: M. L. (pioneer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael O. schrieb:
> Alles klar, die ganze herumdiskutiererei hätten wir uns sparen können.
> Der Aufbau geht so nicht!!!
> (Übrigens auch nicht die 1MB je Bild /PDF -> schau dir die Forumsreglen
> nochmal an)

hätt ich mir denken können...sorry

> Du lernst gerade, dass es einen Unterschied zwischen Schaltplan und
> Layout gibt, sowie idealen wie realen Bauteilen gibt.
>
> - Es fehlt einer der beiden Kondensatoren (Vermutlich Eingangs-C )
> - Die Leitungslängen gehen garnicht -> zu viel Streuinduktivität (der
> TI-Regler stirbt bestimmt aufgrund von Überspannung direkt beim ersten
> oder zweiten Schaltvorgang)

Das ist doch mal eine gute Nachricht!! Ich war schon fast am Verzweifeln 
weil ich keinen Fehler finden konnte.
Den Eingangs-C hab ich weggelassen. Aber auch mit C schmiert mir der IC 
ab.

Ich hab mit DC DC Schaltungen und Layouterstellungen leider noch keine 
großen Erfahrungen. Ich hätte nicht gedacht, dass diese Schaltungen so 
empfindlich reagieren.

Dieser provisorische Aufbau soll nur dem Testen dienen. Später soll eine 
4-layer Karte mit einer Menge anderen Funktionen erstellt werden.

Was meinst du. Kann ich diesen Testaufbau wieder so auf diese "meine" 
Weise bauen, halt nur mit mehr Anlehnung an das EVA-Kit-Layout, oder 
sollte ich mir die EVA-Karte besorgen??

Ich möchte auf jeden Fall meine Teilschaltungen testen, bevor ich eine 
teure 4-layer Karte anfertigen lasse.

Danke nochmal für deinen Hinweis!

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nach Deinem Aufbau zu urteilen, könnte ein bißchen mehr know-how nicht 
schaden.
Suche Dir einen langsamer taktenden IC (50 kHz oder so) und bringe alles 
schön dicht zusammen (besonders die Leitungen, wo schnell viel 
Stromänderung erfolgt). Dann kriegst Du das auch mit so einem 
Provisorium zum Laufen. Mit den Erfahrungen kannst Du dann weitermachen.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch an einem schlechten Beispiel kann man viel lernen. :-)
Spare mit Draht, aber nie mit Abbock-Cs.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das eigentliche Problem in deinem Fall sind die Leitungslängen.
Jede Leiterschleife (und einige cm Kabel die eine Fläche einschließen 
sind sowas) bildet eine Induktivität.
Da deine Drossel einen Induktivitätswert im (ich rate nur) 1..5 uH hat, 
sind die Induktivitäten der Zuleitungen nicht mehr klein gegenüber der 
Speicherdrossel. Damit wird hier ein Teil der magnetischen Feldenergie 
gespeichert und im Abschaltmoment in Form einer Überspannung wieder 
frei.
Der Schaltregler kann mit deinem MOSFET nicht mehr als ca. 7-10V 
vertragen. Diese Spannung ist sehr schnell erreicht...

Designregeln:
1. Strompfad für die Leistung soll möglichst kleine Flächen einschließen
2. Kondensatoren möglichst dicht an die Komponenten führen
3. Rückstrompfad nicht vergessen (am Besten mindestens zweilagig und 
Massefläche ohne große Einschitte im Bereich des Strompfades)
4. Kondensatoren mit niedrigem ESR verwenden (auch Kombiniert)
5. Kückkoppelpfade störungsfrei abgreifen


Das war beispielweise eins meiner Designs (+24V => +5V / 3A)
Beitrag "LM3150 - Simple Switcher nicht ganz so simpel"

Autor: .... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was mir in deinem Bild vom Aufbau erst mal auffällt ist:

Dein Feedback-Kreis fehlt völlig!

Les dir bitte mal Seite 13 des Datenblattes durch. Auf der Seite ist 
auch eine typische, vor allem vollständige, Applikationsschaltung 
gezeichnet.
Du kannst R3,R4 nicht einfach weg lassen!!
In den restlichen Applikationsschaltungen hat TI diese beiden Rs weg 
gelassen, weil es klar ist, dass die vorhanden sein müssen.(dumme 
Angewohnheit von TI)
Was du weg lassen kannst (hast du ja auch gemacht) sind R1, R2 und R6, 
da diese nur einen Komparator zur Low-Batterie erfassung betreffen.

Autor: M. L. (pioneer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
.... schrieb:
> was mir in deinem Bild vom Aufbau erst mal auffällt ist:
>
> Dein Feedback-Kreis fehlt völlig!

versteh ich nicht.
TI schreibt doch, das FB nur für Typen mit einstellbarer Spannung 
beschaltete werden muss
ich habe einen TPS61032, der sollte 5V stabile Ausgangsspannung haben, 
ohne FB-Beschaltung

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann er tatsächlich weglassen => Figure 19 auf Seite 16.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Designregeln: ...
Wer lieber Bilder hätte, kann dort mal schauen ;-)
http://www.lothar-miller.de/s9y/categories/40-Layo...

Autor: .... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ups, sorry, habe ich überlesen..

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.