www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Funktionsgenerator


Autor: Simon A. (bullwai)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

bräuchte Hilfe bei meinem Funktionsgenerator, den ich vor einer Wochen 
entwickelt habe!

Der Funktionsgenrator wurde mit einem XR2206- Baustein realisiert. Nun 
habe ich die gefertigte Platine ordnungsgemäß aufgebaut und ausgetestet. 
Bei dem Funktionstest trat jedoch eine Problem auf. Der XR2206- Baustein 
zieht zu viel Strom (90mA). Der LM393 und der LM318 ziehen zusammen ca. 
20mA. In der Schaltung im Anhang ist der LM318 eigentlich ein LM358 oder 
so. Hab nur nach einem gleichen Gehäuse gesucht, weil ich zu faul zum 
Selbstzeichnen war (Pinbelegung nach LM318).

Vor einer Woche habe ich eine Beispielschaltung aus einem Datenblatt des 
XR2206 aufgebaut, welche einwandfrei funktionierte. Daraufhin habe ich 
die Beispielschaltung erweitert und eine Platine fertigen lassen.

mfg Gabriel

Autor: Schrotty (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und was ist deine Frage?

Autor: Ingolf O. (headshotzombie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schrotty schrieb:
> Und was ist deine Frage?

Vermutlich, warum der XR 90mA Stromaufnahme hat...

Autor: Simon A. (bullwai)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schrotty schrieb:
> Und was ist deine Frage?

Sorry,
hab sie aus reiner Verwirrung vergessen!

Schrotty hats auf den Punkt getroffen!
Der XR2206 zieht einfach zu viel Strom und ich wollte jetzt von euch 
wissen, ob das vielleicht an meiner Schaltung liegen könnte!

Wäre sehr erfreut, wenn ihr mir helfen könntet!

mfg Gabriel

Autor: Ingolf O. (headshotzombie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gabriel G. schrieb:
> Schrotty schrieb:
>> Und was ist deine Frage?
>
> Sorry,
> hab sie aus reiner Verwirrung vergessen!
>
> Schrotty hats auf den Punkt getroffen!
> Der XR2206 zieht einfach zu viel Strom und ich wollte jetzt von euch
> wissen, ob das vielleicht an meiner Schaltung liegen könnte!
>
> Wäre sehr erfreut, wenn ihr mir helfen könntet!
>
> mfg Gabriel

Nee, nee, den Punkt habe ich getroffen, indem ich die vergessene Frage 
erahnt hatte!:-)

Autor: Simon A. (bullwai)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ingolf O. schrieb:
> Gabriel G. schrieb:
>> Schrotty schrieb:
>>> Und was ist deine Frage?
>>
>> Sorry,
>> hab sie aus reiner Verwirrung vergessen!
>>
>> Schrotty hats auf den Punkt getroffen!
>> Der XR2206 zieht einfach zu viel Strom und ich wollte jetzt von euch
>> wissen, ob das vielleicht an meiner Schaltung liegen könnte!
>>
>> Wäre sehr erfreut, wenn ihr mir helfen könntet!
>>
>> mfg Gabriel
>
> Nee, nee, den Punkt habe ich getroffen, indem ich die vergessene Frage
> erahnt hatte!:-)

OK, einigen wir uns auf unentschieden!
mfg

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was zieht der XR2206 denn wenn du Pin8 mal offen lässt?
Laut Datenblatt müssen dort mindestens 1k dran.
Und du schliesst ihn direkt an -12V an.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wieso schliesst du SYNC an Masse an? Lass den Pin offen
oder häng einen Pullup dran. Dann bekommst du dort
ein schönes Rechteck raus. Und wieso hängt der Ausgang
vom LM318 in der Luft?

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also irgendwie weicht dein Entwurf ganz erheblich von den 
Datenblattempfehlungen ab. Kann das sein?

Kai Klaas

Autor: Simon A. (bullwai)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
holger schrieb:
> Wieso schliesst du SYNC an Masse an? Lass den Pin offen
> oder häng einen Pullup dran. Dann bekommst du dort
> ein schönes Rechteck raus. Und wieso hängt der Ausgang
> vom LM318 in der Luft?

den SNYC Ausgang brauche ich nicht. Dafür verwende ich den LM393. Bin 
auch gestern daraufgekommen, dass der SYNC Ausgang offen bleiben muss. 
Der Ausgang des LM 318 hängt in der Luft weil ich einfach ein anderes 
Device mit gleicher Pinanzahl und gleichem Gehäuse genommen habe. War zu 
faul zum Neuzeichnen! Deswegen hängt der Ausgang in der Luft.

Das mit Pin 8 hab ich komplett übersehen! Muss dort nen 1k Widerstand 
dranhängen.

Danke!

Autor: Simon A. (bullwai)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
> Also irgendwie weicht dein Entwurf ganz erheblich von den
> Datenblattempfehlungen ab. Kann das sein?
>
> Kai Klaas

Kann schon sein, dass mit dem SYNC Ausgang hat sich bereits geregelt. An 
den Pin 8 muss ich noch nen 1k Widerstand ranhängen.

mfg Gabriel (bin Anfänger)

Autor: Simon A. (bullwai)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke, für eure Bemühungen!

mein Funktionsgenerator läuft jetzt einwandfrei!
hab Pin 8, 9, 11 einfach offen gelassen. Alles funktioniert wie es 
sollte!

mfg Gabriel

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.