www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik VS1001K Quarz schwingt nicht


Autor: DerMax (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
ich habe mir zum experimentieren einen VS1001K MP§ Decoder zugelegt und
ihn auf eine kleine Adapterplatine gelötet um ihn aufs Steckbrett zu
bekommen.
Natürlich hab ich vergessen mir den passenden 24,576MHz Quarz zu
besorgen und hab erstmal einen 18,432er wie im Datenblatt beschrieben
rangehangen (1M Ohm zwischen XTAL0 und XTAL1 und je einen 33pF
Kondensator gegen GND). Leider tut sich herzlich wenig. Der Quarz hat
zwar nicht ganz die passende Frequenz sollte doch aber trotzdem
anfangen zu schwingen oder? Die leiterbahnen habe ich so kurz wie
möglich gehalten (ca. 2cm)

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

der Oszillator des VS1001 ist ein ziemliches Mimöschen. Ich ahb ihn
damit:

        XTALO   XTALI
          o       o
          |       |
          |  _  |
          o-|___|-o---+
          | 240k  |   |
          |       |   |
          |       |   |
          |   _   |  .-.
          |  | |  |  | |1M
          o-|| ||-o  | |
          |  |_|  |  '-'
          |       |   |
          |       |   |
         ---     ---  |
         ---     ---  |
          |33p    |10p|
          |       o---+
          |       |
         ===     ===
         GND     GND
created by Andy´s ASCII-Circuit v1.24.140803 Beta www.tech-chat.de

zum Laufen gebracht.

Matthias

Autor: Profi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zur Not nimm halt zunindest zum Testen einen externen Quarzoszillator
(findet man oft auf alten Grafikkarten) oder bau Dir einen mit einem
7404 o.ä.
Schaltung dürfte überall zu finden sein.

Ist die Versorgung gut abgeblockt mit guten Cs?

Autor: DerMax (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So also hab mir jetzt mal ein richtiges kleines Testboard gebastelt,
Schaltplan siehe Anhang, aber funktionieren tuts trotzdem noch nicht.
Jetzt weiß ich nich ob ich evtl. den Chip beim ab- und wieder auflöten
kaputt gemacht habe.
Werd mir nächste Woche nochmal den passenden Quarz und die
Induktivitäten kaufen die hatte ich nämlich nicht und hab erstmal nur
Drahtbrücken eingesetzt. Wenns dann immer noch nich geht werd ich mal
noch nen Quarzoszillator probieren...

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

wenn ich da einen 74HCTxxx und Vcc am VS1001 sehe:
Du hast daran gedacht das der VS1001 mit 3,3V betrieben wird und auch
dessen Eingänge nicht 5V kompatibel sind?

Matthias

Autor: DerMax (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab mir jetzt einen 24,576MHz besorgt und die Tests aus der Appnote für
den Chip durchgeführt. Wenn ich jedenfalls mit Quarz den Reset auf High
lege geht auch DREQ auf high, wenn ich dann reset auf GND ziehe sollte
laut appnote DREQ nach 4096 Clockcycles auf low gehen und nach weiteren
6000 wieder auf high. Auf low gehen tut er noch, aber auf high dann
nicht mehr. In der Appnote steht dazu, dass die Firmware nicht richtig
funktioniert wenn sich DREQ nicht wie beschrieben verhält. Kann das
sein?
Wenn ich den Test ohne Quarz durchführe bleibt DREQ auch während der
Reset auf high liegt low, der Quarz scheint also zu gehen.

Hab mir jetzt bei ebay so einen mp3 player für 2,99€ bestellt (siehe
anderen Thread), mal sehen ob ein STA015 besser funktioniert

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Äh, schwingt denn der Quarz jetzt ? Bist du sicher, daß du ein
Grundwellenquarz hast ? Ansonsten probier mal ein 12.288MHz Quarz und
aktiviere halt die Taktverdopplung.

Thorsten

P.S.: Hab mir auch so ein Player bestellt :)

Autor: DerMax (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also ich hab ihn jedenfalls als Grundwellenquarz bei Segor gekauft, aber
selbst wenn es kein Grundwellenquarz ist sollte er ja nur langsamer
schwingen, aber zumindest das Verhalten DREQ sollte noch stimmen.
Ich hab auch mal einen 4MHz Quarzoszillator rangehangen, mit dem
gleichen Effekt wie mit Quarz.

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst du mit einem Scope überprüfen, ob er richtig schwingt ? Wenn er
das tut, und trotzdem nicht funktioniert, is er wohl wirklich kaputt.

Autor: DerMax (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mhmm also wenn ich das oszi ranhänge sehe ich denke ich die schwingung,
allerdings ist die amplitude sehr klein ca. 10mV allerdings kann mein
oszilloskop eigentlich auch nur 20MHz. kann sein das da ein Filter
drinsitzt der höhere Frequenzen wegfiltert.
Und wie gesagt ohne Quarz tut sich gar nichts und mit zumindest ein
bisschen.

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also dämpfen tut das Scope schon, aber hier wären das ja 40dB wenn ich
nicht irre und das ist zu viel. Ich habe gerade mal bei mir gemessen
und es sollte so ca. 3V (Spitze-Spitze) anliegen. Ich würde mal die
Beschaltung, die Mathias vorgeschlagen hat, weglassen. D. h. alle
Widerstände weg und die Kondensatoren symetrisch mit 30pF.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.