www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Atmega88 im Pollin Eval Board??


Autor: kurtkümpel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ist es möglich den Atmega88 im Pollin Board zu flashen etc.??
in der Produktbeschreibung stehen nur andere yController.

Gruß und Dank

Autor: Timmo H. (masterfx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die ATmega48/88/168/328 sind pinkompatibel zum ATmega8, also ja es geht.

Autor: Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen!

Ich hoffe ich kann von jemandem hier einen Tipp erhalten. Ich benutze 
ebenfalls das Pollin-Board. Das hat auch bisher immer gut gefunzt. Aber: 
jetzt wollte ich auf einen Mega88 umsteigen, aber mit dem kann partout 
keine Verbindung hergestellt werden. Hab es mit AVR Studio und PonyProg 
probiert -> nichts.
Weil ich dachte, daß so ein Controller ja mal kaputt sein kann hab ich 
es mit einem weiteren 88er und zwei 48ern probiert. Leider immer das 
gleiche "Ergebnis". Mit einem Mega8 läuft aber alles einwandfrei.

Hat jemand eine Idee, wo das dran liegen könnte? Hab alle Controller von 
Reichelt. Programmer ist das Evertool, externe Spannungsversorgung, 
externer Quarz... ich weiß nicht weiter!

Danke schonmal!

Michi

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Michi (Gast)

>Reichelt. Programmer ist das Evertool, externe Spannungsversorgung,
>externer Quarz... ich weiß nicht weiter!

Richtiger Controllertyp in der Software eigestellt? Unterstützt deine 
Software überhaupt den 88er? Der hat nämlich eine andere Kennung.

MfG
Falk

Autor: Marvin S. (demo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Geht es denn mit dem alten ATmega8?

Autor: Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, das ist ja das Seltsame, warum ich nicht selbst weiter weiß. Der 
alte Mega8 läuft tadellos.
@ Falk:
hoffe ich versteh dich richtig: in AVR Studio hab ich den 88er 
eingestellt (natürlich auch bei den Projekteigenschaften). Es wird ja 
auch fehlerfrei compiliert. Das ginge ja nicht, wenn der Controller 
nicht unterstützt würde (andere Registerbezeichnungen...) seufz
Ich halte es für unwarscheinlich, daß vier Controller auf einmal kaputt 
sind, aber mir fällt im Moment echt nichts schlaueres ein... -_0

Gruß!

Autor: Frank B. (frank501)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du Ein- oder Ausgänge an den SPI-Anschlüssen dran? Irgend welche 
LED's Vielleicht von dem Board?
Ich hatte einmal das selbe Problem, da hatte ich LED's an den 
SPI-Anschlüssen dran und wollte einen M88 einsetzen, da ging das Flashen 
auf einmal nicht mehr. mit dem M8 ging es dann wieder. Den M88 in einer 
Spimpelschaltung zum Programmieren eingesetzt ging dann auch.

Frank

Autor: Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Frank:
Danke für den Tipp. Die LEDs auf dem Board hängen aber an PD5 (T1) und 
PD6 (AIN0). Werde das jetzt erst noch inmal mit einer Rescue-Clock von 1 
MHz probieren (gute Idee?) und wenn das nicht geht trenne ich mal alle 
LEDs und so von dem Controller...

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn du im AVR-Studio eine Verbindung zum Programmer aufgebaut hast, 
musst du nochmals den richtigen Controller auswählen. Ich denke das 
meinte auch Falk

Autor: Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Michael:
klaro, hab ich gemacht. Aber selbst wenn man das nicht macht könnte man 
ja wenigstens die Signatur auslesen. Dann bekommt man zwar den Hinweis, 
daß die Signatur nicht mit dem eingestellten Controller übereinstimmt, 
aber selbst das passiert nicht. Auch mein Versuch mit der Rescue-Clock 
war erfolglos. Ärgerlich... Vielleicht nehme ich das so hin und hoffe, 
daß die nächsten Controller funktionieren. Ist ja schon seltsam, daß 
sowohl AVR Studio UND Ponyprog, weder über richtige COM-Schnittstelle, 
noch über virtuellen COM-Port (Evertool) eine Verbindung zu den 
Controllern kriegen...

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist die ISP-Frequenz niedrig genug?

The device is shipped with internal RC oscillator at 8.0MHz and with the 
fuse CKDIV8 programmed, resulting in 1.0MHz system clock.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.