www.mikrocontroller.net

Forum: FPGA, VHDL & Co. SP601 Spartan 6/Tutorial/ Einstieg/ Hilfe :(


Autor: Igor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,


ich habe mir das SP601 CSG 324 mit Spartan 6 gekauft. Ich wollte jetzt 
mal einfach als Einstieg mal eine LED zum Leuchten bringen.

Vhdl Code geschrieben, den PIN auf FPGA rausgefunden, aber irgendwie 
schaffe ich es nicht zum laufen zu bringen. Ich habe mir auch tutorial 
von ISE 11.2 angeschaut aber die beziehen sich auf ein SPARTAN 3A mit 
LCD Bildschirm.

Hat da jemand villeicht ein einfachs Tutorial wo ich einfach mal ein 
Code auf das Board runterlade... des wird doch wohl nicht so schwer sein 
eine einfach LED zum leuchten zu bringen :(

Es wird doch auch ein X Schema geben...



Kann mir vielleicht jemand helfen oder ein Tipp geben für den Einstieg?


Gruss Igor

Autor: Igor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich möchte eine LED ansteuern, würde es so funktioneren?

------------------------------------------------------------------------ 
----------
-- Company:
-- Engineer:
--
-- Create Date:    13:41:32 11/10/2009
-- Design Name:
-- Module Name:    LED - Behavioral
-- Project Name:
-- Target Devices:
-- Tool versions:
-- Description:
--
-- Dependencies:
--
-- Revision:
-- Revision 0.01 - File Created
-- Additional Comments:
--
------------------------------------------------------------------------ 
----------
library IEEE;
use IEEE.STD_LOGIC_1164.ALL;
use IEEE.STD_LOGIC_ARITH.ALL;
use IEEE.STD_LOGIC_UNSIGNED.ALL;

---- Uncomment the following library declaration if instantiating
---- any Xilinx primitives in this code.
--library UNISIM;
--use UNISIM.VComponents.all;

entity LED is
    Port ( LED : out  STD_LOGIC);
end LED;

architecture Behavioral of LED is

begin

LED <= '1';

end Behavioral;


Was müsste ich machen um ein Code zu implentieren?


Gruss

Autor: Andi Z. (duderino65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,

es kann sein, dass wenn du die LED auf '1' setzt, diese auf dem board 
aus bleibt. du musst sie mit einer '0' ansteuern. schau dir mal die 
'verdrahtung' des boards an.

mfg

Andi

Autor: Marcus W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du brauchst noch ein UCF file, in dem der Pin vom FPGA auf den "LED" 
Ausgang mapped.
Hast du das schon gemacht?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.