www.mikrocontroller.net

Forum: FPGA, VHDL & Co. Aldec Simulator findet MachXO Lib nicht


Autor: Andi Z. (duderino65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

ich habe das problem das mein simulator (aldec active hdl 8.1) die 
library "machxo.components" nicht findet. in der vho datei ist ein rotes 
x beim use... befehl.

es gibt dann folgende fehler:

# Compile...
# File: C:\ispTOOLS7_2_STRT\work\i2s_adat_9_11\ebr_syclk.vho
# Compile Entity "vmuxregsre"
# Error: COMP96_0055: ebr_syclk.vho : (12, 13): Cannot find referenced 
context element.
# Compile Architecture "Structure" of Entity "vmuxregsre"
# Error: COMP96_0056: ebr_syclk.vho : (23, 3): Cannot find referenced 
entity declaration "vmuxregsre".
# Compile Entity "vcc"
# Error: COMP96_0055: ebr_syclk.vho : (40, 13): Cannot find referenced 
context element.
# Compile Architecture "Structure" of Entity "vcc"
# Error: COMP96_0056: ebr_syclk.vho : (49, 3): Cannot find referenced 
entity declaration "vcc".
# Compile Entity "inverter"
# Error: COMP96_0055: ebr_syclk.vho : (62, 13): Cannot find referenced 
context element.
# Compile Architecture "Structure" of Entity "inverter"
# Error: COMP96_0056: ebr_syclk.vho : (71, 3): Cannot find referenced 
entity declaration "inverter".


ich bin gerade etwas überfordert mit dem simulator weil ich mich damit 
absolut nicht auskenne und mich da auch nicht zurecht finde. die 
simualtion habe ich immer aus dem ispLever gestartet.

im design browser hatte ich unter "structure" immer mehrere libs (z.b. 
auch machxo). jetzt sind nur so standard libs vorhanden.

kann ich den simulator irgendwie zurücksetzen?
weiss jemand wie ich das problem beheben kann?

mfg
Andi

Autor: Andi Z. (duderino65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo nochmal :-)

hat sich nun erledigt.
ich habe mir mal die vorhanden libs im active hdl angeschaut und da war 
die machxo lib aus einem verzeichnis des modelsim drin.
hab dann die richtige lib des active hdl angegeben und dann lief es 
wieder.

gibt es tutorials die beschreiben wie man mit den simulatoren umgeht? 
also diese über skripte laufen lässt? die tuts die ich gefunden hab, 
zeigen nur wie man ein projekt erstellt und vhdl datein einfügt. 
allerdings komm ich damit nicht so klar.


mfg

Andi

Autor: SuperWilly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.