www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik USART an pic f18f2550


Autor: Marco Schulze (sharkman)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo.

Ich habe erstmal folgendes Problem. Ich krieg keine Daten vom PIC 
gesendet. mehr hab ich bis jetzt auch noch nicht versucht, weil erstmal 
das laufen sollte. Ich verwende den C18 Compiler und habe den pic an 
einem FTDI hängen. Wenn ich mir jetzt mit dem Oszi die Leitungen RC7 und 
RC6 anschaue, dann nehmen diese beiden immer den High-Level ein. Ich 
vermute deshalb mal, dass ich irgendwo einen Fehler drin habe.
Ich habe mich jetzt einfach mal am C18 User's Guide entlang gehangelt. 
Ich hoffe ich habe keinen zu großen Mist verbrochen.
Was ich noch dazu sagen sollte, an meinem PIC hängt ein exter 12MHz 
Quarz den ich per HSPLL auf 48MHz bringe (Hoffe ich zu mindest). Die 
Baudrate soll 19200 betragen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.