www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik avr-ethernet board + rfm12 + ethersex


Autor: gerd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe hier ein Pollin AVR-IO mit angeschlossenem RFM12 Modul und 
ethersex. Ich kompiliere unter Linux mit der default Config für das 
Pollin Modul, was soweit auch einwandfrei läuft. Will ich nun den RFM12 
Support aktivieren und mache das mit "Make Menuconfig" --> IO --> RFM12 
ASK..., dann erstellt er mir fein eine HEX Datei, die ich dann per 
AVRSTUDIO auf das AVR-IO flashe. Soweit so gut, die HEX ohne RFM12 
Support lässt sich auch per IP Adresse ansprechen, die mit RFM12 Support 
aber nicht mehr !?!?!? Ich renne gegen Wände und bin schon blöd 
geworden....

Bitte,bitte mein Kopf qualmt, keine Ahnung was da abgeht.

Autor: Mirko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo gerd,

das Problem hatte ich auch, man sieht wenn Debug eigenschaltet wird, 
speziell SPI Debug einen SPI Timeout. Der SPI Bus ist blockiert und dann 
kann nix mehr über den ENC kommuniziert werden.
Das liegt daran das wahrscheinlich die defines für das pinning nicht 
stimmen.
Unter hardware/pinning findest du die Macro Dateien wo das eingestellt 
wird. Siehe netio.m4

ifdef(`conf_RFM12', `dnl

/* port the rfm12 module CS is attached to */
pin(SPI_CS_RFM12, PD5, OUTPUT)
RFM12_USE_INT(1)
RFM12_ASK_SENSE_USE_INT(1)
')

laut default ist das CS an PD5 und der INT auf PD3 (INT1) konfiguriert, 
das musst Du anpassen.

Mittlerweile hab ich das laufen, auch der rfm12 status wird nunmehr 
korrekt mit 0x02xx angezeigt aber mit der Kommunikation untereinander 
haperts noch bei mir. Das liegt aber daran das ich zu einem Radig 
Webmodule mit einem RFM12B Modul kommunizieren will - und auf 868 MHz 
natürlich und dafür einige Initialisierungen nicht stimmen. Da bin ich 
aber noch am werkeln.
Mit einem normalen RFM12 auf 434 MHz sollte es aber problemlos gehen.

Gruß,
Mirko

Autor: gerd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Mirko,

danke für deine ausführliche Hilfe, werde es gleich am Wochenende 
ausprobieren. Hoffe das es dann endlich läuft.

Danke nochmals
Gruß
Gerd

Autor: Bernhard S. (bernhard_s36)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo in die RFM12-Runde und ein frohes neues Jahr!

Seit einigen Tagen spiele ich mich mit AVR-NET-IO, Ethersex und RFM12. 
Leider stoße ich auf das gleiche Problem, dass RFM12 und ENC zusammen 
den SPI blockieren.

Da aber beim aktuellen Ethersex die Pinnings absolut korrekt zu sein 
scheinen (CS an PD5, INT an PD3 (INT1), MOSI an PB5, MISO an PB6, SCK an 
PB7), komme ich an dieser Stelle einfach nicht mehr weiter...

Hat einer von euch einen Auszug aus einer angepassten und 
funktionsfähigen pinnings.m4 parat? Oder funktioniert eine alternative 
Verdrahtung?
Das wäre eine sehr große Hilfe!


Vielen Dank und Grüße aus München,
Bernhard
aka. HotKey

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.