www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik problem mit Port A beim mega16


Autor: bob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,
ich wollte den port A beim mega16 als output benutzen. im datenblatt
steht, das man dafür avcc und agnd anschliessen muss. agnd nimmt der uC
noch wenn ich aber AVCC anschliesse, startet das programm nicht mehr. ;(
das erkenne ich, da als erstes ein string per rs232 übertragen wird,
welche nun nicht mehr ankommt). klemme ich den draht wieder ab, geht
alles aber port a leider nicht
ponyprog findet ihn aber noch. hat jemand diese problem schon mal
gehabt ?

bin über jeden tipp dankbar

bob

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hast du kondensatoren dran? bin mir jetzt nicht sicher ob man aref auch
anschliessen muss.. musste mal nachlesen

Autor: Axel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich finde das nicht im Datenblatt... bin ich wieder zu blöd?

Auf welcher Seite stehtn das, das der PortA nur mit AVCC und AGND als
Ausgang zu benutzen sei? Wäre ja interessant...

Vile Grüße
AxelR.

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
als eingang nur damit eigentlich, weil da auch der adc dran ist. und der
will gerne seine spannung haben, ob der port nun die funktion hat oder
einfach nur ein port ist. hab ich zumindest bisher immer so verstanden
:)

Autor: Axel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also was er nicht abkann ist: PortA.7 als Eingang rausführen und Ihn
versehentlich als Masseanschluß für den übrigen, gesamten
Schaltungsaufbau verwenden.
Ich hatte dann auch noch einen LiPo mit 200mA geladen. Dnn war es aus
mit meinem Mega16-PortA.7-PIN. Der Controller lässt sich noch
verwenden, aber PortA.7 nicht mehr. sehr ärgerlich. Ungeschützter
Verkehr, da kommt sowas vor!

Du hast bestimmt hier sicherlich AVCC und AGND vertauscht, die liegen
gegenüber, aber überkreuz, vieleeeicht...
Um den Port als Ausgang zu benutzen, musst Du AVCC nicht beschalten,
glaub' ich nicht.

Schönen Gruß
AxelR.

Autor: bob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der port a am mega16 ist wohl hin. habe den uC durch einen mega32
ausgetauscht. funktioniert gut. man braucht nur gnd anschliessen.

trotzdem danke an alle

bob

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.