www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Royer Converter mit hohem Leerlaufstrom?


Autor: jakob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

habe eben einen Royer-Converter aus Resteteilen zusammengebastelt. Der 
erste Funktionstest lief soweit auch schon ganz zufriedenstellend (in 
dem Sinne, dass die Schaltung läuft und die Transistoren nicht 
abrauchen). Kleine Lampe mit zwei Wicklungen glüht auch fröhlich vor 
sich hin...

Ich habe mich beim Bau soweit an die Anleitung im Wiki gehalten. Als 
Transistoren verwende ich BUV227. Meine Primärspule besteht aus 2x5 
Wicklungen 2,5mm² (Durchmesser ca. 50mm, Höhe auch 50mm; in etwa 5µH)

Direkt an die beiden Endabgriffe sind insg. 4x0,47µF impulsfeste 
Kondensatoren gelötet (waren aus einem Projekt über, wo solche auch 
gefordert sind).

Zusammen ergibt sich also ein Schwingkreis mit einer Resonanzfrequenz 
bei ca. 50kHz. Das passt auch soweit, mein Oszi stimmt mir da zu.

Die Spule in der Versorgungsspannung ist eine Spule mit ca. 100µH auf 
einem Ferritkern. Das der Kern in die Sättigung geht ist eigentlich 
auszuschließen, da es sich um einen wirklich großen Kern mit riesigem 
Luftspalt handelt. Habe das auch mit der bekannten SMPS-Seite 
verifiziert. Sie gibt mir an, dass ich besagten Kern als Speicherdrossel 
in dem Leistungsbereich verwenden kann... ;)

So, nun mein eigentliches Problem: Betreibe ich die Spannung mit 30VDC, 
so ergibt sich ein Leerlaufstrom von ca 1,5A! Gemessen habe ich das über 
einen Shunt in der Versorgungsleitung, der zunächst einmal den 
Kurzschlussfall absichern sollte. Kann sich einer denken woran das 
vielleicht liegen könnte?

Das mysteriöse ist auch, dass keine Bauteile so richtig heiß werden. Die 
Spule wird zwar warm, aber nicht extrem heiß. Genauso mit einem der 
beiden Transistoren. Sind beide auf sehr große Kühlkörper montiert, aber 
der Eine wird wärmer als der Andere (auch unter Last ist dieser der 
Heißere). Es handelt sich dabei um den Transistor, dessen Basis über den 
Widerstand (Hab einen 3k3 genommen, hatte ich da und hat direkt 
funktioniert, vielleicht hier variieren?) direkt an die 
Versorgungsspannung geschaltet ist.

Schaltplan könnte ich, sofern gewünscht auch zeichnen, aber es ist 
eigentlich genau der Gleiche wie im Wiki, nur mit den oben genannten 
Änderungen.

So, da die Gäste schon nach mir schreien, bin ich mal wieder weg hier ;)

Schönes Silvester noch!

: Verschoben durch Admin
Autor: A. R. (redegle)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Als Transistoren verwende ich BUV227
Meinst du BUV27?

Ich hab mich zwar mit bipolaren Transistoren noch nicht allzuausführlich 
beschäftigt. Aber der BUV27 ist ein Leistungstyp und zwar mit einem 
maximalen Basestrom von 4A. Ich denke die Stromverstärkung ist nicht 
allzugroß. Vielleicht 20 bis 80. Sehr grob geschätzt. Habe im Datenblatt 
keine angaben gefunden.
30V und 3,3k ergeben einen Basisistrom von ca 9mA. Selbst bei einer 
Verstärkung von 100 würde er nur 900mA fließen lassen. Bei so hohen 
Strömen in der Primärspule könnte es sein, dass er nicht kompett 
aufschaltet.

Ich würde mal die Spannung über den beiden Transistoren messen.

1,5A rms oder peak?
30V und 1,5A rms ergibt 45W. So etwas müsste man eigendlich fühlen.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich denke die Stromverstärkung ist nicht allzugroß. Vielleicht 20 bis 80.
Sie ist 10
VCE(sat)∗ Collector-Emitter Saturation Voltage
IC = 4A      IB = 0.4A          0.7V
IC = 8A      IB = 0.8A          1.5V

Autor: jakob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ja es handelte sich um zwei BUV27, hab da eine 2 zu viel rein gebastelt. 
;)

Habe eben den Widerstand auf ca. 770 Ohm abgesenkt. Konsequenz war, dass 
der Leerlaufstrom in etwa identisch blieb, aber unter Last sehr viel 
mehr Strom gezogen werden konnte. Beim Kurzschluss mit einem Stück Eisen 
hat die Schaltung über 5A gezogen hat... Hat also schonmal was gebracht.

Leider hat die Schaltung beim entfernen des Eisens aufgehört zu 
schwingen, was ich leider zu spät bemerkt habe. Nun habe ich zwei BUV27 
weniger. Werde die erstmal wechseln und dann das Ganze mal ans Oszi 
hängen.

Beim Leerlaufstrom handelt es sich übrigens um RMS-Werte, da der Shunt 
über einen Tiefpass gemessen wird. Hab ich gestern vergessen zu 
erwähnen.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@jakob (Gast)

>Transistoren verwende ich BUV227. Meine Primärspule besteht aus 2x5
>Wicklungen 2,5mm² (Durchmesser ca. 50mm, Höhe auch 50mm; in etwa 5µH)

Gemessen oder geschätzt?

>Direkt an die beiden Endabgriffe sind insg. 4x0,47µF impulsfeste
>Zusammen ergibt sich also ein Schwingkreis mit einer Resonanzfrequenz
>bei ca. 50kHz. Das passt auch soweit, mein Oszi stimmt mir da zu.

Naja, da kann man doch leicht rechnen. Dein Spitzenstrom in Schwingkreis 
ist bei diesen Werten 60A! Da bleibt schon bissel was hängen.

>So, nun mein eigentliches Problem: Betreibe ich die Spannung mit 30VDC,
>so ergibt sich ein Leerlaufstrom von ca 1,5A! Gemessen habe ich das über

>Das mysteriöse ist auch, dass keine Bauteile so richtig heiß werden. Die
>beiden Transistoren. Sind beide auf sehr große Kühlkörper montiert,

Na dann ist ja klar, dass die nicht so heiss werden.

>Widerstand (Hab einen 3k3 genommen, hatte ich da und hat direkt
>funktioniert, vielleicht hier variieren?) direkt an die
>Versorgungsspannung geschaltet ist.

Viel zu wenig. Ich hab hier vor ein paar Tagen mit etwa 20W 
experimentiert, da hab ich an 12V 220 Ohm genommen.

Beitrag "Re: Ferrit-Topfkern"

>Habe eben den Widerstand auf ca. 770 Ohm abgesenkt. Konsequenz war, dass
>der Leerlaufstrom in etwa identisch blieb, aber unter Last sehr viel
>mehr Strom gezogen werden konnte. Beim Kurzschluss mit einem Stück Eisen
>hat die Schaltung über 5A gezogen hat... Hat also schonmal was gebracht.

Was meinst du mit Kurzschluss? hast du das Eisen in die Spule gehalten? 
Damit wird die Induktivität stark verringert, die Freqeunz geht tierisch 
hoch und der Royer kommt irgendwann aus dem Tritt, schwingt wild und 
unkontrolliert. Das machen die Transistoren nicht lange mit.

>Beim Leerlaufstrom handelt es sich übrigens um RMS-Werte, da der Shunt
>über einen Tiefpass gemessen wird. Hab ich gestern vergessen zu
>erwähnen.

In der Zuleitung kannst du ganz einfach mit dem Multimeter messen, dort 
fliesst nur Gleichstrom.

MfG
Falk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.