www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ISP Stecker ab = Takt weg


Autor: Torsten B. (torty)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen Gemeinde

Hab mir auf Lochraster einen ATMEGA16 verdr.
Wenn der ISP Stecker von meinem USB ISP-PROG aufgesteckt ist, klappt 
auch alles gut. Nur wenn ich ihn dann abziehe bleibt alles stehen. 
Nicht, dass die Spannung weg wäre, sondern der Takt scheint weg zu sein.
Auch wenn ich auf Intern 4MHz 6 CK + 64ms fuse bleibt der uC stehen, 
sobald ich den ISP Stecker abziehe.
Hat jemand eine Idee ?


DAnke
Torsten

Ach noch etwas.
Wenn ich die Betriebsspannung aus- und wieder einschlate, läuft das 
Programm für ein paar 1/10tel Sekunden. Geprüft mit einem Oszi am Timer 
OC2 Pin.
Danach ist wieder Ruhe

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

naja, eigentlich sind da ja nur 2 Sachen von Bedeutung:
Spannung am AVR wirklich ok (direkt an den Pins messen)?
Resetbeschaltung ok (direkt am Pin messen)?

Ansonsten: ich habe auf Lochraster mal 2 Tage einen Fehler durch eine 
superfeine Zinnbrücke zwischen 2 benachbarten Pins gesucht...
Da kratze ich im Zweifel dann immer mit einem kleinen Schraubenzieher 
lang.

Gruß aus Berlin
Michael

Autor: Hugo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pullup am Reset?

Autor: Torsten B. (torty)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Hugo: Hat er
@ Michael: Einer Lötbrücke würde entgegensprechen, dass ja alles toll 
funktioniert, wenn der ISP dran ist.
Wenn ich das Netzteil einschalte, sind sogar genug Takte da, das LCD zu 
init. und den Bildschirm aufzubauen.
Dann ist ein paar ms später Feierabend ..

Noch jemand eine Idee ????

DAnkeeee

Autor: Hugo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also wenn der Pullup wirklich dran ist (z.B. 10k), dann muss irgendwo 
eine Masse fehlen, die über den Programmierstecker dann zugeführt wird 
(wenn eingesteckt ...).
Lochraster ist immer heimtückisch , kalte Lötstelle etc...

Gruß,

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.