www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ZTerm richtig einstellen


Autor: Christopher Schwager (chris91)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey,

hab heute endlich mein USB to Serial Adapter bekommen. Habe aber leider 
jetzt ein Problem.

Da ich unter Mac bin habe ich direkt den Treiber installiert was 
einwandfrei funktioniert und dann ZTerm gestartet.

Bekommen jetzt aber das angezeigt, obwohl da eig etwas mit Temperatur 
stehen sollte:
`fxfffxff`xfff`xff`fxfffxff`xfff`xff`fxfff`xf`xx~ffff`xff`fxfffxff`xfff`xff`fxfffxff`xfff`xff`fxf
ffxff`xfff`xff`fxfff`xf`xx~ffff`xff`fxfffxff`xfff`xff`fxfffxff`xfff`xff`fxfffxff`xfff`xff`fxfffxf
f`xfff`xff`fxfffxff`xfff`xff`fxfff`xf`xx~ffff`xff`fxfffxff`xfff`xff`fx`fffxxf`xfffffxff`f`xxff`ff
`xfffxff`f`ff`ff``ffffxfff`f`ff`ff``ffffxff`f`xff`ffff``x~ffffxff`f``ff`fxxf``xxxffffxff`f`ff`fff
``xffffxfff`f`ff`~ff```xffffxfff`f`ff`~ff```xffffxxff`f`ff`fff```xffffxxff`f`ff`fff```xffffx~ff`f
`ff`fff```xffffx~ff`f`~ff`ff``ffffxxff`f`ff`fff```xffffx~ff`f`ff`~ff```xffffxff`f`ff`fff```xffffx
fff`f`~ff`ff``ffffxxff`f`~ff`ff``ffffx~ff`f`xff`ff``fffxff`f`~ff`ff``ffffxxff`f``ff`fxxf``xxxffff
xff`f`ff`ff``ffffx~ff`f`ff`ff``xffffxfff`f`xff`ff```xxffffxff`f`x`ff`~ff``xx~ffffxff`f`xxff`ff`xf
ffxff`f`xff`fff`xxffffx~ff`f`xfff`xf`xxffffxfff`f`xfff`xf`xxffffxfff`f`xff`xff`xffffx`ff`f`xff`xf
f`xffffx`ff`f`xff`xfff`xffffxff`f`xff`xfff`xffffxff`f`xff`xfff`xffffxff`f`xxff`xff`x`x~ffffxff`f`
xxff`xff`x`x~ffffxff`f`xxff`xff`x`x~ffffxff`fxfffff`xffffxff`fxfffff`xffffxff`fxfffff`xffffxff`fx
fffff`xffff`xff

Was mache ich falsch???

Danke

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Was mache ich falsch???
Dein Spieltrieb ist nicht ausgeprägt genug... :-/
Probier doch erst mal einfach alle Baudraten durch, evtl. taucht mal was 
Sinnvolles auf...

> obwohl da eig etwas mit Temperatur stehen sollte:
Ja, was denn eigentlich?

Autor: Christopher Schwager (chris91)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab jetzt einfach ein anderes Programm genommen und dann gings auf 
einmal:

ADC=208 U=0.520V R=13000.000 Ohm T=19.1 C

Sowas sollte rauskommen.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, da werden sich die beiden Programme wohl in der per default 
gewählten Baudrate unterscheiden.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.