www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik 3,3V aus Li-Ion Akku durch MAX1709


Autor: Oliver A. (oli82)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen.

Ich habe folgendes Problem mit meiner Schaltung.

Ich möchte aus einem Li-Ion Akku 5V und 3,3V erzeugen.

Dafür habe ich 2x den MAX1709 verwendet.
Die 5V werden sauber erzeugt, nur die 3,3V funktionieren nicht.

Als Verpolschutz habe ich je eine Diode verbaut.
Die Diode des 3,3V Teils geht jedoch beim anlegen der Li-Ion Spannung in 
Rauch auf.
Ich habe mal den Strom an der Diode gemessen. Er liegt bei 1,78A, was ja 
nicht ganz richtig sein kann.

Ich habed die Beschaltung mit gepostet.
Könnnt ihr mir bei der Fehlersuche Helfen?

Bisher habe ich nur den 1M Widerstand an 3,3/5V überbrückt, da dieser im 
Datasheet des MAX1709 nicht aufgeführt wird.

Danke für eure Hilfe
Gruß, Oli

: Verschoben durch Admin
Autor: Harald Hermenau (mirona)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

den entscheidenden fehler hast Du gemacht, indem Du das Datenblatt nicht 
richtig gelesen/verstanden hast.
Dieser schaltkreis ist ein STEP-UP Converter.
Das heißt, Du kannst damit aus 5 V keine 3,3 V erzeugen.
Somit würde ich als Diode auch rauchzeichen geben.
der zweite Fehler ist das fehlende C vor deiner Spule.

Tschüß

Autor: Meister (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gilt der Schaltplan auch für die 5V ? Bräuchte sowas nämlich auch in 
meinem nächsten Projekt. Wenn der Schaltplan für 5V anders aussehen 
sollte wärs sehr nett, wenn du den posten könntest!
Danke
Gruß Meister

Autor: Oliver A. (oli82)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Harald Hermenau schrieb:
> Hallo,
> Dieser schaltkreis ist ein STEP-UP Converter.
> Das heißt, Du kannst damit aus 5 V keine 3,3 V erzeugen.
> Somit würde ich als Diode auch rauchzeichen geben.
> der zweite Fehler ist das fehlende C vor deiner Spule.

Danke für die Info.
Aus dem Datenblatt ist nicht zu ersehen, dass vor die Spuhle ein 
weiterer C muss. Jedoch habe ich direkt an V+ noch einen 100nF verbaut.
Aus dem Datenblatt geht doch hervor, dass die Versorgungsspannung 1-5V 
ist und der MAX daraus 3,3/5V(fixed) oder 2,5-5,5V machen kann.
It operates with an input voltage as low as 0.7V and is
suitable for single- to 3-cell battery inputs as well as
2.5V or 3.3V regulated supply inputs. The output voltage
is preset to +3.3V or +5.0V or can be adjusted with
external resistors for voltages between +2.5V to +5.5V.

So steht es zumindest im Datenblatt.
Lediglich im Datenblatt des Eval-Kit steht:
 Imput Voltage Range from 0,7V to VOUT

Wenn ich jetzt trotzdem den MAX verwenden möchte, könnte ich doch eine 
Spannungsteiler oder einen LM1117 vorschalten, um Vin unter 3,3V zu 
bringen. Oder?

Ist zwar nicht die optimale Lösung, da ich aber etwas unter Zeitdruck 
bin, muss ich aber schnellstmöglich eine Lösung parat haben...

@Meister:
Die Beschaltung ist fast identisch.
Du musst nur +5V an ONA, R16 und R15 anstatt der 3,3V hängen und VOut 
ist dann natürlich auch +5V

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Step-Up bleibt Step-Up...

also nimm nur den 5V Schaltregler, und nimm für die 3,3V einen LDO, vom 
Akku gespeist. 3,3V / 3,7V ergibt auch einen Wirkungsgrad von ca. 89%, 
und wenn man keine Ahnung von der Materie hat, wird man mit einem 
Schaltregler auch nicht besser werden...

Und Schaltregler brauchen in der Regel IMMER "dicke" Eingangs-Cs 
(>=10µF), um den Ripple einganggsseitig gering zu halten.

Autor: K. J. (theborg0815) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meister schrieb:
> Gilt der Schaltplan auch für die 5V ? Bräuchte sowas nämlich auch in
> meinem nächsten Projekt. Wenn der Schaltplan für 5V anders aussehen
> sollte wärs sehr nett, wenn du den posten könntest!
> Danke
> Gruß Meister

jo gilt auch für 5V nur das 3,3/5v weicht ab die schaltung scheint von 
meiner seite zu stammen grautier.com und dann der ipod akku lader.

Allerdinks verhält sich der max1709 recht zikkig hab den fehler nicht 
gefunden hin und wieder macht der nen kurtzen ka warum.

Autor: Arc Net (arc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oliver A. schrieb:
> Harald Hermenau schrieb:
>> Hallo,
>> Dieser schaltkreis ist ein STEP-UP Converter.
>> Das heißt, Du kannst damit aus 5 V keine 3,3 V erzeugen.
>> Somit würde ich als Diode auch rauchzeichen geben.
>> der zweite Fehler ist das fehlende C vor deiner Spule.
>
> Danke für die Info.
> Aus dem Datenblatt ist nicht zu ersehen, dass vor die Spuhle ein
> weiterer C muss.

Seite 8 Figure 1 Standard Operating Circuit...
Eingangsseite: 2x 150 uF mit zusammen max 50 mOhm ESR!
Ausgangsseite: 2x 150 uF mit zusammen max 15 mOhm ESR!
Was da z.Z. verbaut ist, kann man im Schaltplan leider nicht lesen.

Die im Datenblatt angegeben Dioden (STPS8L30B, MBRD1035CTL) sind auch 
nicht zum Spaß für 8A bzw. 10A (nicht 100mA wie bei der BAS70 aus dem 
Schaltplan von oben) ausgelegt.

Zudem ist die Strombegrenzung ohne entsprechenden Widerstand von SS/LIM 
nach GND min. 7.5A max. 12A. Die im Schaltplan angegebene Spule ist bei 
9.5A in der Sättigung...

K. J. schrieb:
> Allerdinks verhält sich der max1709 recht zikkig hab den fehler nicht
> gefunden hin und wieder macht der nen kurtzen ka warum.

s.o. + gutes Layout?

Autor: K. J. (theborg0815) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
s.o. ?

Ob des layout so gut ist ka. aber hab auch nur 200mA die ich aus dem 
teiel zuppel und keine 5A.

http://www.grautier.com/grautier/uploads/Elektroni...

Autor: Oliver A. (oli82)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
K. J. schrieb:
> jo gilt auch für 5V nur das 3,3/5v weicht ab die schaltung scheint von
> meiner seite zu stammen grautier.com und dann der ipod akku lader.

Ja, habe die Lib für den MAX von deiner Seite.

@ X- Rocka
Leider hast du da recht und mit dem Datenblatt lesen alleine war es hier 
nicht getan.

Habe nur noch einmal 10µF für den 5V verbaut. Die 3,3V muss ich nun wohl 
oder übel über einen Recom oder LDO erzeugen.

@ Arc Net
Ich habe 1x 150µF Eingangseitig und 2x 150µF am Ausgang verbaut.
Jedoch sind das alle 3 der gleiche Typ, mit 45mohm. Niedrigere hab ich 
leider nicht gefunden.

Die Schaltung belastet die 5V mit 120mA und die 3,3V mit 80-200mA.
Deshalb habe ich diese Spuhlen und Beschaltung gewählt.

Autor: Spezi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

in Deinem Schaltplan oben ist ein Fehler (siehe Datenblatt):

Der Elko C29 ist an der falschen Stelle. Von der Versorgungsspannung aus 
gesehen: erst die Verpol-Diode, danach der Elko, dann die Spule, die 
dann an die LX-Pins des IC angeschlossen ist.
So wie oben gezeichnet kann das eigentlich nicht funktionieren ...  :-(

Autor: Oliver A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also irgendwie ist das mit dem C ein Widerspruch in den beiden 
Datenblättern (Eval-Kit und max1709)

Im Evalkit ist erst die Spule und dann die beiden 150µF.
Was ist nun richtig und was falsch oder geht evtl. sogar beides?

Autor: K. J. (theborg0815) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
des mit dahinter läuft aber des könnte erklären warum es so zickig ist, 
morgen mal testen

Autor: Oliver A. (oli82)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, hab die Schaltung nochmal so aufgebaut, wie im Datenblatt.
Lediglich die Bauteile habe ich beibehalten, da ich sonst neu ebstellen 
müsste.

Resultat:
Ich habe für ca. 10 Sekunden 3,3V, dann scheint der MAX1709 den Geist 
auf zu geben.
Ich habe nach diesen 10 Sekunden einen Kurzschluss zwischen LX und 
GND(PGND).

Nachvollziehen kann ich es nicht, da diesmal die Schaltung so wie im 
Datenblatt ist. Als Last habe ich eine einfache LED mit Vorwiderstand 
verbaut.

Autor: ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was für eine Spule verwendest du ? Typ, Hersteller.

Autor: Oliver A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Spule ist von Würth Elektronik 
(http://www.farnell.com/datasheets/69684.pdf)

Autor: ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oliver A. schrieb:
> Die Spule ist von Würth Elektronik
> (http://www.farnell.com/datasheets/69684.pdf)

Die wäre ja ok.

Hast du die BAS70 ersetzt? Also mindestens eine MBRS130T3 sollte es 
schon sein.

Autor: Oliver A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, noch ist die BAS70 drin.
Könnte die für den Kurzschluss, trotz der geringen Last verantwortlich 
sein?

Autor: Henk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht hast sie einfach gekillt? Denk an dne Spitzenströme bei 
solchen Schaltreglern!

Autor: K. J. (theborg0815) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, haqb nochmal geschaut mit einer BVZ55 satt der BAS und den 150µ vor 
der spule geht das ganze wesentlich besser.

Autor: Oliver A. (oli82)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab das ganze nun mit einem TPS63001 und TPS63002 aufgebaut.

Beschaltung ist einfacher, Leistung reicht vollkommen und vor allem: 
kostet weniger als die Hälfte

Trotzdem danke, dass du die Schaltung noch einmal gestestet hast K.J.

Autor: Terfagter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo bekomme ich den TPS63001 als Privatperson günstig her?

Autor: Oli82 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Am einfachsten direkt ein Sample beim Hersteller beantragen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.