www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik IR Fernbedienung Attiny 2313 Fuses


Autor: Gosch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Ich habe diese Fernbedienung: http://www.a-netz.de/remote-control.de.php 
nachgebaut (Attiny 2313) aber ich weiß leider nicht, wie ich die Fuses 
setzten muss kann mir jemand helfen? Wäre sehr nett.
PS Ich verwende Burn-O-Mat

Autor: technikus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

schöner Link, so etwas hatte ich schon länger gesucht.


Zitat vom angegebenen Link ;-)
"Im Power-Down-Modus wird der Oszillator des Controllers abgeschaltet. 
Wird der Controller durch einen Tastendruck aufgeweckt, so läuft er mit 
8MHz, denn mit geringerer Taktfrequenz könnte man die 
Modultationsfrequenz und Bit-Zeiten nicht so exakt einhalten."

Gruß
ernst

Autor: Gosch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
technikus schrieb:
> "Im Power-Down-Modus wird der Oszillator des Controllers abgeschaltet.
> Wird der Controller durch einen Tastendruck aufgeweckt, so läuft er mit
> 8MHz, denn mit geringerer Taktfrequenz könnte man die
> Modultationsfrequenz und Bit-Zeiten nicht so exakt einhalten."

Und das heißt konkret? Welche Fuses muss ich also setzten?

Autor: Kasperle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Internen RC Oszillator auf 8MHz setzen.
Keine Vorteilung.

Autor: vollhoast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jo also ich hab das jetzt mal gemacht und funktioniert soweit ganz gut 
allerdings nur mit 5V bei Brown Out Detection auf 1,8V glimmt die IR LED 
nur noch aber das ist ja nicht Sinn der Sache xD Weiß wer, wie ich das 
ganze auch mit ca. 3V betreiben kann, das wäre nämlich viel praktischer 
oder kennt jemand kleine 5V akkus?

Autor: Gosch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich hab das jetzt auch ma gemacht (bin jetzt endlich dazu 
gekommen).
Funktioniert gut aber wie vollhoast gesagt hat erst bei 5V. Bin erst 
durch seinen Post drauf gekommen, da ich anfangs zwei Mignon Zellen zum 
testen verwendet hab und da tat sich nichts... Bei 5V ausm USB klappts 
wunderbar
@ vollhoast bist du inzwischen schon weitergekommen?
Gruß, Gosch

Autor: Flo H. (mr-jones)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
bei mir klappt es mit den Fusebits wie in dem Bild dargestellt. 
Verwendet werden hierbei 2 AA Zellen mit also damit 3V.
Ich habe allerdings einen externen Quarz dran!
mfg Flo

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.