www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Versehentliche Überspannung bei ATmega16


Autor: Elektroniker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend,

folgendes Szenario:

Habe auf einem ATmega16 Pong laufen lassen, was soweit recht gut 
funktionierte. Allerdings war das Netzteil weniger stabil und regelte 
komischer Weise bis zu 6.3Volt hoch, der Mega lief jedoch weiter und 
weiter. Habe heute Abend ein paar Programmänderungen vollzogen und 
wollte den µC erneut via ISP programieren, doch siehe da er hängt sich 
nach einer bestimmten Funktion auf. Der erste Gedanke blieb natürlich 
bei einem Prohrammierfehler hängen, jedoch habe ich nach unzähligen 
verzweifelten Versuchen wieder die Orginaldatei aufgespielt. Indes 
wieder das gleiche.

Gewohnt bin ich das entweder das ganze IC abraucht, oder halt standhält.

Kann das möglich sein? Im Datenblatt steht bei 8Mhz von 2,7-5,5 Volt 
betreibbar. 6,3 Volt waren es mindestens.


lg ;-)

Autor: Wilhelm F. (ferkes-willem)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Elektroniker schrieb:

>6,3 Volt waren es mindestens.

Also gerne auch 7 oder 8V. Ich selbst habe schon 74HC-Bausteine aus 
Unachtsamkeit mit 8V verheizt. Die sind mit 2-6V spezifiziert.

5V, sind für einen integrierten Halbleiter Hochspannung. Da entstehen 
intern in den im Nanometerbereich liegenden Strukturen elektrische 
Feldstärken von Megavolt pro Meter, wie sie noch nicht mal in der 
Energietechnik vorkommen. Darüber muß man sich immer im Klaren sein, 
auch wenn man nur mit 5V zu tun hat.

Autor: Elektroniker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oha, interessant.

Mir ist es neu, dass eben nur eine eingeschränkte Funktionalität 
vorhanden ist. Ich mein vielleicht liegt irgendwo anders der Fehler?!

Hatte noch nie ein IC, dass nach Überspannung nur noch "halb" 
funktionierte, weshalb mir die ganze Sache spartanisch vorkommt.


lg :)

Autor: Wilhelm F. (ferkes-willem)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Elektroniker schrieb:

>Mir ist es neu, dass eben nur eine eingeschränkte Funktionalität
>vorhanden ist. Ich mein vielleicht liegt irgendwo anders der
>Fehler?!

Hast du mal ein Ersatz-IC zum vergleichen?

Womöglich hattest du noch nicht so viel Bekanntschaft mit solchen 
Sachen. Mir sind in der Vergangenheit öfters solche Dinge begegnet. Z.B. 
ein Kollege drehte aus Versehen die Spannung am Netzteil hoch, an dem 
eine µC-Schaltung hing. µC defekt, dann bestückten sie den mit Ach und 
Krach neu. Dann ging das Ding nur sporadisch. Wahrscheinlich waren auch 
RAM und FLASH auf dem Board noch beschädigt. Am schlimmsten sind bei 
sowas sporadische Fehler, die nur ab und zu mal auftauchen, und schwer 
zu lokalisieren sind.

>Hatte noch nie ein IC, dass nach Überspannung nur noch "halb"
>funktionierte, weshalb mir die ganze Sache spartanisch vorkommt.

Ließ mal Datenblätter von Halbleiterbauteilen. Da gibt es immer eine 
Rubrik "Absolute Maximum Ratings", wo die höchst zulässigen 
Betriebsdaten stehen. Und der Hersteller schreibt darin, daß bei 
Überschreitung die einwandfreie Funktion des Bauteiles nicht mehr 
gewährleistet ist.

Welcher da von den 10 Millionen Transistoren gerade beschädigt wird, das 
kann jedesmal ein anderer sein.

Natürlich kann man auch mal gerade mit einem blauen Auge davon kommen. 
;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.