www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Mosfet Treiber TC4426 + IRF IRF3205S (Ersatz gesucht)


Autor: Marcel Meyer (marcelmeyer)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich muss mich heute leider mit einem Problem an euch wenden, wo ich mal 
einen Hinweis brauche. Ich befürchte das ich die "Lösung" gefunden habe, 
hätte die aber gerne noch einmal bestätigt.

Es geht um folgendes: Der Mosfet muss (Ohmsche) Lasten im Bereich von 
0-10A per PWM (~120Hz) Schalten, bei 12V. Soweit alles im grünen 
Bereich, bis 2A funktioniert die Schaltung wie erwartet, darüber 
verabschieden sich immer mal wieder die Treiber, bzw. die Schaltung tut 
nicht mehr das was sie sollte.

Mein Verdacht: Der Mosfet hat eine zu hohe Kapazität am Gate, die der 
Mosfettreiber nicht treiben kann. (Qgs = 35nC das macht bei 12V rund 
3000pF). Der Treiber packt laut Datenblatt 1000pF. Hier wird also der 
Teufel begraben sein, oder liege ich da falsch? Interessant finde ich, 
das bis 2A alles Tadellos funktioniert, es wird nichts warm, nur darüber 
gibt es die Probleme.

Falls ich richtig liege, brauche ich Ersatz, und zwar im D²Pak und am 
besten Pinkompatibel. Vielleicht kennt von euch ja einer einen Passenden 
Typen. (Vbr = min. 20V, Imin 10A (ungekühlt)).

Ich danke euch schon mal in voraus für die Hilfe.

Die Datenblätter habe ich direkt mit angehängt, so muss keiner Suchen ;)

Gruß
Marcel

: Verschoben durch Admin
Autor: Volker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1. Freilaufdiode über die Last
2. Der Mosfetreiber muss unbedingt mit guten Keramikondensatoren direkt 
am Versorgungspin abgeblockt werden.
3. Der Gatewiderstand erscheint mir schon recht hoch, 10 Ohm sollten 
reichen.
4. Die 12V versorgung an der Last mit guten Konnsatoren puffern 
(Elko+Keramik).
5. Möglichst kurze Verbindungen

Volker

Autor: Marcel Meyer (marcelmeyer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Volker

Volker schrieb:
> 1. Freilaufdiode über die Last

Okay, lässt sich einrichten (Typ?)

> 2. Der Mosfetreiber muss unbedingt mit guten Keramikondensatoren direkt
> am Versorgungspin abgeblockt werden.

Das oben ist nur ein Ausschnitt aus dem Schaltplan, Kondensatoren sind 
ausreichend verbaut.

> 3. Der Gatewiderstand erscheint mir schon recht hoch, 10 Ohm sollten
> reichen.

Okay, werde ich nochmal anpassen

> 4. Die 12V versorgung an der Last mit guten Konnsatoren puffern
> (Elko+Keramik).

Das ist der Fall, die Eingangsspannung ist sauber

> 5. Möglichst kurze Verbindungen

Auf der Platine sind die Leitungen alle sehr kurz (~1cm), nach dem 
Mosfet geht die Leitungslänge aber eher Richtung 5m

> Volker

Vielen Dank für deine Antwort

Autor: Volker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Auf der Platine sind die Leitungen alle sehr kurz (~1cm), nach dem
>>Mosfet geht die Leitungslänge aber eher Richtung 5m.

Und genau da liegt das Problem. Du hast dann keine ohmsch LAst mehr 
sondern bedingt durch die lange Zuleitung eine hohe Induktivität.

Folgendes sollte helfen:

1. Freilaufdiode wie schon beschrieben (z.B. MBR1545)
2. Zuleitungen zur Last verdrillen.
3. Varistor oder Transildiode direkt am Mosfet.

Fallst Du ein Oszi hast kannst ja mal die Spannung am Drain des Mosfets 
anschauen, da werden saftige Spannungsspitzen drauf sein.

Volker

Autor: Volker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch etwas:

Unbedingt, wie im Datenblatt beschrieben, den Eingang des unbenutzten 
Mosfettreiber auf GND legen.

Autor: Marcel Meyer (marcelmeyer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Volker,

die Freilaufdiode werde ich mal einplanen. Was mich halt stutzig macht, 
nicht der Mosfet stirbt, sondern die Treiber. Und diese sterben auch 
wenn man die last (Overhedprojektorlampe, ca. 1 Ohm, direkt anschließt 
d.h. Leitungslänge 2cm). Mit einem Oszilloskop habe ich mir das schon 
mal angeschaut, die von dir angesprochenen Spannungsspitzen sind nicht 
sehr ausgeprägt (100-200mV bei 2A).

Die Eingänge werde ich auf Masse legen, danke für den Hinweis.

Was sagst du denn zu den treibenden Kapazitäten? Kann das nicht auch die 
Fehlerursache sein?

Gruß
Marcel

Autor: Volker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Was sagst du denn zu den treibenden Kapazitäten? Kann das nicht auch die
>>Fehlerursache sein?
 Kann ich mir bei 120Hz nicht richtig vorstellen, Im Datenblatt steht ja 
nur, dass 1000pF in 25ns getrieben werden können. Bei Dir dauert dies eh 
länger, da Du noch einen Gatewiderstand hast.

Schon mal mit dem Oszi am Gate gemessen?

Volker

Autor: anonymous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Transil, Varistor kannst du dir sparen, hat der FET schon eingebaut (der 
ist Avalace-Fest). Bei Verwendung einer Freilaufdiode gibts sowieso 
keine spannungsspitze am FET mehr.

Bei 100Hz Schaltfrequenz würde ich den Gatewiderstand nicht verkleinern, 
da dies nur die Schaltverluste reduziert und diese bei dir durch die 
niedrige Frequenz im mW-Bereich sind. Allerdings verschlimmerst du damit 
alle anderen "Schalt-Probleme".

Freilaufdiode ist prinzipiell wichtig, aber bei deinen niedrigen 
Frequenzen nicht zwingend notwendig. (Die Automobilhersteller verwenden 
bei sehr niedrigen Schaltfrequenzen(<1Hz) nicht mal welche bei 
induktiven Lasten wie Magnetkupplungen oder Motoren sondern verheizen 
die Energie im FET)

Wie nah ist die Entkopplung deiner Versorgungsspannung an deinem FET? 
Welche Induktivität ist zwischen FET und deinen 
Kondensatoren(geschätzt)? Das wird nämlich der Übeltäter sein. Das 
Problem hatten wir nämlich erst neulich hier im Forum...-> schlechtes 
Layout.

Autor: anonymous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Treibersterben liegt am schlechten Layout in Verbindung mit der 
Gemeinsamen Spannungsversorgung Last und Treiber!

Autor: Volker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Funktioniert die Schaltung nun?

Autor: Marcel Meyer (marcelmeyer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Volker und unbekannt,

habe eure Tipps beherzigt, und die Schaltung läuft nun wie gewünscht. 
Erfolg hat schon das Trennen der Spannungsversorgung von Logik und Last 
gebracht. Die anderen Tipps habe ich dennoch beherzigt.

Vielen vielen Dank,

Gruß
Marcel

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.