www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Freilaufdioden und geschossener L298


Autor: Berman Teymur (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe eine Frage bezüglich meinen Schaltplan.
Die Schaltung funktionierte - Motor hat sich gedreht, alles bestens.
Danach raucht mir der L298 ab.
Ich kann mir nur vorstellen, dass :
1 - Die Spannungsspitzen die mein Motor erzeugt über Freilaufdioden ( 
L6210 wird verwendet - also Geschwindigkeit soll passen) zwar von den 
Ausgängen abgeleitet werden, aber mit "volle Wucht" auf Vs-Pin knallen. 
Aber warum wurde er nicht sofort geschossen, sondern nach eine Weile? 
Spannungsspitzen entstehen doch immer?


2 - bei den ersten, kurzen Test habe ich keinen Kühlkürper verwendet - 
IC wurde schon recht warm ( aber nicht heiß )so habe ich dann keinen 
angebracht , obwohl Dauer der Tests immer länger wurde :) Vielleicht 
habe ich den einfach gegrillt? Es fließen 0,6A / phase bei 15V. Also 
ohne Kühlkörper soll L298 laut schaltplan bei 1,2A*15V*35grad/Watt = 630 
grad heiß werden. Aber wie gesagt, warum dann nicht sofort, sondern nach 
eine Weile?

3. Einen unglücklichen Kurzschluss schließe ich aus - alles mehrmals 
kontrolliert und "durchgepiepst".

Ich würde gerne eure Meinungen ( begründet bitte ;) )hören.

Danke im Voraus

Teymur

Autor: Berman Teymur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oder kann das vielleicht irgendwie an meinem Umpolschutz liegen?

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Deine Leistungs/Temperaturberechnung kannst du so nicht machen, da am 
Treiber nicht 100% der Spannung abfällt. Wäre ja auch blöd, dann würde 
der Motor ja gar nicht mehr laufen.

P=I*Udrop. Also zB: 1,2A*1V = 1,2Watt.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Berman Teymur schrieb:
> Oder kann das vielleicht irgendwie an meinem Umpolschutz liegen?
Das ist eigentlich ein normaler Brückengleichrichter...
Was hängt denn da links davon dran?

Autor: Berman Teymur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Links davon hängen meine 12-15V. Blos der Stecker vom Netzteil kann 
verdreht werden - und aus Sicherheitsgründen habe ich dann diese 
Schutzmaßnahme getroffen.

Autor: byte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Dioden sind zu langsam, oder? Das müsten doch Schottky sein. 
Allgemein muss man mit dem L298 aufpassen... er reagiert auf schlechten 
Aufbau (Wackler, etc.) und falsch Dimensionierte Bauteile teilweise 
recht Mädchenhaft. :)

Autor: L298_Anwender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

was ich bei deiner Schaltung vermisse, ist ein dicker Elko an der
Versorgung des L298. Schlechte Spannung hat schon manchen Chip 
getötet...


Gruß
Ludger

Autor: byte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
byte schrieb:
> Die Dioden sind zu langsam, oder? Das müsten doch Schottky sein.

Komando zurück.. habs schlichtweg überlesen.. sind Schotten drin. Sorry

Autor: Berman Teymur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>was ich bei deiner Schaltung vermisse, ist ein dicker Elko

Sind die 470µF nicht "dick" genug?

Autor: Berman Teymur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>P=I*Udrop. Also zB: 1,2A*1V = 1,2Watt.

Danke für den Tipp :)
Kühlkörper ist also etwas überdimensioniert, aber selbst dann kann mein 
l298 knapp 90grad heiß werden(Vdrop 2-3V), also lieber doch dran lassen.

Autor: Olaf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich würde gerne eure Meinungen ( begründet bitte ;) )hören.

Du hast das Datenblatt/Applikation zum L298 nicht gelesen.
Irgendwo im Datenblatt steht naemlich das die Schutzdioden
schnell sein muessen. Des weiteren steht da noch extra der
verzweifelt deprimierte Zusatz eines frustrierten Applikations
Ingenieur das gerade die 1N400x NICHT schnell sind.

Nimm eine BYV27 und alles wird gut.

Olaf

p.s: und liess das Datenblatt bevor der arme Ing sich noch umbringt
weil die Leute weiterhin die 1N400x verwenden.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olaf schrieb:
>> Ich würde gerne eure Meinungen ( begründet bitte ;) )hören.
>
> Du hast das Datenblatt/Applikation zum L298 nicht gelesen.

Und du hast seinen Post nicht gelesen.

Autor: Berman Teymur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>1N400x NICHT schnell sind.

Für Alle - Die 1N4004 wurden NUR(!!!) im Schaltplan zur Darstellung 
verwendet! Eingebaut wurde ein L6210 !!!

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sehr sinnvoll . . .
Ein korrekten Schaltplan zeichen ist wirklich zuviel verlangt . . .

Autor: Berman Teymur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>sehr sinnvoll . . .
>Ein korrekten Schaltplan zeichen ist wirklich zuviel verlangt . . .

Ich habe den L6210 in Standartbibliotheken nicht gefunden und da Layout 
nicht benötigt wird (alles auf Lochrasterplatte) wurde das genommen was 
da war.
Wenn man sich weniger beschweren würde, das ich Datenblätter nicht lesen 
bzw. Schaltpläne nicht zeichen kann (L6210 steht im Schaltplan als Info 
übrigens auch) wären die Posts vielleicht sinnvoller.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> (alles auf Lochrasterplatte)
Zeig doch mal ein Foto vom Aufbau...

Autor: Berman Teymur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Problem wurde gefunden - Osziloskopieren hat sich gelohnt :)

Nach dem Abschalten generiert Motor Spannungsspitzen - die fließen auf 
470µF und 100nF Kondensatoren ab. Der Umpolschutz stört den 
Ladungsausgleich - es geht zwar von der Spannungsquelle "in die 
Schaltung hinein" aber nicht mehr "heraus". So laden sich die 
Kondensatoren immer mehr auf - und ab 48V ist es für den L298 Schluss :)

Nach dem herauslöten vom Umpolschutz bleibt die Spannung über 
Kondensatoren konstant.

>Zeig doch mal ein Foto vom Aufbau...

Falls erwünscht, lade ich die Fotos vom Aufbau hoch.

Autor: L298_Anwender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich kann's nicht so recht glauben....
Spannungsspitzen können zwar den Elko aufladen, ABER bei nächster
Ein-Zyklus wird die Energie sofort wieder herausgezogen.
Ich glaub nicht, das sich da etwas aufschaukeln kann.
Ween's so wäre - müsste sich der Netzteil-Elko auch immer mehr aufladen.

Gruß
Ludger

Autor: Berman Teymur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, das mag sein, dass Elko beim nächsten Ein-zyklus sich entlädt - aber 
lädt sich ja kurz danach wieder auf.
Auf jeden Fall als ich gemessen habe, war der Elko nach einschalten auf 
12V. Nach dem ersten Schritt war er gleich auf 50V und blieb dabei. 
Vielleicht ist die Ladung nicht immer hoch genug um L298 
durchzuschießen, und mein L298 Opfer eine Reihe unglückliche 
Aufladevorgänge ist?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei solchen Antrieben muss die Versorgungsspannung über dicke Z-Dioden 
begrenzt werden, die verheizen dann ggf. die überschüßige Energie.
Aber vorher muss man natürlich aussreichend dicke Elkos verwenden, Pi 
mal Daumen 1000µF/A

Mfg
Falk

Autor: Berman Teymur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Bei solchen Antrieben muss die Versorgungsspannung über dicke Z-Dioden
begrenzt werden

Kannst du bitte erklären wozu ich Versorgungsspannung begrenzen soll? 
Irgendwie komme ich nicht ganz mit, soweit ich es weiß muss ich doch 
Strom begrenzen, damit Motorwicklungen nicht durchbrennen, aber je mehr 
Spannung dem Motor zusteht, desto schneller kann er sich drehen? Meine 
Schrittmotorenkenntnisse sind lückenhaft, würde mich über Hilfe freuen 
:)

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Berman Teymur (Gast)

>>Bei solchen Antrieben muss die Versorgungsspannung über dicke Z-Dioden
>>begrenzt werden

>Kannst du bitte erklären wozu ich Versorgungsspannung begrenzen soll?

Weil der Motor Energie in deine Versorgung zurückspeisen kann. Sind dann 
die Kondensatoren zu klein bzw. kann die Energie nicht verbraucht 
werden, steigt die Spannung an deinem Kondesator an der 
Versorgungsspanung und irgendwann machts PENG!

MFG
Falk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.