www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LED´s Heizungsansteuerung


Autor: Richard Pfl. (ritsch)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag ,

Habe ein für mich nicht lösbares Problem und zwar habe ich bei meinen
Heizungsstellantrieb ein paar LED´s eingebaut um mitzukriegen was
und wann die Heizung etwas ansteuert da ich mal das Problem hatte
das ein Magnetventil hinüber war und ich das nicht so ohne weiteres
gefunden habe.

In der Ansteuerung sind Relais verbaut diese gehen jeweils auf ein
Magnetventil, Pumpe usw. alles kein Problem was aber nicht
Funktioniert ist die Anzeige beim Stellmotor weil dieser einen denke
mal Entstörkondensator hat und somit egal ob das Relais "Auf" oder "Ab"
angesteuert wird immer beide LED´s leuchten ausser der Motor
befindet sich in der Endlage, schuld ist der Kondensator das ist
mir klar ! Meine Frage ist gibt es evtl. noch einen einfachen Weg
(Dioden,Kondensator) um die Anzeige hinzubekommen oder muss
ich wenn dann auf die andere Seite des Relais (Ansteuerung)
wechseln - was ich nicht will den die ist SMD mit Schnittstelle
CAN Bus und sehr leicht zum kaputtmachen, vorallem wenn man
keinen Schaltplan hat und dadurch auch nicht weis wie das ganze
gerechnet ist.


Habe mal eine Zeichnung vom momentan verbauten Zustand hinzugefügt.

Vielleicht hat ja jemand eine Idee

Danke,
Ritsch

Das das mit den Led´s nicht optimal ist ist mir klar gibts extra 
Schaltungen mit Kondens usw., Aber ich sitz ja nicht die ganze Zeit
vor der Heizung und zur Fehlersuche langts denke ich.Falls mal
eine LED hinüber ist kostet das ja auch nicht die Welt.

Autor: controllergirl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Richard !!

Also... Mit dem gleichen Problem hatte ich auch schon mal zu kämpfen...
Aus meiner Sicht gibts deren Lösungen zwei...

1. Die Led`s statt an den Relaiskontakten an den Relaisspulen 
anschliessen - quasi parallel.
Vorteil: Das geht zum einen besser, da diese oft mit Gleichspannung aus 
der Steuerung geschaltet werden (allerdings nicht immer) und man daher 
die - bei dir im Schaltplan noch fehlenden - antiparallelen Schutzdioden 
an den LED's sparen kann.
Nachteil: Man hat logischerweise nicht den tasächlichen Zustand des 
Relaisausgangs bzw. des Motors sondern nur die Ansteuersignale der 
Relais... wenn denn mal eins hängt oder der Kontakt nicht schaltet sieht 
man das nicht... seuftz

2. Geht das nicht könnte man parallel zu den beiden Motowicklungen 
jeweils ein Relais schalten (statt der LED's in deinem Plan) mit 
ensprechender Spulenspannung...
Da die Relais zum Schalten mehr Strom ziehen als die LED's und die 
Hsterese praktischerweise eingebaut haben - und nicht mehr oder weniger 
vor sich hin leuchten - klappt das oft auch...

Öhm... dies ist übrigens meine erste Antwort auf einen Beitrag hier im 
Forum... bin halt viel unterwegs :o) ... aber da ich im Moment ein NOP's 
gedreht hatte dachte ich... also... bitte nicht treten :O)

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Richard Pfl. schrieb:
> In der Ansteuerung sind Relais verbaut diese gehen jeweils auf ein
>
> Magnetventil, Pumpe usw. alles kein Problem was aber nicht
>
> Funktioniert ist die Anzeige beim Stellmotor weil dieser einen denke
>
> mal Entstörkondensator hat und somit egal ob das Relais "Auf" oder "Ab"
>
> angesteuert wird immer beide LED´s leuchten ausser der Motor
>
> befindet sich in der Endlage, schuld ist der Kondensator das ist
>
> mir klar !


Dat iss kein Entstörkondensator.

Sondern diesen Phasenschiebe Kondensator benötigt dieser Motor, um 
überhaupt zu drehen.


Du läufst hier in das exakt identische Problem das die Boyz mit den 
Rolladenantriebsmotoren haben: Auch da läuft Parallelschaltung nicht.
Sobald die dem Motor parallelgeschaltete Last (Lampe, Relais, 2. Motor ) 
zu hoch ist, "tilt" das System.

Was die Sache wirklich korrekt und zuverlässig sauber löst: Echte 
Trennrelais kaufen und einbauen. Dann läuft der Motor wie gewünscht. Und 
am zweiten Ausgang des Trennrelais kannst Du Deine LEDs bzw. sonstiges 
anschließen.

Die Trennrelais  werden so zwischen 15 und 30 euro gehandelt.

Autor: Richard Pfl. (ritsch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tagchen,

>1. Die Led`s statt an den Relaiskontakten an den Relaisspulen
>anschliessen - quasi parallel.

Würde gehen allerdings möchte ich nicht auf diese Seite wechseln
um nicht´s kaputtzumachen :-)

>2. Geht das nicht könnte man parallel zu den beiden Motowicklungen
>jeweils ein Relais schalten (statt der LED's in deinem Plan) mit
>ensprechender Spulenspannung...
>Da die Relais zum Schalten mehr Strom ziehen als die LED's und die
>Hsterese praktischerweise eingebaut haben - und nicht mehr oder weniger
>vor sich hin leuchten - klappt das oft auch...

Auch ganz netter Ansatz werd ich mal probieren.

>Sondern diesen Phasenschiebe Kondensator benötigt dieser Motor, um
>überhaupt zu drehen.

Dachte vom Wert her weil dieser ziemlich winzig ist könnte es ein
Entstörkondensator sein (normalerweise haben die ja einige µF) 
allerdings hast Du da recht so wie der eingebaut ist sollte das ein 
Phasenschiebe Kondensator sein.
"Tilen" kann ich da llerdings nicht´s weil das keine zwei seperaten 
Motore
sind wie bei parallegeschalteten Rollomotoren.
Trennrelais würde natürlich funktionieren allerdings bau ich mir ja da 
noch mehr Fehlerquellen ein (doppelte Zahl an Relais).

Da der Kondensator im Wechselstrom einen Widerstand darstellt müsste es 
doch gehen wenn ich einfach den Wert etwas erhöhe dem Motor dürfte es 
nicht ausmachen und die eine Le´d müsste doch dann etwas dunkler 
leuchten da diese doch die Spannung über den Kondensator = Widerstand 
bekommt ?!

Danke für die Antworten,

Gruß Richard

Autor: controllergirl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebe Experten für freie und gebundene Elektronen !!! :o)

Nur eine kleine Ergänzung zu der Relaislösung: Beachten muß man dabei 
natürlich, daß es bei den Relais tausende von verschiedenen Versionen 
mit genauso verschiedenen Schalt-, Halte-, und Abschaltströmen gibt - 
bei gegebener Nennspannung... hier ist natürlich etwas Kreativität und 
Glück erforderlich.

Apropos Kreativität... mir ist noch eine kreative Möglichkeit 
eingefallen...

und zwar - ich hab's allerdings in dieser Anwendung noch nicht konkret 
getestet - könnte man die LED's auch in Reihe zu den Wicklungen 
schalten...
genau... weil...
das oder die Motörchen ziehen ja nicht allzuviel Strom (z.B. wenns vom 
Mischerantrieb ist)und wenn der - gemessener Weise - nicht über den ca. 
20 mA für eine normale LED liegt, dann kann man die auch in Reihe 
legen...

Damit das mit dem Wechselstrom dann nicht zu allergischen Reaktionen 
führt, muss dann natürlich antiparallel zu den LED's jeweils eine 
normale Diode (1N4007 oder so) ... oooder...

noch origineller wäre eine DuoLED (in der Version mit zwei Beinchen; 
z.B. rt/gn antiparallel) die dann halt quasi in analog-gelb (vgl. 
analog-käse) rumleuchten würde...

coole idee... sag' ich mal so :o)

aber... wie gesagt... das Motorströmchen müsste man dafür vorher 
messen...

und wenn der dann doch zu groß sein sollte besteht auch noch die 
Möglichkeit einen Widerstand parallel zu den Dioden zu schalten... dann 
müsste es auch mit mehr als 20 mA gehen...

puh... soweit von der "Kreativabteilung"...

viele Grüße von...

yenny :o)

Autor: Richard Pfl. (ritsch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag , gehabt ?


Ganz schön kreativ :-) Allerdings ist mir etwas zum aufsetzten lieber
wie gesagt funktionieren tut´s ja aber ist halt ein Schönheitsfehler
das beide LED´s brennen den ich halt wenn´s einfach gegangen währe
abgestellt hätte. Wenn ich LED´s und Dioden mit in den Stromkreis
vom Motörchen nehme baue ich mir nur ein paar Schwachstellen ein.:-(

Ist Ohnehin schon so ein "Graffe" was heut zu Tage alles hergestellt
und noch schlimmer teuer Verkauft wird.

Gruß Ritsch

Autor: controllergirl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Richard !!

Nun... da hst du wohl recht... mit jedem Teil mehr steigt natürlich die 
Fehlerrate...
Und... wenn's zuviele Teile werden hat man nachher mehr Rechenleistung 
am Stellantrieb als im Netbook... hmmm... das gibt zu denken :o)

Andererseits... wenn der Antrieb mal nicht fährt, merkt mann's ja 
spätestens wenn derselbe von einer dicken Eisschicht überzogen ist...

Aber egal... so schnell geben wir natürlich nicht auf... grusel

ISCH HAB NOCHNE IDEE... guggst du OO

Was wäre denn mit "magnetischer Kontaktaufnahme" ?? ... um genau zu 
sein...
In der Steuerung sind doch schon zwei Relais eingebaut - und die haben 
doch immer 'n schönes Magnetfeld (zumindest wenn Strom durchgeht... 
looogisch).
Man könnte mal nen Reedkontakt dranhalten... oder... wenns dafür nicht 
reicht einen Magnetfeldsensor... das müsste doch wunderschön klappen... 
und sogar potentialgetrennt... sehr angenehm :o)

Ist das eigentlich eine komplette Einheit ??? oder ist der Motor extern 
und mit Drähten angeschlossen ???

Ich habe übrigens - damals - in meinem Stellantrieb auch LED's 
eingebaut, weil ich an der alten Gurke nie erkennen konnte was der 
gerade macht.
Allerdings ist das auch noch ein "Röhrengerät" (der CAN-Bus wurde wohl 
100 Jahre später erfunden) bei dem die Relais ohne Probleme anzapfbar 
waren (also LED's parallel zu den Spulen).

Nun... soweit der Stand der Dinge... ich such' schon mal 'nen Kompass 
raus... frei nach dem Motto... im testen die Besten... höhö...

viele Grüsse von...

Yenny :O)

Autor: controllergirl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh Mist... jetzt isses ein Aprilscherz geworden... grummel
n8 zusammen... **

yenny :o)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.