www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Instrumentenverstärker mit LM358


Autor: Mark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe einen Instrumentenverstärker mit dem LM358, wie im Artikel 
http://www.mikrocontroller.net/articles/Operations... 
beschrieben, aufgebaut. Der LM358 wird mit 5V versorgt.
Alle Widerstände haben den Wert von 10k Ohm. UE1 ist eine 
Referenzquelle, die 2,5 V liefert. UE2 ist ein Temperatursensor, der bei 
Raumtemperatur 3V liefert. Nach der Formel ergibt sich eine 
Ausgangsspannung von 1,5 V bei Raumptemperatur. Das konnte ich auch mit 
einer Simulation in LTSpice verifizieren. Bei steigender Temperatur ist 
auch die Ausgangsspannung gestiegen.
Die Schaltung habe ich dann auf einen Steckbrett aufgebaut, allerdings 
bekomme ich am Ausgang nur 0,7 V und ein erwärmen des Sensors führt zu 
keiner Änderung der Ausgangspannung, obwohl sich die Ausgangsspannung 
des Temperatursensors erhöht.
Die Referenzspannungsquelle liefert auch 2,5 V. Was mache ich falsch?

Vielen Dank im Voraus
Mark

Autor: Flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Steckfehler?
Meine Glaskugel ist leider so staubig, dass ich den Aufbau nicht scharf 
sehe...
;-) Wie wärs mit nem Bildle?

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du den Aufbau mindestens dreimal überprüft? Sind die Verdrahtung,
die Widerstandswerte und die Versorgungsspannnung wirklich korrekt?

Wenn das alles stimmt, wäre der eher unwahrscheinliche Fall eingetreten,
dass das IC kaputt ist.

Miss doch mal die Spannungen an allen Ein- und Ausgängen der OpAmps
(also 9 Messungen) und poste sie hier. Damit kann man die Fehlerquelle
evtl. lokalisieren.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Mark,

Welche Verstärkung hast du gewählt?

Als "Spannungsdifferenz*Verstärkung" darf nicht weniger als 0,7V 
herauskommen, weil der Opamp LM358 keine niedrigere Spannung ausgeben 
kann, da du ihn ohne negative Versorgungsspannung betreibst.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ue1 und Ue2 vertauscht? Was ist das für ein Temperatursensor? Wie hast 
du den angeschlossen?

Kai Klaas

Autor: hakuspakus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der LM358 wird mit 5V versorgt
das ist wohl der Fehler !

....sollte +/- 5V sein.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Der LM358 wird mit 5V versorgt das ist wohl der Fehler !

Wieso? Er bewegt sich doch im erlaubten Eingangs- und 
Ausgangsspannungsbereich, wenn er alles richtig gemacht hat.

Kai Klaas

Autor: Mark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hatte in der Tat einen Fehler in der Verdrahtung. Bei einen OPV war 
invertierenden / nichtinvertierenden Eingang vertauscht. Ist mir trotz 
Überprüfen der Steckverbindungen nicht aufgefallen. Jetzt funktioniert 
es. Vielen Dank.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Jetzt funktioniert es.

Nicht wirklich.

Ein LM358 kommt bei 5V Versorgungsspannung kaum
über 3.5V Ausgangsspannung, und bei deiner
Schaltung des Instrumentenverstärkers entstehen
intern solche Spannungen.

Dein Messbereich ist also stark eingeschränkt.

Trenne dich von diesem 30 Jahre alten OpAmp,
dessen einziger Grund ihn heute zu kaufen sein
kann, dass er der billigste, der allerbilligste
ist den man kriegen kann, und gönn dir einen
Rail-To-Rail OpAmp wie TS912.

Dann klappt das auch mit dem Messbereich.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Trenne dich von diesem 30 Jahre alten OpAmp,
>dessen einziger Grund ihn heute zu kaufen sein
>kann, dass er der billigste, der allerbilligste
>ist den man kriegen kann, und gönn dir einen
>Rail-To-Rail OpAmp wie TS912.

Und die aufwändige Instrumentenverstärker-Schaltung braucht man in der 
Regel auch nicht...

Kai Klaas

Autor: Yalu X. (yalu) (Moderator)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
> Und die aufwändige Instrumentenverstärker-Schaltung braucht man in der
> Regel auch nicht...

Genau. So etwas im Anhang tut's für deine Anwendung wahrscheinlich
genauso gut. Der nutzbare Eingangsspannungsbereich ist sogar noch ein
gutes halbes Volt größer als bei deiner Instrumentenverstärkerschaltung.
Mit einem Rail-to-Rail-OpAmp lässt sich aber natürlich auch hier noch
einiges herausholen.

Als Referenzspannung für den Offset von 2,5V wird hier die 5V-Versorgung
herangezogen.

Autor: Mark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mein Controller läuft mit 3,3V. Daher stört es mich auch nicht, dass der 
LM358 nur bis 3,5 V geht. Die 5 V für die Versorgung sind sowie 
verfügbar. Der Temperaturbereich entspricht einer Spannung von 2,5 - 3,4 
V am Temperatursensor.
Andere Schaltungen habe ich auch getestet, hätte dafür aber, soweit ich 
mich erinnern kann, zusätzlich noch Impedanzwandler benötigt, der 
Schaltungsaufwand war also in etwa der selbe.
Den TS912 werde ich mir besorgen, danke für den Hinweis.

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mark schrieb:
> mein Controller läuft mit 3,3V. Daher stört es mich auch nicht, dass
> der LM358 nur bis 3,5 V geht.

Aber Vorsicht: Die 3,5V-Grenze gilt nicht nur für den rechten, sondern
auch für die beiden linken OpAmps.

> Der Temperaturbereich entspricht einer Spannung von 2,5 - 3,4 V am
> Temperatursensor.

Bei 3,4V Eingangsspannung müsste der OpAmp links unten 2·3,4V-2,5V=4,3V
liefern, was er aber nicht kann. Die obere Eingangsspannungsgrenze liegt
bei (3,5V+2,5V)/2=3V. Mit dem TS912 kannst du diese Grenze auf knapp
(5V+2,5V)/2=3,75V anheben, was deutlich über 3,4V liegt. Für die Instru-
mentenverstärkerschaltung solltest du also schon den TS912 bzw. den
TS914 (vierfach) nehmen.

Die Schaltung aus meinem letzten Beitrag verhält sich diesbezüglich
etwas besser: Mit dem LM358 reicht der Eingangsspannungsbereich bis
3,5V/3+2,5V=3,67V¹, mit dem TS912 sogar bis knapp 5V/3+2,5V=4,17V.

¹) Hier sollte man besser von 3,5V ausgehen, da dies lt. Datenblatt das
   obere Ende des Eingangsspannungsbereichs des LM358 ist.

Autor: Mark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Yalu,

vielen Dank, ich habe mir deine Schaltung genauer angesehen und auch 
durchgerechnet. Die Schaltung hat mich überzeugt und ich werde diese 
auch, mit ein bisschen veränderten Widerstandswerten, verweden. Da spare 
ich mir doch einige Widerstände und sogar einen OPV, da ich das ganze 
zweimal benötige.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die Schaltung hat mich überzeugt und ich werde diese auch, mit ein >bisschen 
veränderten Widerstandswerten, verweden.

Yalu weiß auch nicht, welchen Temperatursensor du einsetzt...

Kai Klaas

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
> Yalu weiß auch nicht, welchen Temperatursensor du einsetzt...

Das ist richtig. Aber ist das wichtig?

Nachdem die Instrumentenverstärkerschaltung mit dem LM358 zu Marks
Zufriedenheit funktioniert hat

> Jetzt funktioniert es. Vielen Dank.

und auch die Eingangs- und Ausgangsspannungsbereiche LM358-konform sind

> mein Controller läuft mit 3,3V. Daher stört es mich auch nicht, dass
> der LM358 nur bis 3,5 V geht. Die 5 V für die Versorgung sind sowie
> verfügbar. Der Temperaturbereich entspricht einer Spannung von 2,5 -
> 3,4 V am Temperatursensor.

sollte man eigentlich davon ausgehen können, dass die von mir gepostete
Schaltung ebenfalls die Anforderungen erfüllt. Natürlich ist der LM358
nicht ultrapräzise. Wenn aber eine hohe Messgenauigkeit für Mark wichtig
wäre, hätte sicher schon entsprechende Untersuchungen durchgeführt und
festgestellt, dass auch die Instrumentenverstärkerschaltung einen
messbaren Fehler hat.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.