www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR Studio - "A problem occured when executing the command"


Autor: Alkan S. (alkan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo alle zusammen!
Also ich beschäftige mich erst noch neu mit Microcontrollern und habe
schon das erste Problem bei der Programmierung des ATiny 2313 :(
Zuerstmal habe ich meine Schaltung folgendermaßen 
http://blazer21.bl.funpic.de/avr/schaltungen.htm  aufgebaut.
Dann habe ich mir noch den Diamex 
DX-ISP(http://www.srt-versand.de/index.php?sid=1bf2959df3...) 
Programmieradapter gekauft ,
alles angeschlossen und mehrmals überprüft.
Nun ist das Problem das im AVR-Studio immer folgende Fehlermeldung 
erscheint:
"A problem occured when executing the command"
und "Entering programming mode.. FAILED!"
Ich weiß einfach nicht woran es liegt.
Jetzt habe ich 4-leds an folgende 4-Pins des 10-poligen ISP-Steckers 
gesteckt...:
MOSI; RESET; SCK; MISO
...und folgendes ist passiert:
- RESET leuchtet die ganze Zeit und die anderen sind aus
- Wenn ich im AVR-Studio Connecten will dann:
  1. RESET geht aus
  2. MOSI geht an und wieder aus
  3. MISO geht an und wieder aus
  4. SCK geht an und wieder aus
  5. RESET geht an
- Die vorhin erwähnte Fehlermeldung erscheint
Soweit ich weiß ist das so OK aber das Programmieren funktioniert eben 
nicht!
Achja und ich ziehe den Strom von dem Programmiergerät, was ich 
natürlich aud 5V schalte.
Vorher habe ich es vom Netzteil gezogen da hat es aber auch nicht 
funktioniert.
Oh und der Programmier-Adapter wird auch im Geräte-Manager angezeigt.
Ich hoffe ihr könnt mir weiterhelfen. ;)

MfG
Alkan

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Jetzt habe ich 4-leds an folgende 4-Pins des 10-poligen ISP-Steckers
>gesteckt...:

Die machst du da ganz schnell mal wieder weg.

>Achja und ich ziehe den Strom von dem Programmiergerät, was ich
>natürlich aud 5V schalte.

Fehler Nummer1. Lass nicht das Programmiergerät deine Schaltung 
versorgen.

>Dann habe ich mir noch den Diamex
>DX-ISP(http://www.srt-versand.de/index.php?sid=1bf2959df3...)
>Programmieradapter gekauft ,

Selber Schuld;)
Tja, ein AVRISP MKII hätte es wohl auch getan.
Robust und seinen Preis wert.

Autor: Alkan S. (alkan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
JUHUUU...,ES HAT GEKLSAPPPT!!!!!!!
Es lag nur am microcntroller dessen pins nicht ganz mit dem Steckbrett 
verbunden war .^^
Nun habe ich es gesockelt und es klappt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.