www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Mega8515 abgefuse t ...


Autor: spatz2222 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

was stellt man meim Mega ein für einen extern. Quarz ?

ich habe auf ext. Low Freq. Xtal oder so ähnlich eingestellt und nun
geht nichts mehr ...

auch nicht mit extern. Oszillator nicht mit 10Hz und nicht mit 1Khz und
auch nicht mit 1Mhz ist der µC ein Fall für dne Müll Eimer ????


Gruß Tobias

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
du brauchst wohl einen quarz, keinen oszillator zum wiederbeleben

Autor: spatz2222 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
tja - das habe ich mir auch schon gedacht - jedoch ohne erfolg ...
ich habe ein Crystal Osz. mit 455Khz ein richtiger Quarz mit 2Mhz u.
mit 4Mhz probiert komisch !


Gruß Tobias

Autor: Heinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie hast du den denn beschaltet ?
Ich habe mal bei einem MEGA8 falsche Fusebits gesetzt und konnte den
wiederbeleben, indem ich einfach einen 4MHz Quarz zwischen XTAL1 und
XTAL2 gehalten habe (einfach lose drangehalten) und währenddessen die
Fusebits neu geschrieben habe.

Autor: spatz2222 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich habe ein 4Mhz Quarz drannglötet - natürlich  mit den Kond. 39pf oder
so ... es geht nichts mehr !

Autor: Phip (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Komisch, ich hab' das gleiche Problem. Bei mir geht ebenfalls nix,
allerdings hab' ich hier noch überhaupt nie ein Verbindung
hingekriegt... Weder das AVR-Studio, noch PonyProg oder yaap hat ihn
erkannt. Die Platte hab' ich nach dem Schema im Tutorial aufgebaut,
nur mit den angepassten Pins. Als Programmer verwende ich den
vorgeschlagenen ISP ( http://rumil.de/hardware/avrisp.html ). Der
einzige Unterschied ist der Quarz; ich hab' keinen Oszillator drin,
sondern einen normalen Quarz mit einer entsprechenden Schaltung (zwei
Rs, ein C und ein Inverter). Ein Clock-Signal hab' ich aber.

Woran kann es liegen, dass der keine Antwort gibt?

Danke schonmal!

PS: Wenn ich zu connecten versuche, dann tut sich zwar etwas beim MISO,
allerdings nur etwa 1V Unterschied, was der PC wohl nicht erkennt...

Autor: Walter B (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
STK500 benutzen.

Autor: Phip (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm...
So wie ich das sehe ist es da mit zwei bis drei Euro aber net getan,
wie?

Autor: spatz2222 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja ich denke auch das STK500 ist vielleicht für Hobby - Ánwendung etwas
übertrieben ober ???
wenn es auch mit ein paar Strippen geht...

jetzt benutze ich ein ISP Dongle ohne IC nur mit ein paar Strippen vom
LPT1 an den µC - sollte man es mal mit dem 74HC244 probieren - könnte
das Erfolg verpsrechen ?


Jedoch bevor ich diese unglücklichen Fuse - Bits gesetzt habe ging es
auch ohne den 74HC244 ...

Autor: spatz2222 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ach ja noch eine Frage - ich habe ja Eingestellt LOW Freq. Xtal oder so
ähnlich. Jetzt habe ich mir ein 32,... Khz Quarz besorgt - was sollte
man da für Kond. gegen GND nehmen ? Bei 16Mhz habe ich 22pF drinn -
habe aber für 32Khz nichts gefunden

Autor: Phip (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, mein Prob hat sich erledigt. Es lag weder an meiner Schaltung noch
am MC. Auf dem Programmer hatte's 'ne Brücke :$

Danke trotzdem!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.